Jump to content











Photo

requirements for RNDIS system file adds?

need to add rndis sys files

  • Please log in to reply
5 replies to this topic

#1 thefuse

thefuse

    Member

  • Members
  • 33 posts
  •  
    Australia

Posted 31 December 2015 - 01:21 AM

HI guys!..I need help to make my Mobile usb internet stick to install and run in my win8pese.

iv been building winPE of many flavours for years but this has me stuck

i have tried or investigated the following

1.adding rndis package hotfix for rndis from microsoft..installing it diring build(apparently rndis is not supported in PE3.0 and higher however the hotfix during the build fixes this issue).

2.plugging in the stick and using the PnPutil all/net/force install etc.

3.adding system files for rndis with Additional files script to be sure they are in the build

I can get the system to "see" the rndis device in device manager,however when i try to install the corect driver from the driver folder in the sticks setup files..the driver fails with a"filter driver was not specified".

I believe the inf files and sys files for windows 8 rndis are a newer version and must be signed as windows8 is apparently very touchy about unsigned drivers.

The rndis device (mobile internet stick) works fine(installs and runs)on regular win7 and win8 machines no problem.

through trial and error i believe that it is a matter of adding ALL required system files as some may be missed during build(iv tried full file copy also when building)..

it is worth noting that i have had success in win7PE to get it all happening ok ...though win8PE has really had me scratching my head...

S0 my question to all members is.....rndis in win8PE.....is there a script anyone would like to share or can some very knoledgeable person let me know which system files to add/ process to get RNDIS devices going in WIn8PE?

i would be a very very grateful man.....thank you for any help you may give...the fuse..

 



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 31 December 2015 - 09:42 AM

I am not sure to understand. :unsure:

Isn't RNDIS a "standard" package that can be added to the "standard" PE made from WAIK/ADK?

https://technet.micr...y/hh824926.aspx

 

Or, if you prefer, if you set temporarily aside the Win8PE and make a PE according to MS instuctions/methods, can you have your RNDIS device working?

 

:duff:

Wonko



#3 thefuse

thefuse

    Member

  • Members
  • 33 posts
  •  
    Australia

Posted 01 January 2016 - 10:49 PM

greetings wonko...

sadly no...rndis is NOT supported in  MS PE3.0 and later.(according to microsoft)....this has also been my experience..there is a hotfix .msu package available from MS which i have installed into my win7PESE with package installer script with success during the build...its a little "clunky" as device manager mostly lists the device as not working correctly however it actually works when the device is  inserted and reinserted a few times.

I have tried to capture the install on a regular windows8 system to duplicate all file changes and registry settings.and have double checked at length to be sure the same changes took place in my win8PE build....to no avail.Its worth noting that i have used standard/medium and full file copy settings during the build to ensure all files are transfered into my win8PE.iso....in summarywhat i can achieve is this(WIN8PE)

1.the device will install when inserted and all files/registry settings install correctly.

2.the device will show up as an RNDIS device in device manager

then my problem starts....

When i chose the device in device manager then attempt to install the drivers for the device...it fails to load the driver(which installs correctly on any regular win7/win8 system....)....with a short explanation that the .inf file doesnt indicate a  "filter driver"'.

to add to my confusion,my long research into RNDIS has discovered that RNDIS is quite complicated in its different structures for different versions of windows....Windows8 and 10 have very different inf and sys files/version numbers...

I have tried also using different inf files(win8 specific) in the driver files supplied with the device... and also a few other things...like making coffee.....banging my head on the desk...having a mini meltdown  etc.

im no expert,but i have been building with winbuilder for many years now..and have built many things in many variants of win pe.theres nothing i cant do if i work at it...

I can make it work in Win7PE...just...but my challenge here is win8PE....

my thoughts are that im missing a specific file or two in the build somehow...but cannot find a full list of files/dependant modules/services required by researching the problem...iv learned a whole lot about something that should be a no brainer...any help or ideas at this point would be much appreciated with many thanks!.....thefuse..

P.S.....i have read the article you suggested above during my research before..went through the process only to find the same issue(with the hotfix  i found at MS it works in PE7...but not win8PE)...as best as i can understand the issue is with a dependancy OR that windows 8 is VERY picky about unsigned drivers and version numbers)...

I downloaded MS official RNDIS .inf driver template for developers...it is VERY similliar to other ones for vista/7.and i read that windows implementation of RNDIS is supposed to be standardized so developers have just one driver for all uses...however in practice it appears that each version of windows has a different inf/sys files....im still swimming here...but cannot find the shore....any direction you can give me here would be very handy...tnx much.


Edited by thefuse, 01 January 2016 - 11:12 PM.


#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 January 2016 - 08:34 AM

I don't get it. :unsure:

The given MS article explicitly says that there exists a package that can be added to a default Windows PE (built per MS method from WAIK/ADK) boot.wim, specifically for 8/8.1 based PE's.

Now this may either be accurate or a big, fat, lie. :w00t: :ph34r:

To verify this you need to build a PE with the MS method and check yourself, for all we (I :ermm: ) know *something else* in either Win7PE or Win8PE (or any other non original MS project) may be conflicting or missing.

It is also possible that the specific hardware you are using is involved in the issue (but it is less likely IMHO).

If someone makes a statement like "A+B=C" you need to verify that statement by summing A and B, not trying to sum D and E to see if you can get C as result as well.

:duff:
Wonko



#5 thefuse

thefuse

    Member

  • Members
  • 33 posts
  •  
    Australia

Posted 06 January 2016 - 06:01 AM

thank you wonko

i have gone back a few steps to retrace my steps...to(as you say),not adding D to E.....

hardware,more specifically was the issue...RNDIS works a charm in win8PE for me now.

                                                    Thank you for the help :cheerleader:



#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 January 2016 - 02:04 PM

thank you wonko
i have gone back a few steps to retrace my steps...to(as you say),not adding D to E.....
hardware,more specifically was the issue...RNDIS works a charm in win8PE for me now.
                                                    Thank you for the help :cheerleader:

Happy all is well :).

:duff:
Wonko




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users