Jump to content











Photo
- - - - -

Bug building win7pese step 4/57 Retrieve Tools


  • Please log in to reply
5 replies to this topic

#1 Oskiator

Oskiator
  • Members
  • 2 posts
  •  
    Switzerland

Posted 29 November 2015 - 11:44 AM

Hi everyone,
I'm trying to do a windwos 7 live USB disk with Winbuilder 082, following this tutorial : http://www.irongeek....7pe-se-tutorial

But when I launch the process I get an error at step 4/57 with the script Retrieve Tools (00-retrieve.script).
The message of the error is "GetWaikTools script required to download Waik/ADK Tools !!!"

What can I do to fix that ?

Thank you in advance and have a nice day ;)
Oskiator

Edited by Oskiator, 29 November 2015 - 11:44 AM.


#2 Sleepy

Sleepy
  • Members
  • 2 posts
  •  
    Germany

Posted 29 November 2015 - 01:36 PM

Hi,

 

bin gestern in den gleichen Fehler gelaufen, liegt wohl daran daß das Windows automated installation Kit (WaiK) für Windows 7 nichtmehr verfügbar ist, woraus diese Datein extrahiert werden. Leider ist die Fehlermeldung mehr als dürftig...

 

Habe das Problem dann dadurch gelöst das ich ein Win8.1 Projekt gemacht habe und dort funktioniert der WaiK Download noch. Anschließend habe ich die Entsprechenden Dateien ins Win7PeSe kopiert (Projects\Tools\Win7PESE\x86) und in "Projects\Win7PESE\Build\00-retrieve.script" die Zeilen 68 & 69 auskommentiert, damit nicht versucht wird das Waik zu runterzuladen. Nach dem Kopieren musste ich noch "Projects\Tools\Win7PESE\x86\wimgapi.dll" in "Projects\Tools\Win7PESE\x86\wimgapi6.2.dll" umbenennen/kopieren.

 

Wird sicherlich bessere Möglichkeiten geben das zu lösen nur anscheinend hat keiner Bock überhaupt noch an Win7PESE zu arbeiten...

 



#3 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13643 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 29 November 2015 - 01:39 PM

GetWaikTools is a tool to grab the Waik/ADK tools (if they are not already available, they correspond to the note on the tutorial you followed:

These next notes you can largely be ignore unless you have problems: For whatever reason, when I use Win 7 32bit as my build platform, the Retrieve Tools or preconfigure scripts seem to just find bcdedit.exe without my intervention, but if I’m building on a 64bit system I have to copy bcdedit.exe manually into tools. Also, many instructions out there seem to indicate you have to copy these files:

imagex.exe
wimgapi.dll
wimmount.inf
wimmount.sys
wimserv.exe

from

C:\Program Files\Windows AIK\Tools\amd64\
to
C:\bootfun\WinBuilder\Projects\Tools\Win7PE_SE\x64
or
C:\bootfun\WinBuilder\Projects\Tools\Win7PE_SE\x86

depending on build platform. Copying them manually seemed unnecessary for me, some pre-configure script grabbed them for me automatically when I did my first build as long as I had WAIK installed. Your mileage may vary, so check with the Reboot.pro forum’s build instructions if you have issues as I can’t really troubleshoot for you remotely.


Can't say specifically on Win7PE_SE, but basically you are missing some needed files, you should be able to get around the issue getting the files manually and putting them in the folder according to the tutorial.
GetWaikTools you can get from here:
http://www.msfn.org/...-the-huge-isos/

Make sure to use the Waik/ADK files for Windows 7 (and not the ones for 8 or 8.1/later).

:duff:
Wonko

#4 Sleepy

Sleepy
  • Members
  • 2 posts
  •  
    Germany

Posted 29 November 2015 - 01:58 PM

Achja, das im Beitrag über diesem verlinkte Tool funktioniert übrigens auch nicht, hatte es ebenfalls versucht.

 

Ansonsten kannst Du Dir die benötigten Dateien selber anschauen, stehen in Projects\Win7PESE\Build\00-retrieve.script in den Zeilen 136 bis 156 und die selber aus dem ISO rausholen: https://download.mic...D/KB3AIK_DE.iso

 

Echt schon lächerlich was für Aufwand getrieben wird um nur die 1,6GB nicht runterladen zu müssen...



#5 Oskiator

Oskiator
  • Members
  • 2 posts
  •  
    Switzerland

Posted 29 November 2015 - 02:43 PM

Thanks for your answers.

I tried to get the files with "GetWaikTools" and from the iso too, but I'm still stuck with the same error. I think I will retry an other moment and restart from the beginning. Enough for today. :)



#6 sarki

sarki
  • Members
  • 1 posts
  •  
    Switzerland

Posted 03 December 2015 - 02:33 AM

Hello,

Unfortunately, I have the same problem, I also download files with "GetWaikTools" and have put in the specified folder by the tutorial but without success.
I am also interested in a solution :)

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users