Jump to content











Photo
- - - - -

Grub4dos Freedos emm386 (fd1)

freedos grub4dos cdrom emm386

  • Please log in to reply
2 replies to this topic

#1 betrand

betrand

    Frequent Member

  • Advanced user
  • 467 posts
  •  
    France

Posted 05 November 2015 - 01:49 PM

Hi,

I am having a prob with emm386.exe and a grub4dos memory mapped additional (fd1).

Freedos boots from memory mapped (fd0).

 

If without emm386.exe, just Himemx.exe, b:\ is seen.

If with emm386.exe, a:\>dir b:, reboots.

 

My menu.lst

 

title map freedos (fd0), image (fd1)
map --mem /freedos.ima (fd0)
map --hook
map --mem /image.ima.gz (fd1)
map --hook
root (fd0)
chainloader (fd0)/kernel.sys
boot
 
My fdconfig.sys
 
;!SWITCHES=/E
!SWITCHES=/N
MENU 0. FreeDOS Himemx Xgcdrom
MENU 1. FreeDOS emm386.exe
 
01?!DEVICE=himemx.EXE  /TESTMEM:off
0?!DEVICE=Emm386.exe
0?!DEVICE=aspi.sys
0?!install=doslfn.com
0?!DEVICE=xgcdrom.sys /D:cdr
0?!install=shsucdx.exe /d:?cdr,o
 
!DOSDATA=UMB
!DOS=HIGH,UMB
!FILES=20
!BUFFERS=20
!LASTDRIVE=z
!shell=a:\COMMAND.COM
 
What would a better way be?
 
 
Other issue, unrelated, 
 

Loading of aspi.sys for Cdrtools from http://sobek.su/Docs/bcdw/index_e.htm .

(Atapi version) during fdconfig.sys boot, on a Cdrom-less notebook.

I want to keep the cdrom menu-item available (rather than have another menu item), and ignored by the system if no CDrom drive present. XGcdrom does that (maybe helped by shsucdx.exe with the ? driver option (ignore if not present).

Aspi.sys just crashes (invalid opcode if I remember correctly) on loading.

 

Any ideas?

 

Thanks



#2 tinybit

tinybit

    Gold Member

  • Developer
  • 1052 posts
  •  
    China

Posted 05 November 2015 - 03:55 PM

Try using MS emm386 instead.

 

The freedos emm386 is rather buggy.

 

You may also try the MS himem.



#3 betrand

betrand

    Frequent Member

  • Advanced user
  • 467 posts
  •  
    France

Posted 07 November 2015 - 04:17 PM

Thank you Tinybit.

Yes, I remember reading a whole page comparing different emm386s.

 

About the aspi.sys question, having

0?DEVICE=aspi.sys

and pressing F8 at menu does the trick.

 

I would like to have the SINGLESTEPPING option always on, rather than pressing F8.

I haven't read anything like SINGLESTEPPING=ON or /Y anywhere.

 

 

Thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users