Jump to content











Photo
- - - - -

grub4dos and gpt vhd...


  • Please log in to reply
3 replies to this topic

#1 sixcentgeorge

sixcentgeorge

    Frequent Member

  • Advanced user
  • 191 posts
  •  
    France

Posted 22 October 2015 - 07:34 AM

these days i am making some vhds for my computers , yesterday i tested one that i turned into the gpt format and got the following error with latest grub4dos 4.6

 

grub4dosgpt.jpg

 

 

i also tested the same vhd but not gpt and it booted perfectly .

with disk of 8 Go the gpt transformation has needed 5 to 20 Mo



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15073 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 22 October 2015 - 07:49 AM

Well, add the appropriate --heads= and --sectors-per-track= parameters and try again.

 

:duff:

Wonko



#3 sixcentgeorge

sixcentgeorge

    Frequent Member

  • Advanced user
  • 191 posts
  •  
    France

Posted 22 October 2015 - 06:07 PM

i have no idea if that is the right solution...

gpt format is not yet supported by grub4dos .., i keep the file for testing some beta



#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15073 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 22 October 2015 - 08:21 PM

i have no idea if that is the right solution...

gpt format is not yet supported by grub4dos .., i keep the file for testing some beta

The GPT format is supported alright in recent versions, see:

http://reboot.pro/to...in-bios-to-gpt/

 

The issue you are having is connected with the map command, it normally auto-detects some needed parameters, but when it doesn't you can provide them.

 

How difficult would be to try issuing (say):

map --mem --heads=255 --sectors-per-track=63 /smicrow8gpt.vhd (hd0)

 

and see what happens? :dubbio:

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users