Jump to content











Photo
- - - - -

GRUB2 hangs on blinking cursor after selecting Fedora boot entry.....


  • Please log in to reply
No replies to this topic

#1 Wonko the Insane

Wonko the Insane

    Frequent Member

  • Advanced user
  • 498 posts
  • Location:The Inside of the Asylum (gate is wide open)
  • Interests:Oh, so you hate me too? Well, join the club! There are weekly meetings at the corner of Fuck You St. and Kiss My Ass Blvd.

Posted 19 October 2015 - 09:31 AM

I have 2 disks in my laptop, primary is MBR-formatted and has Win7 and Fedora installed. 2nd disk is GPT with 6 partitions, data only, no bootable OSes. Grub booted all menu entries fine until I encrypted Windows. Upon reboot I get a password request, which then chainloads Grub and its' menu loads with 7 and Fedora entries. 7's entry loads fine and boots. Selecting Fedora just hangs on a blinking cursor, no messages or errors at all. If I remove encryption for Windows, both 7 and Fedora load normally again.

 

So at first glance it would *seem* that encryption is the issue, BAM, issue solved. But why should Fedora's Grub care about Windows encryption when it's not even the OS requested to load? I believe Fedora's Grub is at fault. I say this because I have dualbooted 7 alongside Mint, Kali, and Arch, this behavior never happens when the Grub they install is in the MBR. I also have never encountered this behavior from Grub while encrypted and UEFI booting. I figured MBR for booting 2 OSes and GPT for a few data partitions should be simple enough, but apparently not. Messing around with UEFI DUET, futilely failing to figure out how to install Clover, etc brought about UEFI-specific issues, which can be worked around, but got aggravating.

 

Does anyone have any idea what might be causing this and how to rectify it?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users