Jump to content











Photo
- - - - -

How disable IDE controller (Secondary Master) in MS VPC 2007?


  • Please log in to reply
2 replies to this topic

#1 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 215 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 05 October 2015 - 04:40 PM

Some time ago I wrote something about MS VPC 2007:

For testing I use a MS VPC 2007 virtual machine but this machine have no possible remove CD-ROM drive in settings. Now I tried VMware Workstation 8 - this one allows remove CD-ROM drive in settings :-)

Today I found a solution how to disable the CD-ROM device (IDE controller). You have to enter incorrect absolute string in the IDE controller ID 1, location 0 in the file .vmc eg. a few small letters. In the example I used the word "dummy" and close tag </absolute>:

<ide_controller id="1">
    <location id="0">
        <drive_type type="integer">2</drive_type>
        <pathname>
            <absolute type="string">dummy</absolute>
            <relative type="string" />
        </pathname>
    </location>
</ide_controller>

Comparison of the presence of CD-ROM:

 

CMOS (device list and boot order):

no_cd_cmos1.png cd_cmos1.png

no_cd_cmos2.png cd_cmos2.png

 

GRUB4DOS (cdrom --init):

no_cd_grub4dos.png cd_grub4dos.png

 

WInXP x86 (My computer, Device Manager and Disk management):

no_cd_winxp.png cd_winxp.png

 

Now, after choosing the menu: CD -> Capture ISO Image... no display window Select CD Image to Capture.

 

Tested in MS VirtualPC 2007 for x64 version 6.0.192.0

Please test other version MS VPC and report.
Thx.



#2 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 215 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 28 April 2016 - 02:13 PM

If you edit a .vmc file while stored in the NVRAM settings for Secondary Master Channel you may receive an error:
Secondary Channel (0) Drive - ATAPI Incompatible
Press F1 to Run SETUP
Press F2 to load default values and continue
You have to press F2 to load default settings.

#3 ppgrainbow

ppgrainbow

    Member

  • Members
  • 31 posts

Posted 08 May 2016 - 02:20 AM

Good work on how finding out a way how to disable the CD-ROM in the secondary master IDE controller!

 

All of my VMs (MS-DOS 3.3, Windows 3.0 and Windows 3.1) with just 4 MB of memory eventually don't need to have CD-ROM support at all.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users