Jump to content

- - - - -

WINPE UEFI and DPI Setings

winpe uefi dpi

  • Please log in to reply
2 replies to this topic

#1 andyle2k

  • Members
  • 2 posts

Posted 19 August 2015 - 05:43 AM

Hi All,


I have a huge problem with WINPE booting in UEFI (x64) mode and the auto DPI scaling it performs.


I've tried setting up an Unattend.xml with the DPI settings but with the DPI element included, the whole XML is ignored. As soon as I remove the DPI setting the XML works fine.


Another approach I've tried is using the startnet.cmd to set the registry for FontDPI to 96 but that doesn't fix it either.


Does anybody know how to fix this or disable the DPI scaling altogether for WINPE? To be clear this is in WINPE not OOBE.


Booting the WINPE in x86 BIOS mode does not trigger the auto DPI scale.


Thank you very much.

#2 Tripredacus


    Frequent Member

  • Expert
  • 234 posts
  • Interests:K-Mart-ian Legend
    United States

Posted 19 August 2015 - 04:42 PM

I see you cross-posted this. WinPE4+ when booted in UEFI mode, if the hardware supports GOP, it will use the native resolution of the display. This is by design and at this time I am not aware of any way to disable this.

#3 andyle2k

  • Members
  • 2 posts

Posted 19 August 2015 - 09:59 PM

Thank you for taking the time to reply on both boards.


Really no way around this hey? Even MS' own setup looks like trash.


Why is there a Technet article on setting DPI if it doesn't actually works? Or does this only work on OOBE and real Windows?




Thanks again.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users