Jump to content

- - - - -

very weird behaviour in Windows 7 x64 setup running in UEFI mode

  • Please log in to reply
No replies to this topic

#1 icefapper

  • Members
  • 1 posts

Posted 15 August 2015 - 11:40 AM

hi all

first accept my sincere apologies as this is going to be a rather long tale, and even though i've tried my best to be as exact as possible, .i might have still made mistakes out of my newbieishness.

i've got a sve151***** notebook with w8 preinstalled; contrary to what many say, i actually like the user experience of w8, but to me at least, it is still so unstable that has made me consider installng a w7 alongside it, i.e, have both on the same dsk. 


i've been told by many that it's not possible to have them both on a gpt dsk in uefi mode, but the retail w7 img i own has an option for making a bootable stick in uefi mode; so i grabbed Rufus and whoa! i had a bootable stick and i began installing w7 on a gpt partitoin i had prepard for the exactly same purpose;


 then it all began.


things were all going ok until i reached the dreaded "Startng Windows"; no matter how much i tried, i was not blessed enough to get past it.


but things were much more strange than they lookd to be: the logo had a "throbbing" to it , and all the time i thought nothing was going on , i could witness the hard LED blink contnuously , suggesting something WAS going on ;


indeed, something was going on. the notebook actually restarted about 4 times (even though all i was shown all the way was a bare throbbing logo of w7); and each time it restarted, there was a new boot entry -- first it was Windows setup , then, when things were supposedly "done" in the final restart, there was a boot entry above my own 8.1 sys, and it was named Windows 7 ;this raised my suspicions even higher -- had w7 been installed even though it lookd to have stayd inactive on the throbbing "Startnig Wnidows" ? i was sure there was something wrong , so i tried installing Windows10 to check whether anything goes wrong too. Nothing went wrong. i was gradually losing control.


Then, in what i rather call a feat of madness, i replaced the "boot.wim" on my w7 installation stick with the "boot.wim" from a w8 stick i'd prepar'd some time ago and rebooted.i got a 0x000000e-something which meant i could not get to have a nice booting.


i did not surrender though. i bootd into my good old w8 parttiion, went to w7 stick (drive D: in my case), launched setup and went along; when it was done "Copying", it rebooted when it reached 20 % in "Expanding" ; i was sure i'm to hit against the dreaded w7 start scr again.


but then something weird happend. there was no such thing as a w7 startup logo. i could not believe (even though i had expected) that the startup logo was that of w8 -- i mean those rotary dots. i thought i was either stuck again, or i had chosen my w8 by mistake, but then, whoa! the "Installng Windows " appeard, with "Expanding" continuing past 20 % and all things went well (i.e, got green checkmakrs) right until the "Completing" level, when the final reboot occur'd.

i was expecting it to finally boot from the dsk with no kind of issues, like as the instllr  had eventually been made to boot from the stick; but, as i suspected, it didn't.


as it turns out, booting into installtaion depends on boot.wim while bootng into what is going to be the final,insatlled w7 depends on the  install.wim; now, what is certain is th"at there is something necessary for a successful boot in    w8.1's "boot.wim"  that its w7 equivalent is lacking in . i'd be glad to know what it is , or whether there exists some other way to get a w7 to boot/instll on a gpt dsk in uefi mode.


thanks a lot for reading this far, and thanks in advance for any ideas you provide on this matter.




Edited by icefapper, 15 August 2015 - 11:48 AM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users