Jump to content











Photo
- - - - -

How To Apply Multiple WIM Files With ImageX?


  • Please log in to reply
2 replies to this topic

#1 AnonVendetta

AnonVendetta

    Silver Member

  • Advanced user
  • 778 posts
  • Location:A new beginning.....
  • Interests:Self-development, computing

Posted 01 July 2015 - 12:27 PM

I've been having issues with my laptop recently, and have decided that it would be best to just reflash an unlocked BIOS, then restore from recovery discs. I made clones of my friend's recovery discs, they're pretty much unscratched so I'm sure they'll work. And we have identical model laptops. But I've been having trouble making a bootable OEM recovery USB from the ISOs, I already tried once and the USB failed to boot, just got stuck on a blinking cursor. Using Dell's AlienRespawn utility failed, it wouldn't install because I dont have a factory recovery partition present on my SSD/HDD. I cant install using the actual discs because I no longer have a disc drive. I noted that in a subfolder on each disc there are 2 WIM files, BASE.WIM and BASE2.WIM. I know how to apply a single WIM file with ImageX, as well as split WIMs (*.SWM), but not 2 WIMs. Can anyone tell me what the command syntax is for applying 2 WIMs?

 

Currently I've tried:

 

imagex /apply F:\preload\BASE.WIM /ref F:\preload\BASE2.WIM 1 J:

 

But I'm not sure if it's actually applying *BOTH* WIMs.

 

Thanks!

 

EDIT: BASE.WIM appears to contain what should be the contents of C:\, but BASE2.WIM is around 2.5GB and only contains a [2].xml file and a [Files] folder with a gazillion files within that that are essentially nothing but a bunch of files with numberss in their names. Surely the data must be important for restoring.

 

EDIT #2:

 

I get the message "Image successfully applied" when using the command listed above, so I still can't be sure whether the BASE2.WIM is also being applied.


Edited by AnonVendetta, 01 July 2015 - 01:23 PM.


#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 7284 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars, www.easy2boot.com
  •  
    United Kingdom

Posted 03 July 2015 - 08:11 AM

I would think that BASE.wim is the OS and BASE2.wim is the Factory Recovery partition contents.

So you use two separate imagex commands to apply them.

If your friend has a similar system, why not look at the contents of the partitions on their drive?



#3 AnonVendetta

AnonVendetta

    Silver Member

  • Advanced user
  • 778 posts
  • Location:A new beginning.....
  • Interests:Self-development, computing

Posted 05 July 2015 - 04:02 AM

It looks like my ripped ISOs might have been corrupt, which would explain why they failed to booting after converting them to USB. I cleaned his discs and ripped them at the slowest speed, then burned to DVDs and restored to my empty SSD drive which had no partition table. The restore went correctly, all partitions were created (OEM, recovery, and C drive) and everything is running fine now. I'm not sure what the 2nd disc was needed for, but it was requested during the process, so I inserted it. The only changes I made were to back up C drive, delete the 3 partitions the restore discs made, recreate a new GPT table with an EFI partition and C drive partition. Then I restored my backup to C and created UEFI boot files on the EFI with bcdboot. Then I booted witbootedh UEFI DUET. No problems so far, conversion successful.


Edited by AnonVendetta, 05 July 2015 - 04:41 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users