Jump to content











Photo
- - - - -

WDS: WinPE Boot from LAN results in error 0x102

pxe uefi efi wds

  • Please log in to reply
16 replies to this topic

#1 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 26 May 2015 - 09:05 AM

I've got a WDS 2012 and a DHCP Server 2012 running on the same subnet.

My WDS 2012 has been deploying Windows 8.1 x64 without any issues, using DHCP Options 66 and 67.

PXE-Boot works fine with BIOS Computers and bootfile name boot\x64\wdsnbp.com

 

Now I am trying to deploy Windows 8.1 x64 to HP Computers with UEFI.

 

In order to be able to boot my UEFI-Client from LAN I changed DHCP Option 67 bootfile name to boot\x64\wdsmgfw.efi.

 

When the UEFI Client tries to boot from LAN, it loads wdsmgfw.efi, then it says "Contacting Server (IP-Address of WDS)" for some minutes and then it stops with error message 0x102.

 

Windows Deployment Services encountered an error:
Error Code: 0x102

 

I've been fiddling about with default.bcd but no avail. I guess I am missing something here, but I don't know what it is.

Option 60 does not seem to be an option, because dhcp and wds are on dedicated servers.

 

As soon as I switch back to BIOS and wdsnbp.com everything works again.

 



#2 erwan.l

erwan.l

    Gold Member

  • Developer
  • 1918 posts
  • Location:Nantes - France
  •  
    France

Posted 26 May 2015 - 10:11 AM

 

I've got a WDS 2012 and a DHCP Server 2012 running on the same subnet.

My WDS 2012 has been deploying Windows 8.1 x64 without any issues, using DHCP Options 66 and 67.

PXE-Boot works fine with BIOS Computers and bootfile name boot\x64\wdsnbp.com

 

Now I am trying to deploy Windows 8.1 x64 to HP Computers with UEFI.

 

In order to be able to boot my UEFI-Client from LAN I changed DHCP Option 67 bootfile name to boot\x64\wdsmgfw.efi.

 

When the UEFI Client tries to boot from LAN, it loads wdsmgfw.efi, then it says "Contacting Server (IP-Address of WDS)" for some minutes and then it stops with error message 0x102.

 

Windows Deployment Services encountered an error:
Error Code: 0x102

 

I've been fiddling about with default.bcd but no avail. I guess I am missing something here, but I don't know what it is.

Option 60 does not seem to be an option, because dhcp and wds are on dedicated servers.

 

As soon as I switch back to BIOS and wdsnbp.com everything works again.

 

 

Hi,

 

Sorry to insist on option 60.

I have read elsewhere that this option 60=PXEClient makes a difference when using wds+efi.

 

Do you mean you cannot alter this option or you did, and it had no (positive) impact.

 

Regards,
Erwan



#3 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 26 May 2015 - 11:19 AM

Hi

I could add and alter this option, but with option 60 set to PXEClient my client would not even find the bootfile.

I also read  that "The DHCP server must not include server option 060 if PXE and DHCP reside on separate servers."



#4 erwan.l

erwan.l

    Gold Member

  • Developer
  • 1918 posts
  • Location:Nantes - France
  •  
    France

Posted 26 May 2015 - 11:56 AM

Error 0x102 more or less means 'server unavailable' which is not very helpful as it can mean several things :

-your (efi) client, once it has loaded the wds firmware, has no more network connectivity 

-your server (which works fine in bios mode) denies the requests coming from you efi client

 

A wireshark capture will help you understand what happens (both for a bios and efi run).

 

Looking at the server logs could also help asserting one of the scenarios above.



#5 Tripredacus

Tripredacus

    Frequent Member

  • Expert
  • 234 posts
  • Interests:K-Mart-ian Legend
  •  
    United States

Posted 27 May 2015 - 02:42 PM

Oh you posted this on Technet as well. As I post there (and here) is that Server 2012 can figure out what boot rom to use automatically and you don't need to change it.

#6 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 29 May 2015 - 03:15 PM

I ran a wireshark scan and as far as I can tell the wds server just does not respond to requests coming from the efi client. I'm clueless.



#7 Tripredacus

Tripredacus

    Frequent Member

  • Expert
  • 234 posts
  • Interests:K-Mart-ian Legend
  •  
    United States

Posted 29 May 2015 - 03:29 PM

Remove Option 67 from the DHCP Server.

#8 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 01 June 2015 - 12:27 PM

Without option 67 there are:
BIOS:  PXE-E53 No bootfile name received
UEFI: PXE-E18 Server response timeout



#9 Tripredacus

Tripredacus

    Frequent Member

  • Expert
  • 234 posts
  • Interests:K-Mart-ian Legend
  •  
    United States

Posted 01 June 2015 - 03:57 PM

moob reported this fixed by removing options and using "ip helpers" ... which is something I also never did. So many different ways you can configure a network, sometimes difficult to get the right fix for people. :)

Topic here:
https://social.techn...=w8itproinstall

Edited by Tripredacus, 01 June 2015 - 03:58 PM.


#10 erwan.l

erwan.l

    Gold Member

  • Developer
  • 1918 posts
  • Location:Nantes - France
  •  
    France

Posted 01 June 2015 - 06:48 PM

moob reported this fixed by removing options and using "ip helpers" ... which is something I also never did. So many different ways you can configure a network, sometimes difficult to get the right fix for people. :)

Topic here:
https://social.techn...=w8itproinstall

 

If he need to remove ip helpers it means the dhcp request was caught by a layer 3 switch and sent onto another vlan.

Surprising since he mentionned that it all sits on the same subnet?



#11 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 02 June 2015 - 06:29 AM

Solved: Removed dhcp options 66 and 67 and added ip helper address pointing to wds. thank you guys!



#12 erwan.l

erwan.l

    Gold Member

  • Developer
  • 1918 posts
  • Location:Nantes - France
  •  
    France

Posted 02 June 2015 - 06:37 AM

Solved: Removed dhcp options 66 and 67 and added ip helper address pointing to wds. thank you guys!

 

you mean you modified your layer 3 switch/router (where the ip helper is setup) to point to wds pointing an another vlan/subnet?



#13 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 02 June 2015 - 06:44 AM

Yes sir. Previously we had an ip helper configured on the switch, pointing to dhcp. Now there are 2 ip helpers (ip relay address), one pointing to dhcp, one pointing to wds. But I also had to remove the dhcp options.



#14 erwan.l

erwan.l

    Gold Member

  • Developer
  • 1918 posts
  • Location:Nantes - France
  •  
    France

Posted 02 June 2015 - 06:52 AM

Yes sir. Previously we had an ip helper configured on the switch, pointing to dhcp. Now there are 2 ip helpers (ip relay address), one pointing to dhcp, one pointing to wds. But I also had to remove the dhcp options.

 

ok makes sense.

 

i was confused as you initially reported your wds and dhcp were on the same subnet.

i had not thought that your clients could be on another vlan.

 

usually if you go for opton 66/67, you have to fill in option 60 as well.

or the alternative is to go for "plain" dhcp options, i.e not use option 66/67 (and therefore option 60).

 

I have the feeling that you could probably leave option 66/67 if you updated option 60 to "PXEClient".



#15 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 02 June 2015 - 07:13 AM

ok makes sense.

 

i was confused as you initially reported your wds and dhcp were on the same subnet.

i had not thought that your clients could be on another vlan.

 

usually if you go for opton 66/67, you have to fill in option 60 as well.

or the alternative is to go for "plain" dhcp options, i.e not use option 66/67 (and therefore option 60).

 

I have the feeling that you could probably leave option 66/67 if you updated option 60 to "PXEClient".

Yeah, sorry, should have pointed out that clients are on a different vlan. 


Edited by moob, 02 June 2015 - 07:14 AM.


#16 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 08 June 2015 - 06:41 AM

for 2 days it worked fine without dhcp options and with additional ip relay address pointing to wds. suddenly, pxe boot stopped working: clients would not get ip addresses any longer from dhcp. we then removed the ip helper pointing to wds and re-enabled dhcp-options.



#17 moob

moob

    Newbie

  • Members
  • 12 posts
  •  
    Switzerland

Posted 16 June 2015 - 05:48 AM

once again. yesterday it worked without dhcp options and with 2 ip helpers in place, one pointing to wds, the other one pointing to dhcp.

this morning:  error pxe-e53 (bios) pxe-e16 (uefi)

I don't get it. I guess I'll set up a dhcp server on my wds box...







Also tagged with one or more of these keywords: pxe, uefi efi, wds

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users