Jump to content











Photo
- - - - -

Booting FreeBSD from a grub4dos USB drive

freebsd grub4dos

  • Please log in to reply
No replies to this topic

#1 steve6375

steve6375

    Platinum Member

  • Developer
  • 6597 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 09 March 2015 - 10:05 AM

FreeBSD ISOs prior to version 9 will 'just boot' using Easy2Boot. Easy2Boot uses partnew to insert the ISO into partition 4 of the USB drive - e.g.

partnew (hd0,3) 0x0 /FreeBSD8.4.iso

Versions 9 and 10 however do not successfully fully boot in this way (Error 19).

 

I found that these versions did not like the fact that partition 4 (the ISO file) was inside partition 1 (the E2B partition) and so FreeBSD would not recognise the ISO as a valid filesystem.

However, even if I manually patched the partition table, FreeBSD 9 would not mount the ISO filesystem even though there were no 'GEOM' errors reported.

I then turned to the 'memstick' FreeBSD images. These are intended to be written to a Flash memory pen using dd (or RMPrepUSB  File->Drive). I also found that these would almost fully boot but gave an Error 19 if I mapped them to a MBR partition using partnew:

partnew (hd0,3) 0xA5 /FreeBSD9_memstick.img

Again the same problem, GEOM errors were reported because the 4th partition was inside the 1st partition.

 

Note: I also found that if a different normal 'dd'ed memstick USB flash drive was present in another USB port at the same time, FreeBSD 9 would boot from an ISO on an Easy2Boot drive - find the other memstick USB drive and then load the OS from that instead! So, presumably, it is looking at all drives and valid FreeBSD partitions in the system and then looking for the correct named volume.

 

I then tried the MakePartImage method. The Grub4dos partition (with the CSM menu and grub4dos files) in partition 1 and the memstick img file in partition 3. This worked fine because the partitions did not overlap!

 

So Easy2Boot v1.63 Beta 3 can now boot to FreeBSD v9/10, pfSense and GhostBSD .img files.

More details here.

 

 

 

 

Attached Thumbnails

  • CaptureBSDISO_BootFail_Err19.JPG






Also tagged with one or more of these keywords: freebsd, grub4dos

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users