Jump to content











Photo
- - - - -

MeeGoPad T01 x86 Quad-Core Intel Atom PC Stick boot PE for Backup


  • Please log in to reply
85 replies to this topic

#26 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 04:45 AM

From your last post: Cant find the BCD in easy mode

Open BootIce go to BCD Tab, select Other BCD file, go to the MeegoPad disk and in Boot partition should be a folder Boot open it and look for BCD.

Found it under z: System\boot
WP_20150313_040.jpg


From your post: Which are the offsets?

ID, Start LBA, FileSys. and Total sectors are the important caracteristics.

WP_20150313_039.jpg
so total sectors are the offset?

#27 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 04:57 AM

then open BCD in easy mode to see how it boots (Usual install or Wim Boot). Make notes of this just in case.

"Easy mode" available in bootice after finding in z: System\boot\bcd
WP_20150313_041.jpg

BCD, which one is it using (Usual install or Wim Boot)
WP_20150313_042.jpg

WP_20150313_043.jpg



#28 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 05:08 AM

Make notes of this just in case.

 

What notes on bcd. im guessing the pics should be ok for notes

 

 

 

As you have the install.wim in the windows images folder (in Images partition) of your MeeGoPad, you are able to reinstall from it to the Windows NTFS partition and recreate all the booting partition (Fat32) too (Usual install or Wim Boot),  you need to format ONLY the Fat32 and the Windows partition before procede, DO NOT FORMAT the Images partition.  Then select in WinNTSetup the install.wim, boot partition and the Windows partions and depending from what you saw in BCD you select how to install (normal or Wim Boot). Let it finish and reboot to your Bios and put every thing as it was before doing any changes, save and boot. Then the system config. should start.

 

Make sure you do not change the partions offsets when formating them, you can do it with BootIce or your  Win8PE SE as you prefer.

 



#29 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 05:16 AM

That Boot file is in your PE, you have to go to MeGoPad disk, Boot partition (Fat32) and there open Boot folder and inside it is BCD but you need to open it from BootIce, BCD Tab,  Other BCD file.

 

EDIT: You have the right one. Let me see the pictures for some seconds.



#30 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 05:31 AM

some more pics of disk management and bootice

WP_20150314_001.jpg

WP_20150314_002.jpg



#31 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 05:38 AM

BCD looks as normal install but the used size in Windows partition looks to me very small like in Wimboot mode, just pagefile is a big file, and the used size is about 3.75 GB so it has to be Win Boot mode.



#32 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 05:39 AM

Double post



#33 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 05:48 AM

Windows c drive and system drive

WP_20150314_003.jpg

WP_20150314_004.jpg

Properties for documents and settings to Windows folder
WP_20150314_005.jpg

#34 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 06:12 AM

To be safe copy install.wim to your USB PE if you want, if not you have the backup from Acronis , open WinNTSetupx86 and select the install.wim on your MeeGoPad as source, select Boot partition (Fat32) and select Windows partition (NTFS), format the two partitions, and select WimBoot, and start the process. In the next window select the UEFI option for booting, After it finish reboot to Bios, undo all changes you made, save and reboot to windows, it should start the config., if not something is wrong with your MeeGoPad



#35 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 06:19 AM

Cant acces partition that has images under windows. I thinks its not mounted to a drive letter. Disk management sees it but has no drive letter.
WP_20150314_006.jpgWP_20150314_002.jpg


I could see the images folder under Ubuntu Mate Liveusb
WP_20150313_034.jpg



#36 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 06:35 AM

Can you assign it a temporary letter in your PE? in Disk Management. It will be gone when you reboot.



#37 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 06:37 AM

Copying Instal.wim file from ubuntu pe to win8pese usb

 

WP_20150314_010.jpg

WP_20150314_011.jpg

WP_20150314_012.jpg



#38 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 06:41 AM

If you like to see more info about Wim Boot: https://technet.micr...y/dn594399.aspx and https://technet.micr...y/dn605112.aspx to do it manual way using Dism.



#39 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 06:58 AM

Will try the WinNTSetup
Select location of windows installation files
Y:\install.wim

Select location of boot drive
Z:

Select lacation of installation drive
C:


WP_20150314_013.jpg

#40 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 07:21 AM

Did you assign it a temporary letter to the partition where is install.wim in MeeGoPad?

 

In your PE in Disk Management you can do it. It will be gone when you reboot.

 

When using Wim Boot. Both install.wim and Windows install location most be in same HDD, SSD or eMMC



#41 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 07:22 AM

Windows source invalid

Will do the mount drive

 

Computer management

Actions available to Healthy recovery partition

Refresh,rescan disks, create vhd, attach vhd

gives no option to assign letter



#42 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 07:25 AM

Where is your surce located, in what disk?



#43 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 07:35 AM

The source is suppose to come from recovery partition
Under Ubuntu it loads it up

When testing and it gave an invalid source. The source Was from the windows 8pese USB Y:

#44 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 07:40 AM

You better make a new Win8.1u1 PE UEFI booting capable as MistyPE http://reboot.pro/fi...le/357-mistype/

 It is small but works fine as I have tested, and then just follow said steps.

 

Don't forget to copy WinNTSepup in it.

 

I'll be here tomorrow to see if I can be of any help.

 

EDIT:

 

1.- Make PE not FE, for actual needs PE is enought, you can exclude all FE

 

2.- The source for building the PE has to be 8.1 update 1 in order to let WinNTSetup make use of Wim Boot option.



#45 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 07:46 AM

Ok! Thanks!

#46 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 07:49 AM

You are wellcome my friend.

 

Please read again post # 44, I Edited it with relevant info.

 

Also please see this: http://www.msfn.org/...34#entry1076456

 

Sorry I forgot this important info, last time I was playing with Wim Boot was more than 10 months ago.

 

There is also another tool and this one do not require 8.1 U 1: wimlib: http://reboot.pro/to...tion/?hl=wimlib

 

This info is also related to Wim Boot: http://reboot.pro/to...oot/?hl=wimboot



#47 skyide

skyide

    Frequent Member

  • Advanced user
  • 218 posts
  •  
    Australia

Posted 14 March 2015 - 08:57 PM

I am getting one of these myself! :)



#48 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 09:15 PM

Congrats!

skyide

#49 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4131 posts

Posted 14 March 2015 - 09:28 PM

You better make a new Win8.1u1 PE UEFI booting capable as MistyPE http://reboot.pro/fi...le/357-mistype/

 It is small but works fine as I have tested, and then just follow said steps.

 

 

 

I'll be here tomorrow to see if I can be of any help.

 

EDIT:

 

1.- Make PE not FE, for actual needs PE is enought, you can exclude all FE

 

2.- The source for building the PE has to be 8.1 update 1 in order to let WinNTSetup make use of Wim Boot option.

Made the MistyPE. Scanned the links. Its a lot to take in

MistyPE uses bbblean as shell

Don't forget to copy WinNTSepup in it.

 

ok.

 

Disk management still shows

Refresh,rescan disks, create vhd, attach vhd

gives no option to assign letter

 

 

3rd Page



#50 alacran

alacran

    Frequent Member

  • Advanced user
  • 406 posts
  •  
    Mexico

Posted 14 March 2015 - 10:36 PM

I see, please read this: https://technet.micr...y/dn605112.aspxthis is Windows way using Dism from 5.1PE, in this part it says:

 

Protect the WIMBoot folders and prepare the PC for OOBE

  • Protect the Windows images partitions by setting them as read-only. Run these steps from an elevated command prompt:

     
     
    icacls "M:\Windows Images" /inheritance:r /T
    
    icacls "M:\Windows Images" /grant:r SYSTEM:(R) /T
    
    icacls "M:\Windows Images" /grant:r *S-1-5-32-544:(R) /T
    
    clear.gifNote It’s not necessary to hide the WIMBoot partitions.

So we need to find a way to unprotect this and make it read and write.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users