Jump to content











Photo
- - - - -

What drivers are being used by the SanDisk Extreme USB 3 UFD ?


  • Please log in to reply
8 replies to this topic

#1 gbrao

gbrao

    Frequent Member

  • Advanced user
  • 344 posts
  •  
    India

Posted 13 December 2014 - 11:45 AM

I just got a SanDisk Extreme USB 3.0 UFD. Installed the latest USB 3.0 drivers for my mobo. Device Manager -> Disk Drives -> SanDisk Extreme shows it is using a Microsoft driver dates 2006.

UFD : http://www.amazon.co...0332200_TE_item

Windows 7 SP1 64 bit.
Haswell + Z87 system.

2014-12-13_170105 small.jpg

#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13475 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 13 December 2014 - 12:29 PM

I just got a SanDisk Extreme USB 3.0 UFD. Installed the latest USB 3.0 drivers for my mobo. Device Manager -> Disk Drives -> SanDisk Extreme shows it is using a Microsoft driver dates 2006.

WHICH driver? 

The disk.sys (and partmgr.sys)? It is normal they are the "disk" drivers all your system uses on any disk-like device.

 

:duff:

Wonko



#3 cdob

cdob

    Gold Member

  • Expert
  • 1317 posts

Posted 13 December 2014 - 12:30 PM

Open device manger, change view per connection.
Search the USB stick. View the referenced USB hub controller.

#4 cdob

cdob

    Gold Member

  • Expert
  • 1317 posts

Posted 13 December 2014 - 12:30 PM

.

#5 gbrao

gbrao

    Frequent Member

  • Advanced user
  • 344 posts
  •  
    India

Posted 13 December 2014 - 02:58 PM

OK, thanks. So the "USB 3.0 drivers" are for the (Intel) Root Hub & eXtensible Host Controller.

 

2014-12-13_202033.jpg

 

 

I'm pretty sure the mouse is connected to a USB 2.0 port. Yet Device Manager shows it at the USB 3.0 Root Hub ?



#6 cdob

cdob

    Gold Member

  • Expert
  • 1317 posts

Posted 13 December 2014 - 03:33 PM

So the "USB 3.0 drivers" are for the (Intel) Root Hub & eXtensible Host Controller.

Yes, Intel USB 3 drivers are connected to the USB stick.
 

I'm pretty sure the mouse is connected to a USB 2.0 port. Yet Device Manager shows it at the USB 3.0 Root Hub ?

Which hardware do you use? Which port do you use?

#7 gbrao

gbrao

    Frequent Member

  • Advanced user
  • 344 posts
  •  
    India

Posted 13 December 2014 - 07:48 PM

Intel i3 4130 + Gigabyte GA-Z87MX-D3H
(http://www.gigabyte....pid=4490&dl=#sp)

8171_big.jpg

2014-12-14_013101.jpg

2014-12-14_012846.jpg

#8 dencorso

dencorso

    Frequent Member

  • Advanced user
  • 110 posts
  •  
    Brazil

Posted 14 December 2014 - 05:57 AM

The connector your arrow is pointing is USB 2.0, there is no mistaking it.

No matter what the software says. All USB 3.0 connectors have the inside plastic guide in blue.

That one hasn't, so there's no way it could be a USB 3.0 one.



#9 gbrao

gbrao

    Frequent Member

  • Advanced user
  • 344 posts
  •  
    India

Posted 14 December 2014 - 06:37 AM

With mouse attached to front USB 2.0 port :

2014-12-14_120506.jpg

---------------------------------------------------------

With mouse attached to front USB 3.0 port :

2014-12-14_120841.jpg




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users