Jump to content











Photo

AlcorMP Tool is giving Error "Get Chip Number Fail"

alcormp usb repair

  • Please log in to reply
3 replies to this topic

#1 sajidrehman668

sajidrehman668
  • Members
  • 3 posts
  •  
    Pakistan

Posted 24 November 2014 - 07:16 AM

I have Kingston 8GB USB which have following info in Chip Genius v4.0

 

Description: USB Mass Storage Device
Device Type: Mass Storage Device
 
Protocal Version: USB 2.00
Current Speed: High Speed
Max Current: 100mA
 
USB Device ID: VID = 058F PID = 1234
 
Device Revision: 0001
 
Controller Vendor: Alcor
 

Tools on web:       http://bbs.mydigit.c...d.php?tid=20620

 

after search on net I found Alcor Recovery tool for repairing Alcor chip controllers Software to fix the issue but dont know much to use it. .

 

Following are the screen shots of some steps that I did on USB.

 

2dj1nqq.jpg

 

14szcsx.jpg

 

After Pressing Start with mentioned settings I received the following Error.

 

2a8j59c.jpg

 

Please guide me about the steps to solve this issue. ( will be thankful if its with screen shots if possible)

 

 

 



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15466 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 24 November 2014 - 09:59 AM

Start by following the same advice given (for Phison instead of Alcor) here:

http://reboot.pro/to...n-datatraveler/

check the stick with the other mentioned tools and see if they can better identify the controller chip, which may help in finding another, more suited "production tool".

 

:duff:

Wonko



#3 sajidrehman668

sajidrehman668
  • Members
  • 3 posts
  •  
    Pakistan

Posted 25 November 2014 - 08:47 AM

I found another Chip Detail Finder i.e ChipEasy 1.5.6. English version which gave me following details

2lvxqtx.jpg

 

According to mentioned Controller, I download the same AlcorMP AU698X and tried as below.

 

353bays.jpg

 

sb7fx1.jpg

 

ohi635.jpg

 

juhifm.jpg

 

1zfmv7r.jpg

 

23h3jh0.jpg

 

I tried many CTL like AU6980/81/82 etc but facing the same Error. :angry:

 

208icqo.jpg

 

25pl0n5.jpg

 

I also tried FC_MpTool_FC8308_FC8508_FC8406_v03 which is suggested in ChipEasy software but No Use as nothing is detecting in that software. :huh:

 

t86qlf.jpg

 

Need disparately help from Experts! :(



#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15466 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 25 November 2014 - 10:43 AM

Do read the page:

http://www.usbdev.ru/files/alcor/

it is not that bad in Google translate :), you will likely need to add your "non-standard" Vid/Pid to the [IGNORE] section if you are using the FC_MpTool, or use the modified version by nat27, but it is also well possible that the stick is "dead" for some reason. :(

 

The page also essentially says to NOT use the "Recovery tool", but rather the AlcorMP_UFD or the FC_MpTool instead.

 

:duff:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users