Jump to content











Photo
- - - - -

PXE chain SCCM 2012 R2 WDS


  • Please log in to reply
3 replies to this topic

#1 sebus

sebus

    Frequent Member

  • Advanced user
  • 305 posts

Posted 30 October 2014 - 02:21 PM

Followed this:

http://sysmagazine.com/posts/175669/

 

or at webarchive:

 

http://web.archive.o...m/posts/175669/

but with a difference, that I am still using my existing PXE menu from a different PXE server, but just added to existing default this entry:

label sccm
menu label Boot to SCCM 2012 R2
COM32 pxechn.c32
APPEND 10.0.0.86::smsboot\x86\wdsnbp.com -W

which starts booting from SCCS PXE, but crashes as it can not find its BCD store:

\\ssccm-server\REMINST\SMSTemp\2014.10.30.11.15.17.01.{10CEDB89-9093-44D6-BF1B-0FA357C08F58}.boot.bcd

I hate how SCCM is not configurable in any way, but have to live with it.

So does anybody know how to make it work?

I do not want to use SCCS PXE as default, as it means that my iso images are transferred by TFTP (currently I boot ipxe undionly.0 which does the transfer by http - which is way faster!)

sebus

 

Edit

 

There is

-o 66.x=xx:xx:xx:xx -S 

option, but I could not make it work either...



#2 sebus

sebus

    Frequent Member

  • Advanced user
  • 305 posts

Posted 30 October 2014 - 10:04 PM

Gave up chainloading SCCM from pxelinux existing ipxe undionly.0 setup & done as per article above

It does work fine if one also adds Option 43 & Option 60 to DHCP as per this as my SCCM/WDS & DHCP servers are on separate machines.

Then I added in its menu a chainload option to get back to my original ipxe undionly.0 menu & all works perfectly fine.

Pity that SCCM has got pxeboot.com hardcoded in smspxe.dll (the usual MS vision of the world, us or nothing...)

I wish I could easily replace totally useless tftp server that comes with WDS (with something better, like Bootix which is free)
Worse case I will need to follow this to optimize (something that should be already optimized!)

 

It seems that maybe this work:

 

EDIT - tested & does NOT work, without this key WDSServer service will NOT start!

 

You can disable the WDS TFTP server by performing the following operations: 

1) Open the registry editor (regedit.exe)

2) Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WDSServer\Providers\WDSTFTP

3) Right click -> export the key to a file as a backup.

4) Delete the entire WDSTFTP registry key.

5) Restart the WDS service

 

and then I can use Bootix TFTP Server

But probably easier will be just to add sccm.iso to my original menu & download it via http



#3 sebus

sebus

    Frequent Member

  • Advanced user
  • 305 posts

Posted 02 February 2016 - 04:59 PM

In the end I PXE boot my machines via DHCP specified option 66/67 undionly.kkpxe (build from latest GIT on Centos) from SCCM/WDS server, which points to pxelinux.0 on itself (via embedded script) & allows me to have any useful menus on a single screen

sebus

#4 sebus

sebus

    Frequent Member

  • Advanced user
  • 305 posts

Posted 02 February 2016 - 05:04 PM

I could also try instructions from here, but will do on another quiet day

chain tftp://ip.of.tftp/Boot/x86/wdsnbp.0

set net0/next-server x.x.x.x

set netX/next-server x.x.x.x





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users