Jump to content











Photo
- - - - -

ignore hard drive


  • Please log in to reply
7 replies to this topic

#1 gaberilde

gaberilde
  • Members
  • 7 posts
  •  
    United Kingdom

Posted 25 May 2014 - 05:53 PM

heres my menu lst

# This Menu created with YUMI (Your Universal Multiboot Installer) http://www.pendrivelinux.com
default 1
timeout 30
color NORMAL HIGHLIGHT HELPTEXT HEADING
splashimage=/multiboot/menu/yumi.xpm.gz
foreground=FFFFFF
background=000000

title --- Directly Bootable ISOs + Windows XP ---
root

title <-- Back to Main Menu
root (hd0,0)
chainloader (hd0)+1
rootnoverify (hd0)




#start Gandal
#Modify the following entry if it does not boot
title Boot Gandal.ISO
find --set-root --ignore-floppies --ignore-cd /multiboot/ISOS/Gandal.ISO
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/Gandal.ISO (hd32)
map --hook
chainloader (hd32)
#end Gandal

can someone tell me or edit this to make it ignore the hard drive?

also the hard drive is dieing so it cant be turned on or anything



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15044 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 25 May 2014 - 06:49 PM

What is "Gandal"?
Does it actually boot from USB as .iso?
If yes, remove the "looking for it".
Normally when you boot form USB you change BIOS boot order and the USB device becomes (hd0) and the first (only?) partition on it becomes (hd0,0), and in any case if you boot to it, root will be already set on the USB device.
I.e.:



title Boot Gandal.ISO
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/Gandal.ISO (hd32)
map --hook
chainloader (hd32)

or:



title Boot Gandal.ISO
root (hd0,0)
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/Gandal.ISO (hd32)
map --hook
chainloader (hd32)

As always it would make sense to test the command sequence in grub4dos command line first, press "c" when the menu.lst shows, then type:

root (hd0,0)
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/Gandal.ISO (hd32)
map --hook
chainloader (hd32)
boot



:duff:
Wonko



#3 gaberilde

gaberilde
  • Members
  • 7 posts
  •  
    United Kingdom

Posted 25 May 2014 - 06:51 PM

What is "Gandal"?

Does it actually boot from USB as .iso?

If yes, remove the "looking for it".

Normally when you boot form USB you change BIOS boot order and the USB device becomes (hd0) and the first (only?) partition on it becomes (hd0,0), and in any case if you boot to it, root will be already set on the USB device.

I.e.:



title Boot Gandal.ISO
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/Gandal.ISO (hd32)
map --hook
chainloader (hd32)

or:





title Boot Gandal.ISO
root (hd0,0)
map --heads=0 --sectors-per-track=0 /multiboot/ISOS/Gandal.ISO (hd32)
map --hook
chainloader (hd32)

:duff:

Wonko

gandel is an iso i want to ignore hd 1 the internal hard drive if i change ur code to hd 1 will it ignore it?



#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15044 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 25 May 2014 - 07:00 PM

gandel is an iso i want to ignore hd 1 the internal hard drive if i change ur code to hd 1 will it ignore it?

That gandal.iso (or gandel.iso) is a .iso is obvious, thanks.

I was asking if it was a Linux, a Dos or a *whatever* as this may affect the actual booting, not in grub4dos loading, buit later, when the actual .iso is loaded.

 

If you don't use find or find --set-root, grub4dos has no reasons to look in (hd1), but this may depend on the actual disk order in the BIOS.

 

The USB device (normally) becomes first hard disk and when booting grub4dos will establish (again normally) root on it, then if you avoid changing root or accessing other hard disk, it should have no issues, but you have anyway to experiment, WITHOUT changing anything in the commands I posted, the idea is that of avoiding grub4dos trying to access other disk devices if not the one you booted from (hd0).

 

:duff:

Wonko



#5 gaberilde

gaberilde
  • Members
  • 7 posts
  •  
    United Kingdom

Posted 25 May 2014 - 07:04 PM

That gandal.iso (or gandel.iso) is a .iso is obvious, thanks.

I was asking if it was a Linux, a Dos or a *whatever* as this may affect the actual booting, not in grub4dos loading, buit later, when the actual .iso is loaded.

 

If you don't use find or find --set-root, grub4dos has no reasons to look in (hd1), but this may depend on the actual disk order in the BIOS.

 

The USB device (normally) becomes first hard disk and when booting grub4dos will establish (again normally) root on it, then if you avoid changing root or accessing other hard disk, it should have no issues, but you have anyway to experiment, WITHOUT changing anything in the commands I posted, the idea is that of avoiding grub4dos trying to access other disk devices if not the one you booted from (hd0).

 

:duff:

Wonko

 

That gandal.iso (or gandel.iso) is a .iso is obvious, thanks.

I was asking if it was a Linux, a Dos or a *whatever* as this may affect the actual booting, not in grub4dos loading, buit later, when the actual .iso is loaded.

 

If you don't use find or find --set-root, grub4dos has no reasons to look in (hd1), but this may depend on the actual disk order in the BIOS.

 

The USB device (normally) becomes first hard disk and when booting grub4dos will establish (again normally) root on it, then if you avoid changing root or accessing other hard disk, it should have no issues, but you have anyway to experiment, WITHOUT changing anything in the commands I posted, the idea is that of avoiding grub4dos trying to access other disk devices if not the one you booted from (hd0).

 

:duff:

Wonko

its a windows 8 pe disk and i want it to ignore the built in hard drive like not even turn it on



#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15044 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 26 May 2014 - 09:01 AM

Well, build a WinFE project. (a WinFE is a particular kind of PE that does NOT modify the internal hard disk).

 

BUT, of course, if you have a disk that is defective or about to die, the right solution is that of disconnecting it, as dencorso suggested on the other thread on MSFN:

http://www.msfn.org/...nal-hard-drive/

 

:duff:

Wonko



#7 tinybit

tinybit

    Gold Member

  • Developer
  • 1157 posts
  •  
    China

Posted 27 May 2014 - 08:16 AM

ignore hard drive ?

do you mean you want it to be invisible ?

Try with these ideas:

1. disable the CHS and LBA accessibility for this drive(eg. hd1):

map --disable-chs-mode --disable-lba-mode (hd1) (hd1)
map --hook

2. let (hd1) point to garbage:

map --mem (md)+8 (hd1)
map --hook

#8 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15044 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 27 May 2014 - 10:16 AM

@tinybit
JFYI the OP misrepresented the issue he was having (failing hard disk), later understood and solved here:
http://www.msfn.org/...nal-hard-drive/

:duff:
Wonko




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users