Jump to content











Photo
- - - - -

wimlib-clc beta

imagex deploy synchronicity wimlib-imagex wimlib wim

  • Please log in to reply
25 replies to this topic

#1 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 20 March 2014 - 01:50 PM

Posted Image

File Name: wimlib-clc beta
File Submitter: ReTokener
File Submitted: 20 Mar 2014
File Updated: 04 Nov 2017
File Category: Tools

wimlib-clc beta
Windows command line compiler for
Synchronicity´s wimlib-imagex 1.9.0 to 1.12.0

Features: capture/append, apply, extract, export, delete, join, split, verify,
info and update.

Thanks a lot to Synchronicity for his good work.
Read Synchronicity´s wimlib-imagex doc´s for more information about specific options.
ANY suggestions or bug reports are appreciated to improve the script.
enjoy
T.

Click here to download this file

#2 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 08 June 2014 - 09:26 PM

@ReTokener

 

Sounds pretty good to me, I don't like to type commands if there is a GUI available; it is very easy to mistype a command.

 

I would like to know if your tool includes wimlib v1.70 or if we need to download it.

 

Just downloaded, and I found it needs wimlib v1.70, there are 2 v1.70:

wimlib-1.7.0-BETA-windows-x86_64-bin and wimlib-1.7.0-BETA-windows-i686-bin

 

My OS is win7SP1x64, please tell me which one to use with your tool

 

 

Best Regards


  • ReTokener likes this

#3 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 08 June 2014 - 11:24 PM

@ReTokener

 

In the mean time I have downloaded and tried both wimlib v1.70 (one at a time) with your tool running your wimlib_CLC_140608_3_x64 (as admin.) as I'm on x64 OS, When I want to capture a volume  I can go as far as the picture: http://www.mediafire...3e2c/Image1.jpg

 

But then, How to start the process?



#4 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 09 June 2014 - 08:07 AM

Hi alacran

I´m sorry for this inconveniance, let´s see what went wrong.

I presume you pressed capture, so there must be log (menu/extras).

(did you specify an image_name?)

If an error appeared, there will be no output but you can copy the command line into the CMD box and see what happens.

 

T.



#5 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 09 June 2014 - 08:00 PM

Uploaded new version 14.6.9.3

Some bugs might be fixed but you never know what different languages/locales hold in store.

 

T.



#6 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 09 June 2014 - 09:33 PM

@ ReTokener

 

About your question: if I gave a name to the image: Yes as you can see in the picture, and Yes i clicked captue and then the Info verified how many files and folders to be copied, when finished it stops there.

 

I just downloaded last version and will try it and report back.

 

Best Regards



#7 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 09 June 2014 - 11:48 PM

Hi ReTokener

 

Just tested your last build: using wimlib-1.7.0-BETA-windows-x86_64-bin and your x64 .exe in same file (now at the root of my Win7SP1x64 partition), selected same XP partition to make the image from it, but when I clicked capture the Info window opened and checked how many files and folders to be copied, when finished it stops there.

Clicking  OK I go back to capture window again, clicking run: a Command prompt opens and it said there is an error Boot\BCD : Can't open file <status=0xc0000043>: Resource busy ERROR: Exiting with error code 47: Failed to open a file Errorlevel =47.

 

Well this may be caused because I have a dual booting XP/Win7:

 

First HDD:

First primary partition: XP and Win7 boot files NTFS Active

Second primary partition: Win7

Third primary partition: documents

 

Second HDD: Single NTFS primary partition

 

As I was runing your tool from Win7, trying to make an image of XP, the boot files corresponding to win7 where unavailable.

 

I then rebooted to MistyPE-7x64.ISO from my HDD using grub4dos and tryed again (running your tool from Win7 partition on HDD), this time when clicked Capture the Info window opened and started capturing, capture finished OK but I had selected Recovery compression, it should be .esd not .wim, and my final image was .wim; I think you need to fix that.

 

Best Regards



#8 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 10 June 2014 - 11:55 AM

 

I then rebooted to MistyPE-7x64.ISO from my HDD using grub4dos and tryed again (running your tool from Win7 partition on HDD), this time when clicked Capture the Info window opened and started capturing, capture finished OK but I had selected Recovery compression, it should be .esd not .wim, and my final image was .wim; I think you need to fix that.

 

Hi alacran,

making an image from PE-System is in most cases the best way to avoid capturing-errors.

 

Thanks for pointing me to the "esd" extension.

I updated the script to build:140610

http://reboot.pro/fi...-line-compiler/

 

Regards T.



#9 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 10 June 2014 - 12:53 PM

@ ReTokener

 

GOOD!  Just downloaded and I ran it, when selected Recovery compression it applyed the esd extension now.

 

I notice your tool writes to C:\Users\User_name\AppData\Roaming\wimlib the log file & the ini file, Could it be possible to avoid it and make it fully portable in order to use it from a WinPE in a CD?

 

Best Regards



#10 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 10 June 2014 - 07:16 PM

@ ReTokener

 

GOOD!  Just downloaded and I ran it, when selected Recovery compression it applyed the esd extension now.

 

I notice your tool writes to C:\Users\User_name\AppData\Roaming\wimlib the log file & the ini file, Could it be possible to avoid it and make it fully portable in order to use it from a WinPE in a CD?

 

Best Regards

 

Thanks a lot alacran

 

In the moment the script uses the APPDATA-Dir to keep some settings in mind.

That does not mean that its not portable, you can use it even from writeprotected media.

The Appdata-Files are created when the script is in usage, they are not necessary for the script to run.

 

Hope this answered you question, if not, don´t hesitate to ask.

 

Regards T.

 

P.S. I updated the script recently to Build:140610.3


  • alacran likes this

#11 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 11 June 2014 - 04:39 AM

@ ReTokener

 

Your answer is good for me.   Well my friend I'm sorry but I think you will need to make a new update since there is a new v1.70Beta with different behaviour on absolute links, See : http://reboot.pro/to...-10#entry184745

 

Best Regards


  • ReTokener likes this

#12 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 11 June 2014 - 01:30 PM

@ ReTokener

 

Your answer is good for me.   Well my friend I'm sorry but I think you will need to make a new update since there is a new v1.70Beta with different behaviour on absolute links, See : http://reboot.pro/to...-10#entry184745

 

Best Regards

 

Hi alacran

Thanks for the hint.

Next Build will respect this.

 

T.



#13 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 28 July 2014 - 11:47 AM

Hello wimlib-enthusiasts

 

Just updated wimlib_CLC to version 140728.

 

    - added: DELETE, EXPORT, EXTRACT, JOIN, SPLIT
    - added: sendto options / shell extensions
    - improved: tool-tips
 

Screenshots may give you a small insight.

 

Download here:

http://reboot.pro/fi...-line-compiler/

 

Hope you enjoy,  T.



#14 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 31 August 2014 - 09:13 AM

New Update 140831

 

Compatible with wimlib-imagex 1.7.1.

New option: VERIFY

 

T.


  • alacran likes this

#15 ljycslg

ljycslg

    Newbie

  • Members
  • 26 posts
  •  
    China

Posted 03 October 2014 - 04:13 PM

I seem to remember a previous version can Established hard link between the same file when capture or apply image?



#16 synchronicity

synchronicity

    Frequent Member

  • Advanced user
  • 165 posts
  •  
    United States

Posted 03 October 2014 - 05:52 PM

I seem to remember a previous version can Established hard link between the same file when capture or apply image?

 

 

If you're talking about the --hardlink option to 'wimlib-imagex apply', that was removed in 1.7.0.  It was prone to be misused and I didn't want to maintain it.  The --symlink option suffered the same fate.

 

Of course, wimlib still supports actual hard links, and there is no special option needed to take advantage of this.



#17 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 01 April 2015 - 05:35 AM

This is last version from ReTokener in order to use wimlib-imagex v1.80 (last version).

 

I asked him in PM for an update and he attached it to his answer.

 

Quote:

 

I reduced scripting and testing for now, so this will not become an official release.

But if you find it useful and not too buggy, feel free to publish it or distribute it to anyone you like.

 

 

 

Attached Files



#18 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 31 January 2017 - 10:32 AM

Hello friends of the wimlib project

Thanks to synchronicity for constant development of the wimlib-project.

For user conveniance I updated the frontend to attend the wimlib-imagex.exe.

Download Build 170130:

http://reboot.pro/fi...imlib-clc-beta/

 

enjoy  T.


  • alacran likes this

#19 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 06 February 2017 - 10:42 AM

New Version:

Download Build 170205:

http://reboot.pro/fi...imlib-clc-beta/

 

enjoy  T.

 



#20 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 19 March 2018 - 05:37 PM

@ReTokener

 

Hello my friend, haven't talk for some time, hope you are fine.

 

As you know I really do not like Win10 but as I'm now part of PEBakery Team and need to run frecuently the PEBakery Builder requiring .Net Framework 4.7.1 to work, I prefered to install Win10 on other partition and not add more than 1 GB just to install .Net Framework 4.7.1 on my Win7

 

When I tried to open some .wims using wimlib_clc_171104 on Win10x64 but I can't see any info of the .wim even on the tab "Info/Delete", so basically wimlib_clc is not working fine on win10.

 

Is there somethig you can do to fix this?

 

Waiting for your answer.

 

Your friend alacran.



#21 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 19 March 2018 - 11:48 PM

Dear friend alacran,

good to hear from you.

 

I tried to reproduce this error you mentioned, with success on:

Win10Pro x64

Version 1709

Build 16299

 

Two facts might cause this error.

First: (most likely) running wimlib-clc without admin rights.

Sec.: not having owner-rights to the (wim)-object.

 

I tried to answer very quick, so no further tests are done.

 

If missing admin rights cause trouble when selecting image by context menu, maybe this helps:

disable UAC setting: Elevated rights for UIAccess apps, (what may lead to vulnerabilities in the system).

 

Hope this an answer to your question.

I´m ready if you need more infos.

 

Sincerely  T.



#22 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 20 March 2018 - 12:29 AM

Thanks for your quick answer R.:

 

 

Two facts might cause this error.

First: (most likely) running wimlib-clc without admin rights.

Sec.: not having owner-rights to the (wim)-object.

 

I'm running 10 as admin and also UAC is permanently disabled, so it has to be something else my friend, the .wim(s) has been created by myself using PEBaakery, but other boot.wim(s) extracted from Win install Isos have same problem.  But only when running your great tool on win10.

 

alacran



#23 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 20 March 2018 - 01:51 AM

@Retokener

 

My friend good news, I found the way to fix this problem, selecting the shortcut on my desktop, right click>> Properties>>Tab Compatibility and selecting "Run as administrator".    But I'm administrator since win10 first boot when was installed (by unattend.xml).

 

Well if this made it work as fine as usually, problem solved.

 

Your friend

 

alacran


  • ReTokener likes this

#24 ReTokener

ReTokener

    Frequent Member

  • Developer
  • 123 posts

Posted 20 March 2018 - 10:20 AM

Dear alacran,

good to hear the problem is solved.

 

For testing purpose here is a modified script that checks admin rights before running. (should do so)

Attached File  wimlib_clc_180319.zip   1.61MB   42 downloads

 

Best wishes  T.


  • alacran likes this

#25 alacran

alacran

    Silver Member

  • Advanced user
  • 596 posts
  •  
    Mexico

Posted 20 March 2018 - 05:17 PM

OK, Thanks, downloaded.

 

I'll test it ASAP and let you know my findings (if any), but I assume it will work fine as always.

 

Your friend

 

alacran







Also tagged with one or more of these keywords: imagex, deploy, synchronicity, wimlib-imagex, wimlib, wim

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users