Jump to content











Photo
- - - - -

Unnecessary DHCP configuration field

tftpd64 dhcp service edition

  • Please log in to reply
5 replies to this topic

#1 rmroot

rmroot
  • Members
  • 2 posts
  •  
    Russian Federation

Posted 26 January 2014 - 04:53 PM

There is an optional filed "Default router" in Tftpd64 settings. I do not want my hosts to receive a default gateway via DHCP in my network. Unfortunately Tftpd64 shows an error when I leave "Default router" field empty. Can you please help me with this inconsistence? How can I avoid sending a default gateway to my hosts?

 

4JkMY9K.jpg

 

TFTPD service edition, version 4.50 (build Nov 28 2013).



#2 rmroot

rmroot
  • Members
  • 2 posts
  •  
    Russian Federation

Posted 16 February 2014 - 03:24 PM

Bump



#3 erwan.l

erwan.l

    Gold Member

  • Developer
  • 1920 posts
  • Location:Nantes - France
  •  
    France

Posted 16 February 2014 - 04:09 PM

Hi rmroot,

 

Try 0.0.0.0 or else try http://reboot.pro/to...iny-pxe-server/ .

 

Regards,

Erwan



#4 DigitalTitan

DigitalTitan
  • Members
  • 1 posts
  •  
    United States

Posted 13 July 2017 - 01:15 PM

I realize this is a really old thread, but I have landed on it multiple times when trying to figure out the same issue.  Each time, I have figured it out, but forget how I did it.  Anyway, this reply is to remind me later, as well as anyone else who lands on it as I have.

 

The DHCP field is required because the DHCP server is enabled in the "Global" tab.

 

The FIRST and MOST IMPORTANT step is to run TftpdXX (32 or 64) as Administrator.  If you don't know how to do this, look it up.  Not running it as Administrator will cause your settings not to save.  This is all provided that you are running UAC.  If you aren't running UAC, then just do the following.....

 

Click on Settings:

6SmUL6f.png

 

Then click on the Global Tab and uncheck "DHCP Server":

vM1LD0e.png

 

Make any other changes that you would like to be standard and click "OK".  These settings will then be saved and loaded each time you open it.

 

You will need to restart the program for the changes to take effect.

 

Enjoy!

I hope I've helped someone.  (mainly me later) LOL



#5 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13644 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 13 July 2017 - 01:48 PM

I think the original question was about having the DHCP server enabled (because it is needed to assign IP addresses) BUT avoiding to serve a gateway/router address (for *whatever* reasons), like:

https://superuser.co...dhcp-in-openwrt

 

:duff:

Wonko



#6 Zoso_The_Internet_Tard

Zoso_The_Internet_Tard

    Silver Member

  • Advanced user
  • 544 posts
  • Interests:An investigation is underway to determine whether Trump has any ties to America.

Posted 14 July 2017 - 12:21 AM

Find a different software that doesn't try to force you to do things based on its' creator's wishes.







Also tagged with one or more of these keywords: tftpd64, dhcp, service edition

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users