Jump to content











Photo
- - - - -

Acronis True Image Home 10 Script


  • Please log in to reply
19 replies to this topic

#1 heinz.w

heinz.w
  • Members
  • 5 posts

Posted 09 April 2007 - 12:26 PM

Hello,

just built my first VistaPE CD. Now I tryed to built a script for Acronis True Image Home 10,
but without success (newcommer with those script things). Maybe someone already
has a running script for WB008. Those script mentioned hr for TI 9... is not working for
TI H 10. Thanks for help.

Regards, heinz.w

#2 NightMan

NightMan

    Frequent Member

  • .script developer
  • 433 posts
  • Location:Russian, Moscow

Posted 10 April 2007 - 02:12 PM

What error do you have? Script work very good (with small modification)

#3 heinz.w

heinz.w
  • Members
  • 5 posts

Posted 10 April 2007 - 04:45 PM

What error do you have? Script work very good (with small modification)

Hello,

with your script I have the following error message:

RegRead - Failed to read specified key from: [HKCU] Section: [Software\Acronis\UniversalRestore] Key: [enterprise] to variable: [%TmpReg%]

Also I have a new folder under Target\VistaPE\Progra Files\acronis\
timounter.dll
trueimage.exe

Don´t know if this is o.k.

heinz.w

#4 NightMan

NightMan

    Frequent Member

  • .script developer
  • 433 posts
  • Location:Russian, Moscow

Posted 11 April 2007 - 07:01 AM

RegRead - Failed to read specified key from:

it's key for UniversalRestore, TI Home not have UR option....

Also I have a new folder under

1. you need drivers snapapi.dll and snapman.sys
2. you need program files from BartPE folder:
acrotls.dll
fcalloc.dll
fnls.dll
fobject.dll
ftrace.dll
gc.dll
icu34.dll
icudt34.dll
rpc_client.dll
timounter.dll
TrueImage.exe

3. copy all files to one folder
4. modify acronis.script
remove FileCopy,"%pFileBox1%\TrueImage.exe","%TargetDir%\%DestDir%"
modify FileCopy,"%pFileBox1%\timounter.dll","%TargetDir%\%DestDir%" to FileCopy,"%pFileBox1%\*.*","%TargetDir%\%DestDir%"

al must work :cheers:

#5 heinz.w

heinz.w
  • Members
  • 5 posts

Posted 11 April 2007 - 04:34 PM

Thanks for your help, but it seems I do not have that script you talking
about. Do not find this commands.
(Yes I have all acronis files (from BartPE Folder) in one folder.
Will upload my script. Maybe you could have a look to it.
Seems there are some missing commands?
Would be great if you could add it.

Regards heinz.w

Attached Files



#6 NightMan

NightMan

    Frequent Member

  • .script developer
  • 433 posts
  • Location:Russian, Moscow

Posted 12 April 2007 - 01:24 PM

sorry, your script is very old...

Attached File  acronis.script   4.19KB   608 downloadsstandart script (TI Enterprise)

Attached File  acronis_tih.script   3.97KB   1031 downloadsTI 10 Home (you need this script)

#7 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 13 April 2007 - 11:32 AM

@ NightMan
I have installed both TrueImageHome and DiskDirector v10 using your script, and everything seems to be working well, except for Defrag in DiskDirector.

I had to make some small changes to the acronis_tih_script, however. They were:
1. Changed the RegWrite in [TI] from TrueImageEnterprise\Settings to TrueImageHome\Settings.
2. Changed the two RegReads in [DD] from HKCU to HKLM.
3. Changed the second RegRead in [DD] from Tmp_software to Software.
4. I found that I needed spawn.exe to make DiskDirector work. So while I was adding that, I added AutoPartNt.exe as well, and I put lines into [DD] to copy them over.

After running TrueImage, I found difficulty in opening/exploring the archive I had made. I think we need to add some file associations to get this going and maybe another file as well. I will come back on this when I have looked at it a bit more.

It is great to have a script for these two programs in VistaPE, as the latest versions are updated for Vista. :cheers:

#8 heinz.w

heinz.w
  • Members
  • 5 posts

Posted 13 April 2007 - 12:28 PM

True Image Home is running now here. Thanks NightMan.
Minor problem, I cannot open it from the start menu, (I have it in DiskTools),
but works from the exe.
By the way same with PDF Reader.

@martinr
Would be great if you could upload your file when you found a solution with
exploring in archives.

Greetings heinz.w

#9 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 13 April 2007 - 05:29 PM

@ heinz.w & NightMan
I have decided to abort the idea of using the Acronis Archive Explorer. To do so involved the addition of two files (tishell.dll and timntr.sys) and a load of extra registry entries. Even after doing this, I couldn't get it to work, and my researches showed that others had had trouble as well. Perhaps that is why Acronis didn't include the files in their BartPE plugin, and also why the explore option does not exist in the Tools section of their special TrueImage.exe (although they have left it in the top menu, where it does nothing).

I have had some success in getting Defrag to work in Disk Director. It turns out that they use the Microsoft files for this, which are not on the VistaPE disk. I have added them using the Windows XP files, as the Vista ones don't seem to work.

I am attaching my revised script which has all my amendments.

Attached Files



#10 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 14 April 2007 - 10:49 AM

Minor problem, I cannot open it from the start menu, (I have it in DiskTools),
but works from the exe.
By the way same with PDF Reader.

If you have recently downloaded PDF Reader, the reason it doesn't open from the start menu is that the name of the executable has changed. The old one was called Foxit Reader.exe; the new one is Foxit_Reader.exe.

You need to find the TXTAddLine in PDFReader.script which sets up the shortcut and put in the underscore character.

#11 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 14 April 2007 - 11:12 AM

@ heinz.w
Sorry, you also need to change the filename in the second line of the [Process] section, or otherwise you will download the PDF Reader program everytime that you run WinBuilder.

That will also give you the mkisofs message on build about a missing directory (the one with squares in its name). Incidentally, once you have deleted that folder (it is empty anyway), the error message goes away.

#12 heinz.w

heinz.w
  • Members
  • 5 posts

Posted 14 April 2007 - 11:22 AM

@martinr
Thanks for info. (That empty folder I found already).
Will try as soon as I find some time.

heinz.w

#13 NightMan

NightMan

    Frequent Member

  • .script developer
  • 433 posts
  • Location:Russian, Moscow

Posted 16 April 2007 - 07:04 AM

[FOXIT PDF Reader]

All fixed, test it :cheers:

Attached File  PDFReader.script   3.58KB   516 downloads

#14 carfan

carfan

    Frequent Member

  • Advanced user
  • 196 posts
  •  
    United States

Posted 23 April 2007 - 02:23 AM

@ heinz.w & NightMan
I have decided to abort the idea of using the Acronis Archive Explorer. To do so involved the addition of two files (tishell.dll and timntr.sys) and a load of extra registry entries. Even after doing this, I couldn't get it to work, and my researches showed that others had had trouble as well. Perhaps that is why Acronis didn't include the files in their BartPE plugin, and also why the explore option does not exist in the Tools section of their special TrueImage.exe (although they have left it in the top menu, where it does nothing).

I have had some success in getting Defrag to work in Disk Director. It turns out that they use the Microsoft files for this, which are not on the VistaPE disk. I have added them using the Windows XP files, as the Vista ones don't seem to work.

I am attaching my revised script which has all my amendments.


this is the script file i am using. can someone help me with a modification to add shorts cuts to the desktop and start menu???

thanks

#15 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 23 April 2007 - 09:00 AM

this is the script file i am using. can someone help me with a modification to add shorts cuts to the desktop and start menu???

The shortcuts for the start menu are already in the script. They are the last line in each of the sections [TI] and [DD]. If they are not working, it could be that you have elected to run the program from RAM. In this case you could try changing the shortcut lines to:
TXTAddLine,%ES%,"%LinkDir%\TrueImage.exe,Disk Tools\Acronis True Image Home.lnk,%LinkDir%","Append"

.....

TXTAddLine,%ES%,"%LinkDir%\DiskDirector.exe,Disk Tools\Acronis Disk Director.lnk,%LinkDir%","Append"
You could change them to that anyway; they should work in either case.

To get your desktop shortcuts, add an extra line at the end of each section, like this:
TXTAddLine,%ES%,"%LinkDir%\TrueImage.exe,!DS\Acronis True Image Home.lnk,%LinkDir%","Append"

.....

TXTAddLine,%ES%,"%LinkDir%\DiskDirector.exe,!DS\Acronis Disk Director.lnk,%LinkDir%","Append"
I haven't tried the desktop shortcuts myself, but I am sure they will work for you, unless you already have 6 to 8 shortcuts on your desktop, in which case you will have a quite different problem if using LiteStep (see here).

#16 Notebook

Notebook
  • Members
  • 3 posts

Posted 12 July 2007 - 05:28 PM

All greetings!
At me a problem with DD at use of given script NightMan:


[Main]
Title=Acronis Utilities
Author=NightMan
Level=5
Version=007
Description=
Locked=false
Contact=vistape@gmail.com
Date=16.03.2007
Selected=True

[Process]
Echo,Processing Acronis...
If,%pCheckBox5%,Equal,true,SET,"%DestDir%","Progra~1\acronis"
If,%pCheckBox5%,Equal,false,SET,"%DestDir%","Programs\acronis"
If,%pCheckBox5%,Equal,true,SET,"%LinkDir%","%SystemDrive%\Progra~1\acronis"
If,%pCheckBox5%,Equal,false,SET,"%LinkDir%","y:\acronis"
If,NotExistFile,"%pFileBox1%\snapapi.dll",run,%ScriptFile%,NotFound
If,NotExistFile,"%pFileBox1%\snapman.sys",run,%ScriptFile%,NotFound
System,RefreshVars
DirMake,"%TargetDir%\%DestDir%"
FileCopy,"%pFileBox1%\snapapi.dll","%TargetDir%\Windows\System32"
FileCopy,"%pFileBox1%\snapman.sys","%TargetDir%\Windows\System32\drivers"
RegHiveLoad,Tmp_setupreg_hiv,%RegSystem%
RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Services\snapman","DisplayName","Acronis Snapshots Manager"
RegWrite,HKLM,0x4,"Tmp_setupreg_hiv\ControlSet001\Services\snapman","ErrorControl","1"
RegWrite,HKLM,0x4,"Tmp_setupreg_hiv\ControlSet001\Services\snapman","Start","0"
RegWrite,HKLM,0x4,"Tmp_setupreg_hiv\ControlSet001\Services\snapman","Type","1"
RegWrite,HKLM,0x2,"Tmp_setupreg_hiv\ControlSet001\Services\snapman","ImagePath","system32\DRIVERS\snapman.sys"
ShellExecute,Hide,reg.exe,"ADD HKLM\Tmp_setupreg_hiv\ControlSet001\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318} /f /v UpperFilters /t REG_MULTI_SZ /d PartMgrsnapman"
RegWrite,HKLM,0x7,"Tmp_setupreg_hiv\ControlSet001\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F}","UpperFilters","snapman"
RegHiveUnLoad,Tmp_setupreg_hiv
If,ExistFile,"%pFileBox1%\TrueImage.exe",run,%ScriptFile%,TI
If,ExistFile,"%pFileBox1%\DiskDirector.exe",run,%ScriptFile%,DD

[TI]
FileCopy,"%pFileBox1%\TrueImage.exe","%TargetDir%\%DestDir%"
FileCopy,"%pFileBox1%\timounter.dll","%TargetDir%\%DestDir%"
RegHiveLoad,Tmp_software,%RegSoftware%
RegWrite,HKLM,0x1,"Tmp_software\Acronis\TrueImageEnterprise\Settings","WorkingDir","%LinkDir%"
RegRead,HKLM,"Software\Acronis\UniversalRestore","enterprise","%TmpReg%"
RegWrite,HKLM,0x1,"Tmp_software\Acronis\UniversalRestore","enterprise","%TmpReg%"
RegHiveUnLoad,Tmp_software
If,%pCheckBox1%,Equal,true,IniWriteTextLine,"%TargetDir%\Windows\System32\PEShell.ini","Shells","Acronis True Image=#$q%LinkDir%\TrueImage.exe#$q"
TXTAddLine,%ES%,"%DestDir%\TrueImage.exe,Disk Tools\Acronis True Image Enterprise.lnk,%DestDir%","Append"

[DD]
FileCopy,"%pFileBox1%\DiskDirector.exe","%TargetDir%\%DestDir%"
RegHiveLoad,Tmp_software,%RegSoftware%
RegRead,HKCU,"Software\Acronis\Acronis Disk Director\MAIN","Password","%TmpReg%"
RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\MAIN","Password","%TmpReg%"
RegRead,HKCU,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"
RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"
RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\Settings","ExePath","%LinkDir%\DiskDirector.exe"
RegHiveUnLoad,Tmp_software
If,%pCheckBox2%,Equal,true,IniWriteTextLine,"%TargetDir%\Windows\System32\PEShell.ini","Shells","Acronis Disk Director=#$q%LinkDir%\DiskDirector.exe#$q"
TXTAddLine,%ES%,"%DestDir%\DiskDirector.exe,Disk Tools\Acronis Disk Director.lnk,%DestDir%","Append"

[NotFound]
Message,"The path you specified as your source is not valid! #$x#$xPlease select a valid source dir in the script configuration window..."
Exit,"Exiting..."

[Interface]
pTextLabel1="You need copy necessaries files to plugin source folder",1,1,9,10,315,24,8,Normal
pTextLabel2="""snapapi.dll"" and ""snapman.sys"" - common files",1,1,9,27,230,18,8,Normal
pTextLabel4="""timounter.dll"" and ""TrueImage.exe"" - for Acronis True Image",1,1,9,42,372,18,8,Normal
pTextLabel5="""DiskDirector.exe"" - for Acronis Disk Director",1,1,9,57,380,18,8,Normal
pTextLabel6="Please use files only from ""BartPE"" folder",1,1,9,73,230,18,8,Normal
pCheckBox5="Run from ram (boot.wim)",1,3,9,135,198,21,True
pCheckBox1="Add TI to PE Shell",1,3,9,169,200,18,True
pCheckBox2="Add DD to PE Shell",1,3,9,189,200,18,True
pFileBox1="C:\WinBuilder\Projects\VistaPE\App\Disk Tools\acronis",1,13,81,94,208,28,dir
pTextLabel7="Source folder",1,1,9,99,72,18,8,Normal


At attempt to start DD I receive following result:
Posted Image
Log:
http://rapidshare.co...534850/log.html

There is a decision of the given problem?

P.S. I apologize for, probably, bad English. Translation - machine.

#17 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 13 July 2007 - 09:53 AM

@ Notebook

I hate to criticise anything which NightMan does, because he produces some wonderful work. In this case, however, I think that he made a mistake in his script.

The part that needs altering is the following in the [DD] section:
RegRead,HKCU,"Software\Acronis\Acronis Disk Director\MAIN","Password","%TmpReg%"

RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\MAIN","Password","%TmpReg%"

RegRead,HKCU,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"

RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"

I see from the script which I am using that I changed it to::
RegRead,HKLM,"Software\Acronis\Acronis Disk Director\MAIN","Password","%TmpReg%"

RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\MAIN","Password","%TmpReg%"

RegRead,HKLM,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"

RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"

The Password and key data appears in the HKLM part of the registry, not HKCU.

It is of course essential to have Disk Director installed on your machine, or otherwise the registry entries won't be there to copy over.

#18 Notebook

Notebook
  • Members
  • 3 posts

Posted 13 July 2007 - 11:21 AM

To martinr
I have closely read through all branch and your previous post on this subject too. Tried to make how you have written. As a result it is not loaded at all VistaPE. Here a screenshot:
Posted Image
Log:
Attached File  log.html   1.13MB   2104 downloads
Yours faithfully, Notebook

#19 martinr

martinr

    Frequent Member

  • Advanced user
  • 120 posts

Posted 13 July 2007 - 12:11 PM

@ Notebook
It seems strange that the small alteration I suggested should have caused so many errors in your build! I think that you must have done some other things by accident before running WinBuilder.

For example, I see from your log that you had selected the German language script, the Russian language and also the UK English language. You should only run one of these, not all three. From the text in the log, it looks as if it should be Russian. The German script threw up several errors when it ran, so do make sure that you turn it off.

Just looking at the Acronis script, the log shows that it could not read your registration key from HKLM\SOFTWARE\Acronis\Acronis Disk Director\Settings in your registry. This may be because you are using a Demo version of the program. Open the registry on your machine, and look to see if there is a value there called "key". If there isn't, you need to comment out these two lines in the script:
RegRead,HKLM,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"

RegWrite,HKLM,0x1,"Tmp_software\Acronis\Acronis Disk Director\Settings","key","%TmpReg%"
You can do this by placing a # symbol at the start of each line.

What I would next do is to check all the selections you have made in WinBuilder and then make another build.

If you still have a problem, I will send you my Acronis script which definitely works.

Last thing, I think that the winload error you got is probably caused by all the errors in the log. Another common cause of this is building on a FAT 32 partition. You should always use NTFS for VistaPE.

Let me know how you get on.

#20 Notebook

Notebook
  • Members
  • 3 posts

Posted 17 July 2007 - 09:08 PM

To martinr
Thanks you for council about change lines in the script. Possibly, all over again I have committed a mistake in change of these lines. At repeated change all has earned. It is unique, that the question on this here already does not work also rose - impossibility of start defrag and checks of disks on mistakes. There is a decision of the given problem?
Notebook

And, certainly, thanks NightMan for his scripts!!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users