Jump to content











Photo
- - - - -

Booting Android x86

android x86 eassy2boot usb boot

  • Please log in to reply
8 replies to this topic

#1 Aleksey09

Aleksey09
  • Members
  • 9 posts
  • Location:somewhere in Argentina
  • Interests:Computer hardware and learn to use Grub4Dos
  •  
    Argentina

Posted 04 October 2013 - 07:52 PM

Good afternoon to everybody:

2 months ago, I started modificating the english project "EASY2BOOT" (http://www.rmprepusb...-maintain/e2bv1) translating it to spanish and making to my jobs (i´m a computer techniciant).

Y finished the modification 2 weeks ago and works perfectly (i can boot hiren´s boot, windows xp, 7 and vista besides a copule GNU/Linux Distros), and now i´m trying to boot the project Android x86 (http://www.android-x86.org/download), thing to difficult to my skills. Now i need your help to could boot it and probe its functions (is Live-CD and Instalable).

 

Thanks from now. If you need help, just say it.



#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6559 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 October 2013 - 08:23 PM

Android x86 boots under E2B. Just add the .iso file to a menu folder (e.g. \_ISO\MAINMENU). It is listed in the tutorial - is there a problem?



#3 Aleksey09

Aleksey09
  • Members
  • 9 posts
  • Location:somewhere in Argentina
  • Interests:Computer hardware and learn to use Grub4Dos
  •  
    Argentina

Posted 04 October 2013 - 10:32 PM

Yes, it doesn´t work. In my project modifications, to boot an iso image, i have to use the iso load´s codes described in a file in a e2b folder (i dont know which file, but it explines how to boot diferent image types).

When i execute the image´s codes, it gave me a boot error



#4 steve6375

steve6375

    Platinum Member

  • Developer
  • 6559 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 October 2013 - 10:36 PM

Maybe you have broken something?  \_ISO\e2b\grub\QRUN.g4b  is the file that runs the ISO. Try using the latest version of it.



#5 Aleksey09

Aleksey09
  • Members
  • 9 posts
  • Location:somewhere in Argentina
  • Interests:Computer hardware and learn to use Grub4Dos
  •  
    Argentina

Posted 04 October 2013 - 10:47 PM

This is the code i use to boot andriod x86,

 

iftitle [if exist /_ISO/TOOLBOX/android43.iso] ^F4 [F4]  ANDROID x86 4.3 --BETA--\n Proyecto de Android adaptado para la arquitectura x86 - Version Live CD/Instalable.
partnew (hd0,3) 0x0 %1
map  /_ISO/TOOLBOX/android43.iso (0xff) || map --mem /_ISO/TOOLBOX/android43.iso (0xff)
map --hook
root (0xff) || rootnoverify (0xff)
chainloader (0xff)
boot

Edited by Aleksey09, 04 October 2013 - 10:47 PM.


#6 steve6375

steve6375

    Platinum Member

  • Developer
  • 6559 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 October 2013 - 10:54 PM

The code in QRUN.g4b should be very similar???  Look under  :.iso   label.



#7 Aleksey09

Aleksey09
  • Members
  • 9 posts
  • Location:somewhere in Argentina
  • Interests:Computer hardware and learn to use Grub4Dos
  •  
    Argentina

Posted 04 October 2013 - 11:25 PM

There is the error.

http://imageshack.us...s/820/pqit.png/

The code i use is:

 

iftitle [if exist /_ISO/TOOLBOX/android43.iso] ^F4 [F4]  ANDROID x86 4.3 --BETA--\n Proyecto de Android adaptado para la arquitectura x86 - Version Live CD/Instalable.
/%grub%/QRUN.g4b /_ISO/TOOLBOX/android43.iso


#8 steve6375

steve6375

    Platinum Member

  • Developer
  • 6559 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 05 October 2013 - 09:55 AM

I download android-x86-4.3-20130725.iso and copied it to the \_ISO\MAINMENU folder - it boots fine!

 

You must either have a bad ISO or you have broken E2B.

 

Try 'RMPrepUSB - File - Boot from ISO file using QEMU emulator'   on the ISO file on the USB drive.



#9 Aleksey09

Aleksey09
  • Members
  • 9 posts
  • Location:somewhere in Argentina
  • Interests:Computer hardware and learn to use Grub4Dos
  •  
    Argentina

Posted 06 October 2013 - 01:14 AM

I download android-x86-4.3-20130725.iso and copied it to the \_ISO\MAINMENU folder - it boots fine!

 

You must either have a bad ISO or you have broken E2B.

 

Try 'RMPrepUSB - File - Boot from ISO file using QEMU emulator'   on the ISO file on the USB drive.

 Steve, i don´t know what is happening to me, i downloaded the iso again, i boot it and happen the same problem...







Also tagged with one or more of these keywords: android x86, eassy2boot, usb boot

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users