Jump to content











Photo

Bug Reports, Requests, HowTo's about Tiny PXE Server

pxe network boot

  • Please log in to reply
805 replies to this topic

#801 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2404 posts
  • Location:Nantes - France
  •  
    France

Posted 11 December 2018 - 10:41 AM

EDon

 

Ok, can I make clear what exactly should I use in GUI setting for the Next server, and do I need to use BINL and ProxyDhcp?

 

The computer where pxesrv is running is at IP 192.168.137.5

The machine which I network boot is a VirtulBox guest on computer with IP 192.168.137.2 (bridged to VM)

The router runs own DHCP server at IP 192.168.137.1

 

Is http://${dhcp-server} the correct value?

 

-Dont use BINL : dont need it.

 

-Do use proxyDHCP : you do need it since you have a DHCP server on your lan (dont compete with it)

 

-The screenshot you posted previous is incorrect : listening IP/next server should be 192.168.137.5 NOT 192.168.137.2 !

 

-http://${dhcp-server} may work but prefer http://${next-server} .

 

-Leave OPT66 empty and if you ever decide to use this option it should NOT be 192.168.137.2 (based on your previous screenshot)

 

Looks like you are confusing your "client" IP with your "server" IP ???



#802 Franz Ferdinand II.

Franz Ferdinand II.

    Newbie

  • Members
  • 13 posts
  •  
    Macedonia

Posted 11 December 2018 - 10:57 AM

Thanks again for all the input. Now it finally appears to work

The last problem I have with it is it doesn't boot as UEFI machine (I must switch BIOS to compatibility mode).

Is the non-UEFI mode the only way how can I access the network bootloader?


Edited by Franz Ferdinand II., 11 December 2018 - 10:57 AM.


#803 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2404 posts
  • Location:Nantes - France
  •  
    France

Posted 11 December 2018 - 11:00 AM

Thanks again for all the input. Now it finally appears to work

The last problem I have with it is it doesn't boot as UEFI machine (I must switch BIOS to compatibility mode).

Is the non-UEFI mode the only way how can I access the network bootloader?

 

UEFI is well working but probably not using memdisk or sanboot.

 

I recommend using wimboot method.

Lots of threads about this on this forum like this one.



#804 Franz Ferdinand II.

Franz Ferdinand II.

    Newbie

  • Members
  • 13 posts
  •  
    Macedonia

Posted 11 December 2018 - 11:10 AM

I am pretty sure it has nothing to do with ISO load method but not detecting the PXE layer at all.

All I get on boot in UEFI mode is this screen:

 

JtL3kZL.png



#805 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14520 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 11 December 2018 - 11:31 AM

@Franz Ferdinand II.

 

It is difficult (please read as impossible) to try and help you unless you communicate ALL you are doing/have tested..

 

You now posted the results without the settings you used :frusty: , I am pretty sure you know what these ar, the issue is that we cannot know them unless you post them.

 

Just in case, Standard Litany  :

https://jdebp.eu/FGA...ard-litany.html

 

:duff:

Wonko



#806 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2404 posts
  • Location:Nantes - France
  •  
    France

Posted 15 December 2018 - 06:22 PM

About previous post from Franz Ferdinand II and PXE Booting with UEFI, a common mistake when using UEFI and ProxyDHCP is to NOT set option 60=PXEClient (i.e based on my experience it MUST be set).

 

As a whole, PXE booting, although "fun" (for some of us), is "not easy" and requires basic network knowledge, riguor and method.

Anyone can achieve if any of the 3 qualities above is missing, failure rate will increase.







Also tagged with one or more of these keywords: pxe, network boot

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users