Jump to content











Photo

Bug Reports, Requests, HowTo's about Tiny PXE Server

pxe network boot

  • Please log in to reply
779 replies to this topic

#326 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 13 July 2015 - 08:18 PM

I do not believe the proxy DHCP needs such a logic.

 

Not sure.

 

I am doing nothing in the discover phase under proxydhcp (whereas I do send back some datas under dhcp).

 

Plus, under proxydhcp, the host already has an IP (from the dhcp server) and I am sending 0.0.0.0 as IP (per proxydhcp RFC).

 

EDIT : had wrongly read you, you actually do NOT believe ... so we are on the same line :)



#327 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 13 July 2015 - 08:22 PM

may i be able to by pass the dhcp logic by setting up static entrys?

 

I did run Wireshark during the pxe boot and I'd like to try to share the report with you, if it helps shinning a light on the problem :).

 

 

 

 

I hope that works and has the necessary information you requested.

 

thanks

Robert

 

Your pxe client is sending pxelinux.0 plus lots of garbage behing the filename.

It could be because it was expecting a null char from my server.

 

Some old pxe client do that (what are you devices by the way?).

 

Try the below : 

added : will replace \0 by null char for opt60,66,67 (some pxe clients require a null terminated string there)

 

This applies to the config.ini but should work as well in the text fields.



#328 robertapi

robertapi
  • Members
  • 8 posts
  •  
    Germany

Posted 14 July 2015 - 07:36 AM

Your pxe client is sending pxelinux.0 plus lots of garbage behing the filename.

It could be because it was expecting a null char from my server.

 

Some old pxe client do that (what are you devices by the way?).

 

Try the below : 

added : will replace \0 by null char for opt60,66,67 (some pxe clients require a null terminated string there)

 

This applies to the config.ini but should work as well in the text fields.

 

The machines are some pretty old embeded pcs (embeded mainboard 986LCD-M /mITX, celeron pc, all in all not very up2date) i did update the bios as i thought that maybe fixes the problem, but as luck would have it, it didnt.

 

i did download the pxesrv.zip today and the fix you implemented for the dhcp server works like charm, thank you very much you are the best!

 

I Did try the "\0" after my opt67 but it just wrote it into the optionfield from the pxesrv.exe and seemed to think thats part of the string.

which results in the following:

 

08:59:18 ROOT=C:\pxesrv\files\pxelinux.0\

08:59:34 TFTPd:DoReadFile OpenError:pxelinux.0 Cannot open file "C:\pxesrv\files\pxelinux.0\pxelinux.0". Das System kann den angegebenen Pfad nicht finden
08:59:34 TFTPd:DoReadFile OpenError:pxelinux.0 Cannot open file "C:\pxesrv\files\pxelinux.0\pxelinux.0". Das System kann den angegebenen Pfad nicht finden

 

root=files seems to be updated by the "pxelinux.0  \0" as well, the log indicates that it thinks the rootfolder is now located at "C:\pxesrv\files\pxelinux.0\" which it isnt and trying to find the pxe.linux.0 in a non existent folder wont work :)

 

It obvious to me, that i'm doing it wrong, but what would be the way to go about it right?

 

My bush-fix at the moment: i run tftpd32 as pxe server and tinypxe server as dhcp and it will boot, with tinypxe server alone it wont.

 

Interestingly tftpd32 does need the fix you proposed with the termination of the opt67 parameter.

This only works with "opt67=pxelinux.0\0" and wont if i leave out the \0 part.

 

If i run tftpd alone i dont need to specifiy the boot file with the  added "\0" in the dhcp options, it starts the pxe boot menu right away.

This is very strange maybe it is a indicator to you what i am doing wrong.

 

I am in awe how fast you are and with implementing the fixes to your program, thumbs up and a big big thanks!

 

greetings 

Robert



#329 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 14 July 2015 - 08:21 AM

The machines are some pretty old embeded pcs (embeded mainboard 986LCD-M /mITX, celeron pc, all in all not very up2date) i did update the bios as i thought that maybe fixes the problem, but as luck would have it, it didnt.

 

i did download the pxesrv.zip today and the fix you implemented for the dhcp server works like charm, thank you very much you are the best!

 

I Did try the "\0" after my opt67 but it just wrote it into the optionfield from the pxesrv.exe and seemed to think thats part of the string.

which results in the following:

 

08:59:18 ROOT=C:\pxesrv\files\pxelinux.0\

08:59:34 TFTPd:DoReadFile OpenError:pxelinux.0 Cannot open file "C:\pxesrv\files\pxelinux.0\pxelinux.0". Das System kann den angegebenen Pfad nicht finden
08:59:34 TFTPd:DoReadFile OpenError:pxelinux.0 Cannot open file "C:\pxesrv\files\pxelinux.0\pxelinux.0". Das System kann den angegebenen Pfad nicht finden

 

root=files seems to be updated by the "pxelinux.0  \0" as well, the log indicates that it thinks the rootfolder is now located at "C:\pxesrv\files\pxelinux.0\" which it isnt and trying to find the pxe.linux.0 in a non existent folder wont work :)

 

It obvious to me, that i'm doing it wrong, but what would be the way to go about it right?

 

My bush-fix at the moment: i run tftpd32 as pxe server and tinypxe server as dhcp and it will boot, with tinypxe server alone it wont.

 

Interestingly tftpd32 does need the fix you proposed with the termination of the opt67 parameter.

This only works with "opt67=pxelinux.0\0" and wont if i leave out the \0 part.

 

If i run tftpd alone i dont need to specifiy the boot file with the  added "\0" in the dhcp options, it starts the pxe boot menu right away.

This is very strange maybe it is a indicator to you what i am doing wrong.

 

I am in awe how fast you are and with implementing the fixes to your program, thumbs up and a big big thanks!

 

greetings 

Robert

 

 

try the \0 in the ini file.

root=C:\pxesrv\files

opt60=PXEClient\0

opt66=<your_ip>\0

opt67=pxelinux.0\0

 

Last time I checked it was working.

I'll review my code today to be sure.

 

EDIT : i confirm that you need to edit the config.ini as you cannot edit textfield opt67.

EDIT2 : I also confirm a bug with ROOT when adding \0 to OPT67 -> fixing it.



#330 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 14 July 2015 - 08:49 AM

New version uploaded.

 

fixed : bug on \0 after introducing http support in root field

 

The below should now work fine without messing the root path.

Hopefully that should enable your embeded mainboard 986LCD-M /mITX to pxe boot.

 

root=C:\pxesrv\files

opt60=PXEClient\0

opt66=<your_ip>\0

opt67=pxelinux.0\0



#331 robertapi

robertapi
  • Members
  • 8 posts
  •  
    Germany

Posted 14 July 2015 - 08:59 AM

try the \0 in the ini file.

root=C:\pxesrv\files

opt60=PXEClient\0

opt66=<your_ip>\0

opt67=pxelinux.0\0

 

Last time I checked it was working.

I'll review my code today to be sure.

 

EDIT : i confirm that you need to edit the config.ini as you cannot edit textfield opt67.

EDIT2 : I also confirm a bug with ROOT when adding \0 to OPT67 -> fixing it.

 

i was about the answer to your post, as i read the edits while quoting you.

If i configure opt60=pxeclient\0 or pxeclient it seems to break the dhcp service

 

 

10:51:56 ROOT=C:\pxesrv\files\pxelinux.0\
10:51:56 DHCPd:67 started...
10:51:56 TFPTd started...
10:52:19 DHCPd:DISCOVER received, MAC:00-E0-F4-25-E8-25, XID:F525E825
10:52:19 DHCPd:OFFER sent, IP:192.168.100.2, XID:F525E825
10:52:21 DHCPd:REQUEST received, MAC:00-E0-F4-25-E8-25, XID:F525E825
10:52:21 DHCPd:ACK sent, IP:192.168.100.2, XID:F525E825
10:52:23 DHCPd:RELEASE received, MAC:00-E0-F4-25-E8-25, XID:F525E825
10:52:23 DHCPd:DISCOVER received, MAC:00-E0-F4-25-E8-25, XID:F625E825
10:52:23 DHCPd:OFFER sent, IP:192.168.100.3, XID:F625E825
10:52:27 DHCPd:REQUEST received, MAC:00-E0-F4-25-E8-25, XID:F625E825
10:52:27 DHCPd:ACK sent, IP:192.168.100.3, XID:F625E825
10:52:31 DHCPd:RELEASE received, MAC:00-E0-F4-25-E8-25, XID:F625E825
10:52:32 DHCPd:DISCOVER received, MAC:00-E0-F4-25-E8-25, XID:F725E825
10:52:32 DHCPd:OFFER sent, IP:192.168.100.4, XID:F725E825

 

if i disable the option with ; it will try to start (but cant with the root folder problem)

As i havnt had a clue what dhcp option 60 is for, i found for example this:

 

http://www.experts-e...without-it.html

 

which is true for my setup, so i dont need to configure it, wanted to let you know about the possible bug though.

 

 

thanks for the reply

Robert



#332 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 14 July 2015 - 09:01 AM

i was about the answer to your post, as i read the edits while quoting you.

If i configure opt60=pxeclient\0 or pxeclient it seems to break the dhcp service

 

 

if i disable the option with ; it will try to start (but cant with the root folder problem)

As i havnt had a clue what dhcp option 60 is for, i found for example this:

 

http://www.experts-e...without-it.html

 

which is true for my setup, so i dont need to configure it, wanted to let you know about the possible bug though.

 

 

thanks for the reply

Robert

 

Ok, indeed, if you were not using it before, ignore it then.

Focus only on opt66 and opt67 then, using latest version from a few mns ago (which fixes the root path issue).

 

EDIT : have you tried using the simple bootp filename field in place of the pxe options opt66/67?

The bootp filename field is null char terminated by design, no need to use the \0 trick.

 

So to sum up, you should be able to either use the opt66/opt67 with the \0 trick OR use the simple bootp filename (to be verified).



#333 robertapi

robertapi
  • Members
  • 8 posts
  •  
    Germany

Posted 14 July 2015 - 09:13 AM

Ok, indeed, if you were not using it before, ignore it then.

Focus only on opt66 and opt67 then, using latest version from a few mns ago (which fixes the root path issue).

 

EDIT : have you tried using the simple bootp filename field in place of the pxe options opt66/67?

The bootp filename field is null char terminated by design, not need to use the \0 trick.

 

So to sum up, you should be able to either use the opt66/opt67 with the \0 trick OR use the simple bootp filename (to be verified).

 

I dont have words for the amount of support you made available to me, T H A N K S!!!

 

The root fix, fixed my problems, the \0 works with the ancient embebed pcs, holy smokes thats so awesome :)

 

Bootp filename: no i havn't tryed this yet, but for now i'm very happy with the working solution i have.

 

have a very nice day, dear kind sir!

Robert



#334 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 14 July 2015 - 09:21 AM

I dont have words for the amount of support you made available to me, T H A N K S!!!

 

The root fix, fixed my problems, the \0 works with the ancient embebed pcs, holy smokes thats so awesome :)

 

Bootp filename: no i havn't tryed this yet, but for now i'm very happy with the working solution i have.

 

have a very nice day, dear kind sir!

Robert

 

 

Well I am happy that you are happy :)

 

And you also contributed to improve Tiny PXE Server so thanks for that too !



#335 robertapi

robertapi
  • Members
  • 8 posts
  •  
    Germany

Posted 14 July 2015 - 09:33 AM

About the bootp filename:

 

i did just now try the boot file, filename Option field in the pxesrv.exe and it did work fine as well, i somehow assumed i would need that for ipxe (and as i am new to all of this, i assumed i wont need it and skipped that part of the options entirely).

 

looks like if i had configured the program the right way from the start, i wouldnt have needed the work around with the \0 termination.

 

Robert



#336 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 14 July 2015 - 10:03 AM

About the bootp filename:

 

i did just now try the boot file, filename Option field in the pxesrv.exe and it did work fine as well, i somehow assumed i would need that for ipxe (and as i am new to all of this, i assumed i wont need it and skipped that part of the options entirely).

 

looks like if i had configured the program the right way from the start, i wouldnt have needed the work around with the \0 termination.

 

Robert

 

Dont worry, you did well in reporting your issues.

There was a real issue with the DHCP logic and the opt66/67 "\0" trick was broken (it had been introduced a few versions ago).

So, all in all, Tiny PXE Server is "better" now than it was before you reported your issues.

 

About network booting, there are different ways to proceed (bootp, dhcp, proxydhcp, pxe options, etc) with pros and cons and depending on your environement.

 

Cheers,

Erwan



#337 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 218 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 17 July 2015 - 07:32 PM

Always use version 1.0.0.11 and no any problems.But now test 1.0.0.19. If click Offline button, change boot file from pxelinux.0 to e.g. grldr and click Online button Tiny PXE Server still serve pxelinux.0 instead grldr :-( why? Does TPS saves the settings in the registry? I noticed it using a virtual machine MS VPC2007.

P.S. After reboot (switch OFF and switch ON) VPC all working OK and machine get bootfile from TPS.
Maybe a problem with the VPC and not the TPS?
I use the TPS with VPC2007 a very long time but the first time I met up with such a problem.

#338 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 17 July 2015 - 07:58 PM

Always use version 1.0.0.11 and no any problems.But now test 1.0.0.19. If click Offline button, change boot file from pxelinux.0 to e.g. grldr and click Online button Tiny PXE Server still serve pxelinux.0 instead grldr :-( why? Does TPS saves the settings in the registry? I noticed it using a virtual machine MS VPC2007.

P.S. After reboot (switch OFF and switch ON) VPC all working OK and machine get bootfile from TPS.
Maybe a problem with the VPC and not the TPS?
I use the TPS with VPC2007 a very long time but the first time I met up with such a problem.

 

TPS does not save any settings in the registry.

All is saved in the ini file (only if you "right click / save to ini").

 

Check your ini file, it may have multiple "filename=" entries (seen that before).

 

You should use version 1.0.0.19 : i have introduced many changes and fixes since 1.0.0.11.



#339 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 218 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 17 July 2015 - 08:40 PM

OK, but I noticed another mistake. Boot Agent in VMware Workstation 8.0 does not start with TPS 1.0.0.19. After change TPS to 1.0.0.11 all working OK.
Attached File  xp-2015-07-17-22-41-07.png   5.65KB   0 downloads
If switch ON ProxyDHCP in 1.0.0.19 still not boot:
22:42:53 ProxyDhcp enabled
22:42:53 restart service
22:43:01 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:43:02 DHCPd:OFFER sent, IP:0.0.0.0, XID:2A6E5F62
22:43:04 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:43:04 DHCPd:OFFER sent, IP:0.0.0.0, XID:2B6E5F62
22:43:08 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:43:08 DHCPd:OFFER sent, IP:0.0.0.0, XID:2C6E5F62
22:43:16 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
22:43:16 DHCPd:OFFER sent, IP:0.0.0.0, XID:2D6E5F62
Without ProxyDHCP enabled:
22:51:30 ROOT=C:\PXE\
22:51:30 DHCPd:67 started...
22:51:30 TFPTd started...
22:51:31 HTTPd started...
22:51:31 PID created: 644
22:51:39 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:51:40 DHCPd:OFFER sent, IP:192.168.20.4, XID:2A6E5F62
22:51:41 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:51:42 DHCPd:ACK sent, IP:192.168.20.4, XID:2A6E5F62
22:51:44 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:51:44 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:51:45 DHCPd:OFFER sent, IP:192.168.20.4, XID:2B6E5F62
22:51:48 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:51:49 DHCPd:ACK sent, IP:192.168.20.4, XID:2B6E5F62
22:51:53 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:51:53 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:51:54 DHCPd:OFFER sent, IP:192.168.20.4, XID:2C6E5F62
22:52:01 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:52:02 DHCPd:ACK sent, IP:192.168.20.4, XID:2C6E5F62
22:52:10 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:52:10 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
22:52:11 DHCPd:OFFER sent, IP:192.168.20.4, XID:2D6E5F62
22:52:26 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
22:52:27 DHCPd:ACK sent, IP:192.168.20.4, XID:2D6E5F62
22:52:43 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
From TPS 1.0.0.11 VMware boot normal from pxelinux.0:
22:45:44 DHCPd:incoming packet from : .00.0C.29.6E.5F.62
22:45:44 DHCPd:DHCP_DISCOVER received, xid:625F6E2A
22:45:44 DHCPd:DHCP_OFFER sent, IP:192.168.20.4, xid:625F6E2A
22:45:46 DHCPd:incoming packet from : .00.0C.29.6E.5F.62
22:45:46 DHCPd:DHCP_REQUEST received, xid:625F6E2A
22:45:47 DHCPd:DHCP_ACK sent, IP:192.168.20.4, xid:625F6E2A
22:45:47 TFTPd:DoReadFile:pxelinux.0 B:1456 T:0


#340 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 218 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 17 July 2015 - 09:10 PM

I use this option in config.ini:
opt66=$dhcp
opt60=PXEClient
opt43=0.0.0.0
In TPS 1.0.0.11 with this options VMware boot.
In TPS 1.0.0.19 with this options VMware not boot. After delete or comment this options VMware boot.

#341 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 09:24 AM

I use this option in config.ini:

opt66=$dhcp
opt60=PXEClient
opt43=0.0.0.0
In TPS 1.0.0.11 with this options VMware boot.In TPS 1.0.0.19 with this options VMware not boot. After delete or comment this options VMware boot.

What is $dhcp?
What about opt67?
Can you post the entire ini?

#342 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 09:26 AM

OK, but I noticed another mistake. Boot Agent in VMware Workstation 8.0 does not start with TPS 1.0.0.19. After change TPS to 1.0.0.11 all working OK.attachicon.gifxp-2015-07-17-22-41-07.pngIf switch ON ProxyDHCP in 1.0.0.19 still not boot:

22:42:53 ProxyDhcp enabled
22:42:53 restart service
22:43:01 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:43:02 DHCPd:OFFER sent, IP:0.0.0.0, XID:2A6E5F62
22:43:04 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:43:04 DHCPd:OFFER sent, IP:0.0.0.0, XID:2B6E5F62
22:43:08 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:43:08 DHCPd:OFFER sent, IP:0.0.0.0, XID:2C6E5F62
22:43:16 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
22:43:16 DHCPd:OFFER sent, IP:0.0.0.0, XID:2D6E5F62
Without ProxyDHCP enabled:
22:51:30 ROOT=C:\PXE\
22:51:30 DHCPd:67 started...
22:51:30 TFPTd started...
22:51:31 HTTPd started...
22:51:31 PID created: 644
22:51:39 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:51:40 DHCPd:OFFER sent, IP:192.168.20.4, XID:2A6E5F62
22:51:41 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:51:42 DHCPd:ACK sent, IP:192.168.20.4, XID:2A6E5F62
22:51:44 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2A6E5F62
22:51:44 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:51:45 DHCPd:OFFER sent, IP:192.168.20.4, XID:2B6E5F62
22:51:48 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:51:49 DHCPd:ACK sent, IP:192.168.20.4, XID:2B6E5F62
22:51:53 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2B6E5F62
22:51:53 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:51:54 DHCPd:OFFER sent, IP:192.168.20.4, XID:2C6E5F62
22:52:01 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:52:02 DHCPd:ACK sent, IP:192.168.20.4, XID:2C6E5F62
22:52:10 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2C6E5F62
22:52:10 DHCPd:DISCOVER received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
22:52:11 DHCPd:OFFER sent, IP:192.168.20.4, XID:2D6E5F62
22:52:26 DHCPd:REQUEST received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
22:52:27 DHCPd:ACK sent, IP:192.168.20.4, XID:2D6E5F62
22:52:43 DHCPd:RELEASE received, MAC:00-0C-29-6E-5F-62, XID:2D6E5F62
From TPS 1.0.0.11 VMware boot normal from pxelinux.0:
22:45:44 DHCPd:incoming packet from : .00.0C.29.6E.5F.62
22:45:44 DHCPd:DHCP_DISCOVER received, xid:625F6E2A
22:45:44 DHCPd:DHCP_OFFER sent, IP:192.168.20.4, xid:625F6E2A
22:45:46 DHCPd:incoming packet from : .00.0C.29.6E.5F.62
22:45:46 DHCPd:DHCP_REQUEST received, xid:625F6E2A
22:45:47 DHCPd:DHCP_ACK sent, IP:192.168.20.4, xid:625F6E2A
22:45:47 TFTPd:DoReadFile:pxelinux.0 B:1456 T:0

I will install vmware workstation and do some tests.

#343 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 10:17 AM

vmware workstation 11 + TPS 1.0.0.19 + proxydhcp : OK

12:11:28 DHCPd:67 started...
12:11:28 DHCPd:4011 started...
12:11:28 TFPTd started...
12:11:28 HTTPd started...
12:14:29 DHCPd:DISCOVER received, MAC:00-0C-29-EC-F3-3D, XID:2AECF33D
12:14:30 DHCPd:OFFER sent, IP:0.0.0.0, XID:2AECF33D
12:14:31 DHCPd:DISCOVER received, MAC:00-0C-29-EC-F3-3D, XID:2BECF33D
12:14:32 DHCPd:OFFER sent, IP:0.0.0.0, XID:2BECF33D
12:14:35 DHCPd:REQUEST discarded, MAC:00-0C-29-EC-F3-3D, XID:2BECF33D
12:14:37 PDHCPd:REQUEST received, MAC:00-0C-29-EC-F3-3D, IP:192.168.1.150, XID:2BECF33D
12:14:37 Proxy boot filename empty?
12:14:37 PDHCPd:DHCP_ACK sent, IP:192.168.1.150:68, xid:2BECF33D
12:14:37 TFTPd:DoReadFile:ipxe.pxe B:1456 T:0
12:14:43 DHCPd:DISCOVER received, MAC:00-0C-29-EC-F3-3D, XID:1F95AD2B
12:14:43 DHCPd:iPXE user-class detected
12:14:43 DHCPd:OFFER sent, IP:0.0.0.0, XID:1F95AD2B
12:14:43 DHCPd:REQUEST discarded, MAC:00-0C-29-EC-F3-3D, XID:1F95AD2B
12:14:44 DHCPd:REQUEST discarded, MAC:00-0C-29-EC-F3-3D, XID:1F95AD2B
12:14:44 TFTPd:DoReadFile:menu.ipxe B:1432 T:16208



#344 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 10:19 AM

vmware workstation + TPS 1.0.0.19 + dhcp : OK

12:17:22 DHCPd:67 started...
12:17:22 TFPTd started...
12:17:22 HTTPd started...
12:17:36 DHCPd:DISCOVER received, MAC:00-0C-29-EC-F3-3D, XID:2AECF33D
12:17:36 DHCPd:OFFER sent, IP:192.168.1.100, XID:2AECF33D
12:17:38 DHCPd:REQUEST received, MAC:00-0C-29-EC-F3-3D, XID:2AECF33D
12:17:38 DHCPd:ACK sent, IP:192.168.1.100, XID:2AECF33D
12:17:38 TFTPd:DoReadFile:ipxe.pxe B:1456 T:0
12:17:45 DHCPd:DISCOVER received, MAC:00-0C-29-EC-F3-3D, XID:9CCCB039
12:17:45 DHCPd:iPXE user-class detected
12:17:45 DHCPd:OFFER sent, IP:192.168.1.101, XID:9CCCB039
12:17:48 DHCPd:REQUEST received, MAC:00-0C-29-EC-F3-3D, XID:9CCCB039
12:17:48 DHCPd:iPXE user-class detected
12:17:48 DHCPd:ACK sent, IP:192.168.1.101, XID:9CCCB039
12:17:48 TFTPd:DoReadFile:menu.ipxe B:1432 T:16208



#345 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 218 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 18 July 2015 - 12:16 PM

Apparently, we use a different configuration. My is:
  • Tiny PXE Server running on Host WinXP SP2 64-bit
  • virtual machine network in VMware Workstation 8.0 is set to Bridged mode
I not use option67 because boot file is set in Boot File section
If change or delete option66 $DHCP still no boot

PXE option are required to start the computer from floppy disks RIS. Because I do not use RIS commented out options for RIS and everything works, so it looks like my config.ini:
[dhcp]
;for Netboot working
rfc951=1

root=C:\PXE\
filename=pxelinux.0
httpd=1
binl=0
start=1
dnsd=0
proxydhcp=0
bind=0
smb=0
log=0
cmd=freenfs.exe
offline=freenfs_off.bat

;for RIS client working
;opt43=0.0.0.0
;opt60=PXEClient
;opt66=$dhcp

[frmDHCPServer]
top=17
left=14


#346 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 12:28 PM

Apparently, we use a different configuration. My is:

  • Tiny PXE Server running on Host WinXP SP2 64-bit
  • virtual machine network in VMware Workstation 8.0 is set to Bridged mode
I not use option67 because boot file is set in Boot File section
If change or delete option66 $DHCP still no boot

PXE option are required to start the computer from floppy disks RIS. Because I do not use RIS commented out options for RIS and everything works, so it looks like my config.ini:
[dhcp]
;for Netboot working
rfc951=1

root=C:\PXE\
filename=pxelinux.0
httpd=1
binl=0
start=1
dnsd=0
proxydhcp=0
bind=0
smb=0
log=0
cmd=freenfs.exe
offline=freenfs_off.bat

;for RIS client working
;opt43=0.0.0.0
;opt60=PXEClient
;opt66=$dhcp

[frmDHCPServer]
top=17
left=14

 

Hi,

 

You cannot mix filename and pxe options (opt 60,66,67).

it is either one or the other :

-use opt60,66 AND 67 (Pxe)

or

-use filename (plain dhcp)

 

Do not use $dhcp variable : TPS does not knwo this variable and it will mess up the whole thing.

opt60=PXEClient

opt66=ip_of_your_dhcp_server

opt67=pxelinux.0

 

You also need to bind your interface as you have multiple interfaces (vm ones and physical ones).

If you use bridge, bind on your physical interface (the one showing in opt54).

 

Erwan



#347 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 14225 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 18 July 2015 - 01:43 PM

You cannot mix ...

....

Do not use ....

......

You also need to ......

....

 

 

All in all this sounds a lot like a RTFM :w00t:, with the only marginal issue being that the FM seemingly does not exist :(.

:whistling:

 

:duff:

Wonko



#348 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 218 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 18 July 2015 - 01:45 PM

Hi,
 
You cannot mix filename and pxe options (opt 60,66,67).
it is either one or the other :
-use opt60,66 AND 67 (Pxe)
or
-use filename (plain dhcp)
 
Do not use $dhcp variable : TPS does not knwo this variable and it will mess up the whole thing.
opt60=PXEClient
opt66=ip_of_your_dhcp_server
opt67=pxelinux.0
 
You also need to bind your interface as you have multiple interfaces (vm ones and physical ones).
If you use bridge, bind on your physical interface (the one showing in opt54).
 
Erwan

I delete filename from plain DHCP and set opt67=pxelinux.0 and change also opt66=$dhcp to IP my TPS server but still not boot :-(

P.S. To admin - please remove my repeated posts (now I put just a dot ".")

#349 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 03:11 PM

All in all this sounds a lot like a RTFM :w00t:, with the only marginal issue being that the FM seemingly does not exist :(.

:whistling:

 

:duff:

Wonko

 

Work in progress (Misty is currently writing the doc - looks great so far).



#350 erwan.l

erwan.l

    Gold Member

  • Developer
  • 2281 posts
  • Location:Nantes - France
  •  
    France

Posted 18 July 2015 - 03:13 PM

I delete filename from plain DHCP and set opt67=pxelinux.0 and change also opt66=$dhcp to IP my TPS server but still not boot :-(

P.S. To admin - please remove my repeated posts (now I put just a dot ".")

 

uhm strange?

 

Would you be able to do a wireshark capture : 

-one with TPS 1.0.0.11 working

-the same with TPS 1.0.0.19 not working

assuming the config.ini is the same in both cases.

 

You did put bind=1 in the config.ini as well right?

 

I can only test win7 x64 + vmware workstation 11 over here (and i do not experience such issues).







Also tagged with one or more of these keywords: pxe, network boot

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users