Jump to content











Photo
* * * * * 1 votes

MistyPE

winpe5 winpe4 winpe3 winpe2 winpe

  • Please log in to reply
212 replies to this topic

#201 alacran

alacran

    Frequent Member

  • Advanced user
  • 394 posts
  •  
    Mexico

Posted A week ago

Allready tested it, DO NOT WORK ON PE, very good for on online real OS,  it needs explorer to be working on as it uses some of Internet Explorer's folders, files.

 

Very nice on real OS.

 

Thats why I didn't suggestet it for your poroject after reading Wonko's Post, and testing it on WinPE.

 

alacran

 

EDIT: It works fine on WinPE, I apologice for this mistake, more info on next posts.



#202 Atari800XL

Atari800XL

    Member

  • Members
  • 71 posts
  •  
    Netherlands

Posted A week ago

Apologies to any testers for the volume of all of the recent updates

 

No apologies necessary, just hope you're getting enough sleep. :sleeping:  :logik:  :yawn:



#203 misty

misty

    Silver Member

  • Developer
  • 620 posts
  •  
    United Kingdom

Posted A week ago

@alacran
If you had actually read the LaunchBar webpage you would have seen a way of running it in WinPE :whistling:

I made the same mistake and created lots of work for myself getting it to work in MistyPE.

The following is from an email I sent to the LaunchBar developer yesterday -

...I have been playing around with LaunchBar today and having fun trying to get it working in a minimal Windows Preinstallation Environment. LaunchBar itself worked fine as soon as the "%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch" directory was created - scripting the creation of shortcuts to go into this folder on the other hand was a bit more difficult but I got it working with a vbs script.

And then I actually read the instructions!!!! The configuration file will make it very easy to script. This is a very nice application and has very good instructions. Thank you.

After spending so much time writing instructions for various programs myself, I really could kick myself for not having propery read the LaunchBar webpage....

My initial workaround would have been a nightmare to implement in MistyPE - the config file is working fine and is implemented in my test build. More later.

Misty

#204 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13329 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted A week ago

@alacran
If you had actually read the LaunchBar webpage you would have seen a way of running it in WinPE :whistling:

It is "normal" :) to see how half the people are protesting for the lack of documentation and half the people are completely failing at reading them when available.

The anomaly is when the two halves are actually the same half ;)

 

 


Allready tested it, DO NOT WORK ON PE, very good for on online real OS,  it needs explorer to be working on as it uses some of Internet Explorer's folders, files.
 
Very nice on real OS.
 
Thats why I didn't suggestet it for your poroject after reading Wonko's Post, and testing it on WinPE.
 
alacran

Now, Wonko has a lot of defects :w00t: :ph34r: (including the habit of often talking in third person), but he tends to be (besides Sane) very accurate when posting information, the simple fact that he proposed a nice little tool specifically for use in a PE should have been enough to believe that it does work in a PE and doubt that maybe the way you implemented it was *somehow* incorrect ... . :whistling:

 

 

:duff:

Wonko



#205 misty

misty

    Silver Member

  • Developer
  • 620 posts
  •  
    United Kingdom

Posted A week ago

In my case I spent several hours on an unnecessarily complex workaround - reading the instructions properly I was able to get it working in less than 10 minutes.

I've become so accustomed to programs not having any instructions that I neglected to read fully the LaunchBar webpage and caused unnecessary work for myself. Hopefully this will be a lesson I learn from.

Misty

#206 misty

misty

    Silver Member

  • Developer
  • 620 posts
  •  
    United Kingdom

Posted A week ago

Update - use the script in post #193 or your existing Tools > Update Project script to download it.

All project scripts will be updated. LaunchBar has been added. The update package will set LauchBar as enabled by default (option to enable\disable is in the main project options (option 11)).

Some LaunchBar settings are also in the Shell.Then.End > BlackBox Lean script.

LaunchBar will work with programs in boot.wim or with programs on another drive - a batch file will be launched to search for LaunchBar in a hardcoded path.

More developments to follow over the next week. For anyone frustrated by the number of recent updates, please feel free to wait a week or so before spending time testing the moving target that MistyPE has become over the past 10 days. Current update is limited to those with the update.project.script in post #193 (or a more recent version obtained by running the original update script) - a maximum of 7 testers at the moment.

Misty

#207 alacran

alacran

    Frequent Member

  • Advanced user
  • 394 posts
  •  
    Mexico

Posted A week ago

@alacran
If you had actually read the LaunchBar webpage you would have seen a way of running it in WinPE :whistling:

I made the same mistake and created lots of work for myself getting it to work in MistyPE.

The following is from an email I sent to the LaunchBar developer yesterday -

My initial workaround would have been a nightmare to implement in MistyPE - the config file is working fine and is implemented in my test build. More later.

Misty

 

Let me tell you my mistake is worst, I actually read all page and understood complitely author (very clear) instructions, also created the folder for settings/shortcuts and put both in user.added.files but was so ansious to test this tool that (now I know) complitelly forgot to put any settings.

 

Finally, I'm very glad you include it in your project, I'll test it ASAP.

 

alacran



#208 alacran

alacran

    Frequent Member

  • Advanced user
  • 394 posts
  •  
    Mexico

Posted A week ago

@misty

 

Just updated MistyPE and made a new buid, LaunchBar is working very fine, it took me some time, but finally found LaunchBar.ini file, then edited it to make a shortcut to folder User.Added.Files I used "User Files" for shortcut name.

Reopened MistyPE updated the boot.wim and made a new WinPE.iso.   Booting again from remade iso new shortcut was there and selecting it, it opens a little menu with all my Portables including all their icons automaticaly made by LaunchBar, this tool is fantastic, as it is now, centered on top of screen it looks great there.

 

I guess you forgot to add a shortcut to this folder, since I assume you are going to fix it, let me suggest to add an option to let user select if he/she wants to autolaunch LaunchBar when booting, I would not like to use custom batch script for this pourpose as it can have diferent use.

 

Regards

 

alacran



#209 alacran

alacran

    Frequent Member

  • Advanced user
  • 394 posts
  •  
    Mexico

Posted A week ago

It is "normal" :) to see how half the people are protesting for the lack of documentation and half the people are completely failing at reading them when available.

The anomaly is when the two halves are actually the same half ;)

 

 

 

 

Now, Wonko has a lot of defects :w00t: :ph34r: (including the habit of often talking in third person), but he tends to be (besides Sane) very accurate when posting information, the simple fact that he proposed a nice little tool specifically for use in a PE should have been enough to believe that it does work in a PE and doubt that maybe the way you implemented it was *somehow* incorrect ... . :whistling:

 

 

:duff:

Wonko

 

@Wonko

 

Sorry, totally my mistake, I was patching the boot.wim to include this aplication and writing in the forum and forgot about ini file thats why it didn't work when I tested it. So this can be an strange case when there is a rare third half: People how reads instructions very carefully, understand them very well, but when make it, forget to do something.

Good tool, it works very fine and looks very nice.

 

alacran



#210 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13329 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted A week ago

@Wonko
 
Sorry, totally my mistake, ...

Don't worry :), it can happen to everyone, I was just pulling your leg ;).

:duff:
Wonko

#211 misty

misty

    Silver Member

  • Developer
  • 620 posts
  •  
    United Kingdom

Posted A week ago

I've had a response to an email I sent to the LaunchBar program author - Peter Lerup. Peter has very kindly given permission to redistribute LaunchBar with MistyPE/Mini-WinFE.

Many thanks Peter.

:cheers:

Misty

#212 misty

misty

    Silver Member

  • Developer
  • 620 posts
  •  
    United Kingdom

Posted A day ago

Support for Browse for Folders and SysWoW64 now working in Windows 10.0.10586

The following file dependencies are required -

* fwbase.dll - required for SysWoW64
* edputil.dll - required for Browse For Folders

GhostSrv and GhostExp has the following dependency in Windows 10.0.10586 (and probably other versions of Windows - not tested yet) when running on 64-bit Windows with SysWoW64 -

* dbgcore.dll - ghost dependency

Next build coming soon. Lots of testing needs to be completed due to numerous code changes. It's not even ready for Beta yet. More soon.

:cheers:

Misty

#213 misty

misty

    Silver Member

  • Developer
  • 620 posts
  •  
    United Kingdom

Posted An hour ago

NEW UPDATE - download via the Tools > Update Project script

Lots of updates and a serious risk of something broken. I'll continue to test, however after days of staring at code it would be useful to get someone else to test and feedback.

This is a full update package (documents removed for now).

SysWoW64 support added for Windows 10.0.10586.

Bug in SysWoW64 support for Windows 8.1 fixed.

Q-Dir file manager included - select this or A43/FileManagerPE.

Number of programs updated.

WinRE and ADK scripts removed.

Tabbed style interface added for a range of scripts including the main project script and following new scripts -
* Tools > ADK
* Tools > Cache Files

Both new scripts are pre processing. Use the Tools > ADK script to download/install/build WinPE from an ADK with any required packages. ADK for Windows 8 / 8.1 / 10.0.14393 supported.

The Tools > Cache Files script can be used to copy WinRE from a local drive. It can also be used to create a cache from a combination of WinRE.wim (or a .wim created using the new ADK script) and either install.wim or a local installation or mounted .iso source.

:cheers:

Misty
  • alacran likes this





Also tagged with one or more of these keywords: winpe5, winpe4, winpe3, winpe2, winpe

3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users