Jump to content











Photo
- - - - -

install win7 Pro 64 bit su vhd - errore durante l'inst


  • Please log in to reply
14 replies to this topic

#1 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 09 September 2013 - 02:59 PM

dopo l'approccio all'installazione di xp su vhd, sono passato a provare l'installazione di win 7 Pro 64 bit su vhd.

 

Ho seguito la guida http://reboot.pro/to...ot-os-from-vhd/ però ho dei problemi...

 

Il principale problema penso che sia nella mancata firma dei driver. Nonostante abbia fatto la procedura alla lettera infatti, non vedo montato automaticamente il disco vhd. Allora ho copiato il contenuto dell'immagine WinVblock.ima all'interno di una cartella.

 

Ho lanciato l'installazione premendo F8 al boot della iso e selezionado la disattivazione del controllo firma dei driver, verificando che la cartella dei driver winVblock e il suo contenuto fossero visibili dall'applicazione dell'installazione (attraverso l'esplora risorse lanciato dal notepad). I file vhd, iso, e la cartella dei driver sono tutti visibili all'applicazione ma provando a linkare i driver l'apposita voce dell'interfaccia non trova nessun driver firmato compatibile.

 

Qualche idea ?

 

I test sono stati effettuati all'interno di una VM VMware e i driver winvblock sono quelli recuperati nel file winVblock.ima.gz al seguente link: http://www.rmprepusb...b-beta-versions


Edited by deatty, 09 September 2013 - 03:00 PM.


#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 09 September 2013 - 03:42 PM

No. 

No, no, no. :frusty:

 

Se segui un tutorial lo devi seguire ESATTAMENTE oppure SAPERE GIA' cosa cambiare (ma in questo caso non avresti bisogno del tutorial - COMMA22! ).

 

Quel particolare tutorial é confuso, mescola diversi metodi ed é stato scritto - tra l'altro - da un membro che aveva in generale le idee poco chiare, e particolarmente nessuna idea chiara su come fare un boot da .vhd.

 

Comunque per quanto riguarda windows 7  quel tutorial offre 2 (due) diversi metodi:

  1. con integrazione di winvblock nel file .wim
  2. con l'uso delle immagini floppy

 QUALE dei due hai provato a seguire, e SEI SICURO di averlo seguito ESATTAMENTE?

 

Il primo non necessita dell'installazione MANUALE del driver, il secondo molto probabilmente sì (per windows 7 e specificamente per 64 bit).

Once the Setup ISO starts loading, it will auto install WinVBlock from a floppy disk or image, then auto attach the pre-made VHD, and proceed with OS install to it. If auto install or hitting F6 doesn't work for you, you must install WinVBlock from a folder and start WinVBlock service manually from Command Prompt (SHIFT+10) after the Setup ISO boots, then use WinVBlock driver commands to attach ISO, IMA and VHD disks if not auto mounted, and proceed with OS installation:

 

 

In ogni caso secondo me avresti maggior fortuna sequendo quest'altro tutorial:

http://reboot.pro/to...-and-windows-7/

http://www.911cd.net...showtopic=23553

Che comunque non é tra i più facili/lineari (perché mescola liberamente XP, Windows 7, immagini universali, vhd's e vhd's su USB), ma con un pò di pazienza é di calma si può replicare.

In pratica usa questo programma:

http://www.msfn.org/...winntsetup-v23/

che nasce con il supporto per l'installazione di Windows 7 su .vhd con il supporto per il boot nativo, aggiungendo il supporto esterno (o non-nativo) con Firadisk.

 

 

:cheers:

Wonko



#3 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 09 September 2013 - 04:04 PM

No. 

No, no, no. :frusty:

 

Se segui un tutorial lo devi seguire ESATTAMENTE oppure SAPERE GIA' cosa cambiare (ma in questo caso non avresti bisogno del tutorial - COMMA22! ).

 

comma 22 ?!?

 

Quel particolare tutorial é confuso, mescola diversi metodi ed é stato scritto - tra l'altro - da un membro che aveva in generale le idee poco chiare, e particolarmente nessuna idea chiara su come fare un boot da .vhd.

 

Comunque per quanto riguarda windows 7  quel tutorial offre 2 (due) diversi metodi:

  1. con integrazione di winvblock nel file .wim
  2. con l'uso delle immagini floppy

 QUALE dei due hai provato a seguire, e SEI SICURO di averlo seguito ESATTAMENTE?

 

ho seguito la porzione con l'immagine floppy. Credo di averlo seguito correttamente.

In pratica ho:

 

1. copiato le entry per grub4dos così come postate.

2. creato il file vhd pre-formattato tramite shell da disco di installazione

3. copiato il file vhd, la iso di installazione i l'immagine nella root dell'unico disco presente sul sistema (unica partizione)

4. controllato il nome dei files per farli coincidere con i riferimenti nelle entry di grub4 dos

5. reso i file contigui

6. lanciato la prima fase di installazione da grub4dos, ma l'auto mount del vhd non và (non lo vedo tra i dischi disponibili)

7. come da guida ho provato a lanciare l'installazione premendo F8, disabilitando il controllo della firma digitale dei driver, verificato che i file fossero visibili all'utility di installazione e linkato il contenuto dell'immagine floppy (pre-copiato su una cartella). Anche con controllo disabilitato della firma, l'utility di installazione dice che non mi trova driver compatibili (a sto punto mi domando se i driver che ho sono corretti.

 

 

l'unica parte che mi manca del tutorial è provare a installare da shell i driver e montare manualmente il file vhd

per capirci questa sezione (ho notato tra l'altro che nel testo mancano le barre "\"), anche perchè era riportato di farlo se l'utility non vedeva i driver su cartella (non sò se la considerazione vale per gli altri punti puntati con "*" )

 

[*]At the first Install Windows window, select Locale settings and click Shift+F10 to open Console at x:sources>

type Notepad, click File Open to check mounted drive letters, and see if the VHD, IMA and ISO disks are visible. If not:

copy c:winvblocksc.exe x:windowssystem32

copy c
:winvblockwvblk32.sys x:windowssystem32drivers



[*]Install WinVBlock driver to the running WinPE:

sc create WinVBlock binPath= x:windowssystem32driverswvblk32.sys type= kernel start= boot group= "SCSI miniport"

drvload c:winvblockWinvblk.inf

net start
WinVBlock



[*]Switch back to Notepad and reopen File Open to see, if VHD, IMA and ISO disks are now visible. If not, you could:

- attach an .ISO with:

winvblk -cmd attach -m c -u c:Win7Pro.iso

- or a floppy disk image with:

winvblk -cmd attach -m f -u c:WinVBlock.vfd

- or an HDD or VHD image with:

winvblk -cmd attach -m h -u c:Win7Pro.vhd

You might need to repeat the attach commands a few times until successful, and wait each time for the result



[*]Return to Windows Setup with the command below or just click its window.

x:setup

Wait for Win Setup to recognize all mounted drives, then proceed with OS setup to VHD.

You might need now to install WinVBlock to OS on the VHD by clicking Load Driver in Win Setup Menu and pointing to Winvblk.inf,

if OS can't auto install it from WinVBlock.ima at this time, or after 1-st reboot (with or without pressing F6) to finish setup



 

Il primo non necessita dell'installazione MANUALE del driver, il secondo molto probabilmente sì (per windows 7 e specificamente per 64 bit).

 

In ogni caso secondo me avresti maggior fortuna sequendo quest'altro tutorial:

http://reboot.pro/to...-and-windows-7/

http://www.911cd.net...showtopic=23553

Che comunque non é tra i più facili/lineari (perché mescola liberamente XP, Windows 7, immagini universali, vhd's e vhd's su USB), ma con un pò di pazienza é di calma si può replicare.

In pratica usa questo programma:

http://www.msfn.org/...winntsetup-v23/

che nasce con il supporto per l'installazione di Windows 7 su .vhd con il supporto per il boot nativo, aggiungendo il supporto esterno (o non-nativo) con Firadisk.

 

 

:cheers:

Wonko

 

 

grazie per l'alternativa ancora una volta. :happy_dance: 

Provo a darci un occhio. In caso posso chiederti qualche dritta sui passaggi che eventualmente mi confondono ?

 

 

 

Risposte in blu (in attesa di prendere confidenza con il controllo del quote dell'interfaccia del forum (vi prego di scusarmi....)


Edited by deatty, 09 September 2013 - 04:06 PM.


#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 09 September 2013 - 04:13 PM

COMMA 22 (JFYI):

http://it.wikipedia....so_del_Comma_22

 

:cheers:

Wonko



#5 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 13 September 2013 - 02:19 PM

niente da fare...

non riesco a fare i passi sucessivi e far partire manualmente il servizio winvblock con "net start" (mi restituisce "nome del servizio non valido")

 

ma se eseguo l'installazione di windows 7 su vhd in maniera classica e inietto i driver winvblock dopo il processo di installazione, potrebbe funzioanare ?

(dato che il product key non è delle versioni con supporto ufficiale al vhd, se provo a far buttare la partizione vhd dopo il processo di installazione, mi restituisce un errore di licenza)



#6 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 13 September 2013 - 08:18 PM

allora, dato che il metodo di installazione con inserimento dei driver con installazione on-line è arrivata a un vicolo cieco, ho provato il secondo metodo.

 

Ho creato il vhd, ho copiato l'immagine wim del disco di installazione con IMAGEX, ho inniettato i driver winvblock con DISM. Fino qua tutto bene.

 

Quando provo ad avviare la continuazione dell'installazione da relativa entry del menu di grub4dos, mi restituisce il seguente errore:

 

riferendosi al file di driver winvblock, "windows cannot verify the digilat signature for this file"

 

 

 

ora, dovrei disabilitare il controllo firme tramite il tasto F8, ma dato che l'avvio lo faccio tramite grub4dos non riesco a beccare il momento giusto...

cè modo di configurare l'avvio della modalità senza controllo firma direttamente da entry grub4dos ?

 

EDIT: trovato, era nella schermata dopo l'opzione per il boot con le opzioni avanzate con F8.

 

Permane un problema...

al boot mi resta sempre con la schermata nera con la barra di caricamento verde.

Che posso fare a questo punto ?


Edited by deatty, 13 September 2013 - 08:48 PM.


#7 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 14 September 2013 - 08:51 AM

Se net start non trova il servizio, significa che non é stato correttamente creato con SC.EXE.

 

Posta i comandi ESATTI che dai. 

ESATTI.

 

:cheers:

Wonko



#8 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 17 September 2013 - 08:29 PM

Se net start non trova il servizio, significa che non é stato correttamente creato con SC.EXE.

 

Posta i comandi ESATTI che dai. 

ESATTI.

 

:cheers:

Wonko

 

da console lanciata con Shift+F10

 

copy c:\winvblock\sc.exe x:\windows\system32

copy c
:\winvblock\wvblk64.sys x:\windows\system32\drivers

sc create WinVBlock binPath= x:\windows\system32\drivers\wvblk64.sys type= kernel start= boot group= "SCSI miniport"

drvload c:\winvblock\Winvblk.inf

net start
WinVBlock

 

 

 

screen dei comandi inviati

http://imageshack.us...s/545/8c3b.png/



#9 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 18 September 2013 - 08:33 AM

At first sight you need NOT to use drvload.

 

After SC CREATE, run SC QUERY Winvblock, in order to verify that the service installed.

 

Try using Winvblk.exe instead of SC.EXE:

https://github.com/Sha0/winvblock

 

then run anyway the SC QUERY Winvblock before attempting to start the service.

 

:cheers:

Wonko



#10 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 18 September 2013 - 11:24 AM

At first sight you need NOT to use drvload.

 

After SC CREATE, run SC QUERY Winvblock, in order to verify that the service installed.

 

Try using Winvblk.exe instead of SC.EXE:

https://github.com/Sha0/winvblock

 

then run anyway the SC QUERY Winvblock before attempting to start the service.

 

:cheers:

Wonko

 

il comando "sc query winvblock" non restituisce nessun testo.

 

ho copiato tutto il contenuto della cartella winvblock nella cartella "x:\windows\system32\drivers\"

e lanciato il seguente comando

 

winvblk.exe -cmd install service wvblk64.sys

 

 

 

e mi restituisce "il sottosistema necessario per il supporto del tipo dell'immagine non è presente"



#11 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 18 September 2013 - 12:01 PM

And what happens with:

winvblk.exe -cmd install service wvblk32.sys

:dubbio:

 

:cheers:

Wonko



#12 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 19 September 2013 - 09:48 PM

And what happens with:

winvblk.exe -cmd install service wvblk32.sys

:dubbio:

 

:cheers:

Wonko

lo stesso msg



#13 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 20 September 2013 - 09:50 AM

Hmmm. :unsure:

E cosa succede invece usando SC per installare il driver 32 bit?

 

SC dovrebbe ritornare un errore se non reiesce a creare il servizio per qualche motivo, e se il servizio é effettivamente creato, SC Query lo deve listare.

Prova ad installare un altro driver, diciamo httpdisk, per verificare se i l problema é "generico" con SC o specifico con Winvblock.

 

:cheers:

Wonko



#14 deatty

deatty

    Member

  • Members
  • 32 posts
  •  
    Italy

Posted 20 September 2013 - 04:02 PM

Hmmm. :unsure:

E cosa succede invece usando SC per installare il driver 32 bit?

 

SC dovrebbe ritornare un errore se non reiesce a creare il servizio per qualche motivo, e se il servizio é effettivamente creato, SC Query lo deve listare.

Prova ad installare un altro driver, diciamo httpdisk, per verificare se i l problema é "generico" con SC o specifico con Winvblock.

 

:cheers:

Wonko

 

niente da fare. Stesse reazioni con sc e winvblk.exe con altri driver provati. (firadisk.sys, firadi64.sys, iastor.sys...)



#15 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13691 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 20 September 2013 - 04:24 PM

niente da fare. Stesse reazioni con sc e winvblk.exe con altri driver provati. (firadisk.sys, firadi64.sys, iastor.sys...)

Allora c'é qualcosa "a monte" (ma non so cosa possa essere).

Che ESATTA .iso stai usando come base?

Nel dubbio, provane una scaricata da digitalriver, versione Inglese:

http://reboot.pro/to...d-links-needed/

http://forum.noteboo...-languages.html

 

Oppure, lascia perdere e prova il metodo di Wimb, come già suggerito:

http://reboot.pro/to...st/#entry176906

 

Tanto per capirsi, (nella mia mente perversa) affidabilità di qualunque cosa scritta da Wimb 99.17%, affidabilità di qualunque cosa scritta da Sambul61 0.00% (e purtroppo non ci sono le percentuali negative).

 

:cheers:

Wonko






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users