Jump to content











Photo
* * * * * 1 votes

WinBuilder


  • Please log in to reply
193 replies to this topic

#151 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 01 April 2015 - 03:11 PM

I have a software which reques it. I want to make an minimal image for Virtual Box. I'll try other readers. My software has a certificaton. I don't know if others support it.
 
Is it possible to add http://reboot.pro/to...dobe-reader-xi/? How?

 
It is not possible to add a script for the deprecated WinBuilder 08x to the new WinBuilder 20xx.
 
I'll have a look into the old script and will see what is possible.
 
In the mean time maybe you try my new SumatraPDF plugin. The process of upload may be finished in about one hour.
 
Peter

#152 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 05 May 2015 - 09:20 AM

A new version is uploaded.

 

What's New in Version 2015.05.04
  • Added MS Installer
  • Added Command History functionality
  • Added Custom Project

Peter



#153 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 15 May 2015 - 11:10 AM

New version published.

 

What's New in Version 2015.05.14
  • Small adjustment in command history: ESCAPE cleans current line
  • Fix bug in starting NVDA
  • Check custom projects for valid source
  • Added User Folders
  • Fixed bug on linux, when WinBuilder was on a different than the home volume.

Peter

 



#154 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 13 June 2015 - 03:27 PM

New version is uploaded!

What's New in Version 2015.06.12

  • BUILD CORE, WIM, ISO now fully independent from each other.
  • Add cached files collections, rather than expanding from WIM on every build. This brings on my old XP machine a build from more than 6 minutes downto 2:30 minutes.
  • Add Win7pe function "Update.java" which uses external file "update.ini" to make optional necessary Win7Pe settings file adaptions on WinBuilder update.

You can now modify your PE by e.g.:

(Thought more for developers than standard users!)

  • BUILD CORE
  • Add / change / remove something in <BaseDir>\output\wim-boot
  • BUILD WIM
  • Add / change / remove something in <BaseDir>\output\bootdisk
  • BUILD ISO

The idea of "Cached files" is also not new. In WinBuilder 8x there are some projects with "Stored WIMs".
The difference is that the "Stored WIMs" are complete and need some GB space per source CD.
The here used method caches only the "Standard PE" files, which needs only about 350 mb per source CD.
The other files (e.g. in plugins) are still extracted actually from the WIMs.
 
Some logs showing the timing:
 
Standard build:

Spoiler

Cached build:

Spoiler

 

Peter



#155 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 13 June 2015 - 05:33 PM

I got a strange error report inside the download section and removed from there.

 

Please report troubles here!

 

Peter



#156 Darkman74

Darkman74
  • Members
  • 8 posts

Posted 22 June 2015 - 07:59 AM

I tried this Build on several systems - but it dosent work. first i tried (two) Win 7 x64 with actual updates - winbuilder dosent start.

archLinux x64 with JDK 8.x winbuilder dosent start (the syntax to launch seems to be wrong?!?)

at least i tried win8.1 same here 

 

the Windows Systems dosent report anny errors 

 

(sorry 4 the bad english) 

 

kind regards 

 

Andy



#157 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 June 2015 - 09:11 AM

Try to start WinBuilder from console:

 

<BaseDir>run\jre\bin\java -Xms640m -Xmx1024m -jar <BaseDir>\winbuilder.jar

 

<BaseDir> is where WinBuilder.jar is installed.

 

This maybe outputs error messages.

 

Peter



#158 Darkman74

Darkman74
  • Members
  • 8 posts

Posted 22 June 2015 - 09:43 AM

Hello Peter,

 

thank you for the quick reply.

 

Here the Output.
 
 
c:\work\winbuilder>java -Xms640m -Xmx1024m -jar winbuilder.jar
Exception in thread "main" java.lang.IllegalArgumentException: Parameter 'direct
ory' is not a directory
        at org.apache.commons.io.FileUtils.validateListFilesParameters(FileUtils
.java:545)
        at org.apache.commons.io.FileUtils.listFiles(FileUtils.java:521)
        at org.apache.commons.io.FileUtils.listFiles(FileUtils.java:691)
        at win7pecore.Update.checkActivateDriver(Update.java:84)
        at win7pecore.Update.action(Update.java:63)
        at win7pecore.Win7PE.<init>(Win7PE.java:133)
        at build.Core.main(Core.java:133)
 
testet on w7 x64 with java 7.x and the java version bundled with winbuilder 
the same on w8.1 x64 and java 8.x

Edited by Darkman74, 22 June 2015 - 10:00 AM.


#159 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 June 2015 - 10:16 AM

your command line should be:

 

C:\winBuilder>run\jre\bin\java -Xms640m -Xmx1024m -jar winbuilder.jar

 

I'm going to do some tests with mixed java 6 / 7 /8.

 

But allow me two weeks of vacation before (coming back july 6th)

 

Peter


Edited by pscEx, 22 June 2015 - 04:10 PM.
Sorry, thr RUN\ is wrong

  • Nuno Brito likes this

#160 Darkman74

Darkman74
  • Members
  • 8 posts

Posted 22 June 2015 - 10:41 AM

Just testet with other location - same problem.

 

Schönen Urlaub! ;-) 

 

(eben erst gesehen das du quasi aus der Nachbarschaft kommst) 


Edited by Darkman74, 22 June 2015 - 10:50 AM.


#161 BxB

BxB
  • Members
  • 1 posts
  •  
    Thailand

Posted 06 July 2015 - 06:29 AM

Just downloaded ver. 2015.06.12 to two of my Win 7 sp 1 machines, it works on neither.  I double click on WinBuiler.exe, it starts doing something, but nothing happens, no screen comes up. 



#162 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 07 July 2015 - 12:01 PM

I could reproduce.

 

There may be an issue in  adressing the delivered Java, when Java is not installed on the host.

 

I'll fix as soon as possible.

 

Peter



#163 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 07 July 2015 - 04:22 PM

Issue fixed.

 

WinBuilder.exe now starts on a host without Java installed.

 

I could not test when the installed java version is below 6. But that should work too.

 

Is there somebody still working with such an old Java version below 6?. Please report.

 

Peter



#164 Darkman74

Darkman74
  • Members
  • 8 posts

Posted 08 July 2015 - 01:53 PM

Problem still exists :-(

Win 7 Prof. x64 (German)

Java 8 update 45 installed.

 

 

Tried both ways 

- Start the Exe within the Directory

- Start from Command Prompt 

 

 Command Prompt produces folowing output 

 
Exception in thread "main" java.lang.IllegalArgumentException: Parameter 'direct
ory' is not a directory
        at org.apache.commons.io.FileUtils.validateListFilesParameters(FileUtils
.java:545)
        at org.apache.commons.io.FileUtils.listFiles(FileUtils.java:521)
        at org.apache.commons.io.FileUtils.listFiles(FileUtils.java:691)
        at win7pecore.Update.checkActivateDriver(Update.java:84)
        at win7pecore.Update.action(Update.java:63)
        at win7pecore.Win7PE.<init>(Win7PE.java:133)
        at build.Core.main(Core.java:133)
I try at home with Archlinux and another Win7 .....


#165 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 08 July 2015 - 03:09 PM

Command prompt was the right way to find exceptions! Congratuation! :1st:

 

I'll try with your configuration.

 

Peter



#166 mcmccam

mcmccam
  • Members
  • 1 posts
  •  
    United States

Posted 09 July 2015 - 12:48 AM

I'm having the exact same error. I've tried it on two different computers running Windows 8.1 64bit and one fresh install of Windows 7 32bit. Same error on all of them.



#167 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 09 July 2015 - 06:52 AM

I could reproduce. As known, when the issue is well described, it is already solverd one half.

 

Here seems to be a design issue, to attach only a 32 bit jre.

 

But launch4j, which is building winbuilder.exe, can only process one attached jre.

 

I have to find a work around.

 

Peter



#168 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 26 July 2015 - 05:05 PM

A new version is uploaded.

What's New in Version 2015.07.24

  • Corrected startup for different host OS and architecture
  • Some enhancements with autoupdate on different hosts

This fixes hopefully the last time reported issues.

 

Tested with:

 

XP SP3 32 and 64 bit

Win7 32 and 64 bit

Linux Mint Cinnamon 64 bit

 

Members can do me a favoure and test the upgrade mechanism.

 

Instead downloading the latest version, download manually http://winbuilder.ex..._2015.07.16.zip

This is practically the same file like the latest upload, but has a different version number.

 

Unpack this "Old" version into an empty directory and start winbuilder (winbuilder.exe in WIN systems, winbuilder.jar in others).

Follow the instructions to upgrade.

 

The process should lead you finally to the latest winbuilder (2015.07.24) and build the PE successfully.

If not, please report the details.

 

Billy-Bob :yahoo:


  • ZEE likes this

#169 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 13 October 2015 - 01:22 PM

A new version is uploaded.

What's New in Version 2015.10.13
  • Added optional ability to load special plugin's app on every build (For beta tests with rapidly changing apps)

This is done especially for testing Siginets Uninfector.

 

Because this change is not relevant for normal users, there is no message of WinBuilder about a newer version.

 

Existing plugins do not have the property "ForceDownload" and are therefore fully unaffected.

 

Peter



#170 Shoshi

Shoshi

    Member

  • Members
  • 54 posts
  •  
    United States

Posted 02 March 2016 - 03:11 PM

I'm running MX15 on one of my laptops (it is based on Debian Jessie) and I cannot run this program at all. When I try I get the following error.

 

Unrecognized option: -Xsx1024m
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
 
 
I have this version of Java installed.
 
java version "1.8.0_74"
Java™ SE Runtime Environment (build 1.8.0_74-b02)
Java HotSpot™ 64-Bit Server VM (build 25.74-b02, mixed mode)
 


#171 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 02 March 2016 - 05:08 PM

Sorry, there has been a (correccted) typo in the description.

 

Instead of

java -Xsm640m -Xsx1024m -jar winbuilder.jar

use

java -Xms640m -Xmx1024m -jar winbuilder.jar

 

Peter :confused1:


  • Shoshi likes this

#172 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15060 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 March 2016 - 06:33 PM

What can I say? :unsure:

Libby Lol! :lol:

:duff:
Wonko

#173 Shoshi

Shoshi

    Member

  • Members
  • 54 posts
  •  
    United States

Posted 05 March 2016 - 06:19 PM

I got it working and downloaded a valid windows 7 source (windows 7 ultmate 32bits). It does build the iso, but when it boots it is very low res and has a very low color bit depth. I also installed several app plugins and the start menu shortcuts cannot find the apps. I can navigate to the apps in the PE and launch them.



#174 Shoshi

Shoshi

    Member

  • Members
  • 54 posts
  •  
    United States

Posted 05 March 2016 - 08:39 PM

This is what it looks like.

CpWMnVf.png


Edited by Shoshi, 05 March 2016 - 09:07 PM.


#175 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 06 March 2016 - 09:40 AM

Sorry, onother small but important glitch in the upload.

The attached file is missing.

 

Unzip it into your WinBuilder directory.

 

I'll correct the download.

 

Peter

 

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users