Jump to content

- - - - -

[Q] Syslinux failed to (chain)boot Ubuntu( installer) OR HOWTO

syslinux isolinux boot ubuntu linux chainboot

  • Please log in to reply
No replies to this topic

#1 secipor

  • Validating
  • 1 posts

Posted 05 July 2013 - 06:38 AM

I have a USB stick which is bootable( with Syslinux 5.10). And I want to use it to boot Ubuntu.


I could provide more details if necessary. Thank you all in advance.



What I've tried:


I downloaded Ubuntu 13.04 i686 ISO image and extracted all files to H:\ubuntu\ (H: was my USB flash drive)




I tried to boot it with


chain isolinux=/ubuntu/isolinux/isolinux.bin


but failed. it said


Err: option 'maps' requires a sector





Then I thought I could load its configure. So I entered


config /ubuntu/isolinux/isolinux.cfg /ubuntu/isolinux


Then got a message saying:


Failed to load COM32 file gfxboot.c32


 Then I tried again:


boot: live


But it said:


Loading /casper/vmlinuz failed: No such file or directory


Then I moved all files from H:\ubuntu\ to H:\ and loaded its configure, though Syslinux still failed to load gfxboot but I could boot Ubuntu with


boot: live




My Questions


1. Why Syslinux failed to load gfxboot when gfxboot.c32 file could be found?


2. How to put Ubuntu to a standalone folder( Such as H:\ubuntu) and Use Syslinux to boot it?

Edited by secipor, 05 July 2013 - 06:52 AM.

Also tagged with one or more of these keywords: syslinux, isolinux, boot, ubuntu, linux, chainboot

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users