Jump to content











Photo
- - - - -

BCD access when enabling Parental Controls


  • Please log in to reply
No replies to this topic

#1 sir_bootalot

sir_bootalot

    Member

  • Members
  • 41 posts
  •  
    Finland

Posted 14 June 2013 - 05:30 PM

Dudes,

 

I decided to start using Parental Controls for some extra malware protection in my Win7 64-bit Home Premium, because I can't use SRP with Home Premium version.

 

I'm new to using Parental Controls, but I set it up the way described here (in the short Parental Controls segment of this page, most of stuff there is for SRP):

http://www.mechbgon.com/srp/

 

After that I tried to make image of that instance of windows installation, and before that, I always do two steps to allow me using it easily on logical partitions too (at the moment I was doing this, this instance of Win7 was on the second primary partition, with all the boot files on the same partition too - the first primary is only 100MB and NOT used for Windows boot files, but only for grub4dos, and yes, this setup works normally well for me, and I have done it this way several times without problems).

 

Those two steps, I was going to do before taking the image:

1) generalization of BCD

2) emptying of the MountedDevices

 

However, setting up Parental Controls seems to prevent me the access to c:\boot\BCD (that is located on the second primary partition, meaning I have the second primary for both SYSTEM and BOOT).

 

I use a script to generalize BCD, where I have commands starting 'bcdedit /store c:\boot\bcd', but just in case I also tried typing the command 'bcdedit /store c:\boot\bcd' in command prompt but with similar results, windows complained I had no access to BCD (and yes, it is there on C:\boot).

 

When setting up Parental Controls, I made a new administrator level account with no password, and changed my original account to standard level where I set up the parental controls (and gave access to the different programs the way described in the mechbgon link).

 

So I understand that PC restricts me from using system files (although I thought it should only restrict using of .exe files), but even when logging off with the standard account and logging in with the aministrator level account doesn't let me access the BCD. Strange. Ideas how to solve it?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users