Jump to content











Photo
- - - - -

Unable to use C: from FreeDos USB Stick


  • Please log in to reply
2 replies to this topic

#1 gdgrana

gdgrana
  • Members
  • 1 posts
  •  
    United States

Posted 01 May 2013 - 06:30 PM

I recently used some Linux utilities to format a USB stick and install FreeDOS on it via unetbootin. I wanted to use this to run a utility to check on the SSD of my Dell Mini (which supposedly can show errors that prevent the OS from booting). I went through the motions as if I had created a DOS-bootable stick via Windows: after installing FreeDOS I simply copied the files I wanted directly to the root drive of the stick. Now, if I boot into the stick from my Ubuntu machine, I can easily change from A: to C: and examine the contents; I can even run the utility file no problem. However, when I try to do the same thing on the Mini, I run into problems. I can check the A: drive without issue, but if I linger on the C: drive, things start freezing; dir halts after listing the directory contents, and if I try running the executable I get a flashing cursor after hitting enter and that's it. I've tried all available boot options (LiveCD, with HIMEM and the other option enabled, or with no drivers), but they all yield the same results.

 

Has anyone else ever encountered something like this? Thanks.



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 May 2013 - 07:23 PM

Maybe you should set up the stick in such a way that the FreeDOS is loaded (as image) in RAM, this way you avoid possible issues with USB access (caused by either the stick, the Dell mini or the two coupled together).

 

Can you list EXACTLY which "utility file" and "tools" are you wanting to run from the FreeDOS?

 

The original Dell utilities (generically, cannot say the specific ones or the "Mini") normally use a "special" DELL Dos, maybe that is the issue?

 

but we have ways to run the Dell Dignostics "as they are" as .iso or floppy image, see:

http://reboot.pro/to...execcommandcom/

 

Still generically speaking the DELL's BIOSes tend to be:

  1. non-standard
  2. incompatible with a whole lot of "low-level" software
  3. more generally "picky"

BTW which filesystem uses that C:\ drive on the "Mini"?

 

:cheers:

Wonko



#3 betrand

betrand

    Frequent Member

  • Advanced user
  • 467 posts
  •  
    France

Posted 02 May 2013 - 10:52 AM

Hello, longtime no see, Rebob!

 

Seems to me like a plopboot problem, well that's what I encountered in the past what you described.

I.e, when plpbt is loaded, you can dir, but it is buggy when trying to do anything.

 

Also, maybe the path of an FS problem? I have no idea and have no pretention of trying to explain, but reminds me (though not essentially Dos, but FS) of the grldr dos mkisofs boot topic. Though here on USB. I.e, the rootdir entries are OK, but the Fs is weird.

 

Forget this second idea. Are you using Plpbt?

 

:)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users