Jump to content











Photo

Missing .dll when running Win7Pe_SE


  • Please log in to reply
4 replies to this topic

#1 gilly_uk

gilly_uk
  • Members
  • 3 posts
  •  
    United Kingdom

Posted 08 April 2013 - 11:23 AM

Hi,

   Im having a small issue with an ISO Im creating using the Win7PE_SE project in Winbuilder. My goal is to create an ISO that has the portable app HelixPro.exe available so that I can do remote imaging of laptops back to my forensics machine. 

 

I have copied the Helix folder containing all its Libs, Dlls and exe;s into the required folder and have set the Portable Apps program where to look to create the Desktop Shortcut etc. 

 

When I run the ISO and try to launch the program it starts up but then I get a Net1 error could not locate dsrole.dll please reinstall the program. The thing is that this dll is in Windows/System32 where it should be so why would it through an error is there something im doing wrong at the build stage that is making this dll not somehow install correctly? 

 

Many thanks for reading

 

Andy



#2 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 08 April 2013 - 12:09 PM

Does the copy of your Helix folder work outside a PE, when using an USB stick in your standard os?

 

Peter



#3 gilly_uk

gilly_uk
  • Members
  • 3 posts
  •  
    United Kingdom

Posted 08 April 2013 - 12:14 PM

I haven't tried running it from a USB disk but I have just copied the folder straight onto a new windows build and it runs absolutely fine. I even have another companies Win Live CD of which I extracted the boot.wim file mounted it copied the folder in and then rebuild the ISO and that worked when running off CD. It has to be something with the way either the win7PE_SE windows environment is build and/or the Portable apps are copied into the image. 

 

The only reason im trying to get this to work instead of copying the files straight into the boot.wim from my other image is that I couldn't get a shortcut to the program on the desktop to work as the shortcut patch didn't update to what it should be when rebuilding the ISO.



#4 gilly_uk

gilly_uk
  • Members
  • 3 posts
  •  
    United Kingdom

Posted 08 April 2013 - 01:10 PM

Solved - Rebuilt the ISO using a WIN7 x86 DVD instead of x64 and it is now working. Thank god it was a simple fix



#5 paraglider

paraglider

    Gold Member

  • .script developer
  • 1716 posts
  • Location:NC,USA
  •  
    United States

Posted 09 April 2013 - 02:20 AM

You were looking in the wrong directory for dsrole.dll - as its a 32 bit system dll it should be in windows\syswow64 on a 64 bit os.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users