Jump to content











Photo
- - - - -

Unable to boot from an USB HD.

hard drive usb windows seven vista nt.6

  • Please log in to reply
18 replies to this topic

#1 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 06 April 2013 - 04:58 PM

Hi folks,

 

Further to a different post (see http://reboot.pro/to...-19#entry170716  )  I'm trying to work out the unability of booting from an usb external hard drive.

 

This usb external HDD has gotten Windows 7 ultimate (64bits) installed using the NT6.x fast installer method.

 

When trying to reboot, I got this message :

"Reboot and select proper boot drive or Insert boot media in selected boot device and press a key"

 

 

Everest ultimate  give :

 

notebook Asus M70Vn series

mobile dualcore intel core 2 duo P8600, 2400Mhz    (alias Penryn-3M)  x86, x86-64, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1

 

motherboard ASUSTek Montevina

chipset motherboard Intel Cantiga PM45     

BUS   Intel AGTL+    width 64bits   

Bios AMI (12/21/09)

Ram 2x2Go DDR2-800  SDRAM   6-6-6-18 @ 400MHz

Intel ICH9M-E/M Sata AHCI controller

-----------------------------------------------------------------------------------------

external USB device   ( ntfs, active partition  - named I: )

model id :   WDC WD2500BEVS-22UST0

SATA @ Oxford    (ATA8-ACS)

484521 cylinders 1 6heads , 63 s/track, 512b/sector

488397168     LBA sectors

16 multiple sectors

buffer 8 Mo

50 bytes ECC

 

48-bit LBA  Yes

writing cache Yes, active

DMA setup auto-activate Yes , no active

 

plugged in Port 4 in USB 2.0 Root hub from controler intel ICH9 USB2 - 293A

 

driver : 6.0.6002.18005    (06/21/2006)   from Microsoft

-------------------------------------------------------------------------------------------------

usb2.0 1.3M UVC webcam in port 5

-------------------------------------------------------------------------------------------------

2 internal HD  ST9250320AS ( 250Go , 5400 rpm )

 

OS :   Vista homepremium 32bits        (6.0.6002 Vista RTM)

 

 

Any help 'd greatly appreciated. Thanks


Edited by jeppy, 06 April 2013 - 05:01 PM.


#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 05:19 PM

Set aside (temporarily :)) 7 and the installer you tried.

Just open the (external) disk in Disk management, remove the current "big" partition, re-create a new one (primary) 120 Gb in size.

Leave the rest of the disk "unused/unpartitoned".

Make sure the new partition is set as "active".

Format it as NTFS.

Open the corresponding drive letter in Explorer and copy to it's root just the file BOOTMGR (it should be in root of your Vista install, possibly hidden/system).

 

Try rebooting (as you did before with all other boot order entries disabled).

You should get an error, this time generated by the BOOTMGR (the one you posted previously came from the BIOS), something *like* "Windows failed to start..." File: \Boot\BCD Status: 0xc000000f

 

Report what happens.

 

:cheers:

Wonko



#3 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 April 2013 - 05:57 PM

To test if it is bootable, try booting it using an emulator - e.g. Download RMPrepUSB - press CTRL-Z to list large USb drives - then click on Test using QEMU button.

If it starts to boot then the problem is your BIOS. If it does not try to boot under QEMU at all, then the problem is with the way you prepared the USB hard disk.

Report back what happens...



#4 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 06 April 2013 - 06:10 PM

@Wonko :

 

got same message :

"Reboot and select proper boot drive or Insert boot media in selected boot device and press a key"

 

diskmgmt.gif

 

bootmgr.gif

I would like to point out something appearing strange to me.

When I used the NT6.x fast installer, I got a final message saying :

Creating bootmgr and bootsec....

The boot menu and boot sector has been created!

 

But I have not seen any boot file dated from to-day !!!

 

 

@Steve : Thanks.   I gonna try out your idea.


Edited by jeppy, 06 April 2013 - 06:13 PM.


#5 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 06:35 PM

Your BIOS still doesn't boot from the external disk. :(

 

WD drives "green" kind, in a not externally powered USB enclosure have been reported to be so slow in initializing/spinning up to become ready well past the BIOS has already interrogated the USB bus. (but yours is seemingly a "blue" disk :unsure:)

 

There could still be a timing problem of some kind, the message you are getting is "ambiguous", it could be a "device not ready" kind of error, a "not detected device" or a "detected but failing to boot" one.

 

Have you tried "cold booting" or "warm booting" (CTRL+ALT+DEL)?

 

Can you quickly check if for *any* reason the disk MBR CODE is not a bootable one?

You will need a hex/disk editor or more simply make a backup of it (first sector of \\.\PhysicalDriven) with HDhacker:

 http://dimio.altervista.org/eng/

 

:cheers:
Wonko



#6 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 06 April 2013 - 06:36 PM

@Steve :

I have downloaded, then installed RMPrepUSB v2.1.664.

Using Test using QEMU for the drive (which has only the bootmgr file on it as I showed in previous message).

 

I have entered   0  = None (do not emulate a HD ) then   484  for virtual ram size

and got that window :

qemu.gif



#7 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 06:41 PM

I have entered   0  = None (do not emulate a HD ) then   484  for virtual ram size

and got that window :

So, the disk is OK, as well as the MBR and PBR code. :thumbup:

 

The timing needs to be checked.

 

Ideally you should have an Y cable and power the disk from an external USB power supply (or if the enclosure provides a jack for an external power supply), try using it.

 

This way you should have the disk already spinning when you actually boot the PC.

 

Additionally check the BIOS settings, you may have something *like* "enable legacy USB support" that need s to be Enabled (or Disabled), and try different USB ports.

 

:cheers:

Wonko



#8 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 06 April 2013 - 06:46 PM

BTW: I also have an external big USB HDD in a EDEN dockable station ( Hitachi HDS  723020BLA642    2 To )

for my backups.

I could create a 250 Gb partition, re-using NT6.x fast installer, and reboot from it.

 

Do you think it's worthy ?



#9 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 07:03 PM

BTW: I also have an external big USB HDD in a EDEN dockable station ( Hitachi HDS  723020BLA642    2 To )

for my backups.

I could create a 250 Gb partition, re-using NT6.x fast installer, and reboot from it.

 

Do you think it's worthy ?

No, the issue is before and besides (and beyond :w00t:) the NT6.x fast installer.

A disk partitioned under Vista, formatted under it and with just the file BOOTMGR in root must boot (to the error you just got when testing in Qemu).

So something is missing in the very beginning.

 

That can be as said mainly:

  1. BIOS (either "absolute" like a limitation of some kind in it or "relative" like settings in it)
  2. Disk (the actual disk drive and the time it needs to be ready if powered by the same PC that is booting)
  3. Disk enclosure ( the controller in it having some limitation, again either "absolute" or "relative" )

So, if you have another USB hard disk is good to try it, but no need to re-do the NT 6.x fast installer, the last few simple steps of partitioning/formatting/copying BOOTMGR are faster and more than enough.

 

If you have a USB stick, it would be another thing to test, in which case you could use RMPREPUSB to partition/format it (all data on it will be deleted, so only do it if you have a "spare" USB stick or image it before doing the test).

 

Check also my everyday more outdated page, FAQ #10 is still essentially valid (especially on oldish hardware):

http://jaclaz.alterv...SB/USBfaqs.html

 

:cheers:

Wonko



#10 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 April 2013 - 07:10 PM

Have you correctly configured the BIOS?

Attach the WD USB disk and switch on the notebook.

In the Boot menu Boot Device Priority - you should set Removable Device as the first item.

In the Boot - Hard Disk Drives menu, you should set the WD USB HDD as first in the list



#11 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 07 April 2013 - 07:16 AM

Hello,

I have tried out with another external HDD.

heden.gif

This dockable usb station Heden BEHEDEX32U2 (S-ATA / USB2 ) is self-powered.

The HDD is an Hitachi 2To   ( 7200 rpm )

 

- I have formatted and activated a partition in which I put the bootmgr  ( took in Vista root )

and ....... I got same message

"Reboot and select proper boot drive or Insert boot media in selected boot device and press a key"

 

I have seen that the usb controller was first running during Asus booting.

 

 

- Testing using QEMU emulator  from RMPrepUSB gave the same error message as in a previous post ( see image )



#12 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 07 April 2013 - 09:08 AM

Have you correctly configured the BIOS?

Attach the WD USB disk and switch on the notebook.

In the Boot menu Boot Device Priority - you should set Removable Device as the first item.

In the Boot - Hard Disk Drives menu, you should set the WD USB HDD as first in the list



#13 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 07 April 2013 - 09:36 AM

Yes.

First thing I did.



#14 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 07 April 2013 - 09:39 AM

Do you see the USB drive listed during the POST? Is it listed in the BIOS menu? Does the USB HDD LED flash at all (is it being accessed by the BIOS). Is there a BIOS Boot Selection menu (e.g. by pressing ESC or F12 during POST)? Can it boot from a USB flash drive? Is there any BIOS options like Quiet boot or quick boot or splash screen that you can disable?



#15 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 07 April 2013 - 10:19 AM

This:

http://support.asus....P&os=24&no=1704

03.jpg

 

:cheers:

Wonko



#16 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 08 April 2013 - 07:55 AM

1 - Yes in BIOS Menu I see  my 3 hard drives ( the 2 internal ones SG and the usb one )  and I put the external usb WD at top of the list.

     and the boot device priority has been set to :

    (1) external device   (2)   cd/dvd     (3) hard drive     (4) network

 

2 - The white led was flashing a short time while booting.

 

3 - Quiet boot is enabled.

 

4 - My BIOS was up-to-date.   (v206)

 

In the meantime , I have decided tu use VirtualBox and I succeeded installing win7 ultimate x64 and my softwares.

 

But I'd like to get this annoying trouble ( not booting from usb ) to be fixing up.

 

Be sure I appreciate very much the time you spend to helping me.  Very rare I think.



#17 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 08 April 2013 - 08:59 AM

Disable Quiet Boot - this will at least show more info...



#18 jeppy

jeppy

    Newbie

  • Members
  • 10 posts
  •  
    France

Posted 08 April 2013 - 02:47 PM

Using a 1Gb flash drive with files set by Acronis True Image recovery I was able to boot.

 

So I'm puzzled



#19 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 08 April 2013 - 08:09 PM

Using a 1Gb flash drive with files set by Acronis True Image recovery I was able to boot.

 

So I'm puzzled

A good idea would be to now try imaging your USB stick "as is" (booting succesfully) to the hard disk, and see what happens.

 

:cheers:

Wonko







Also tagged with one or more of these keywords: hard drive, usb, windows seven, vista, nt.6

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users