Jump to content

- - - - -

booting .wim via pure syslinux?

wim syslinux

  • Please log in to reply
2 replies to this topic

#1 numbnuts

  • Members
  • 4 posts
    United States

Posted 27 March 2013 - 09:04 PM

Howdy boys!
I'm a long-time lurker and huge fan of the syslinux project -- I've been able to boot wim's using syslinux via PXELINUX for quite some time -- I recently came across a post indicating that it is possible to set it up in UBCD, so I set out to attempt booting via USB using a similar config, only I haven't been able to successfully duplicate the expected result.
I haven't been able to find much information on wim-booting purely from SYSLINUX and so now I'm curious... Is it possible to boot a wim via "pure" syslinux? I've read it can be done by chainloading Grub4DOS, and it's not that I can't, just that I'd rather not have to...
here's my folder structure:
/usb                             --root--
/usb/syslinux/               --folder containing main menu (default), bootimages, etc...--
/usb/syslinux/source/   --folder containing syslinux 5.01 (2013) source files--
/usb/ldlinux.sys            --bootloader--
/usb/syslinux.cfg          --bootloader config file--
Using the above folder structure, I've tried placing both the BOOT and SOURCES folders along with BOOTMGR in the USB root directory and/or in the syslinux folder without success, using:
MENU LABEL ^1) Wim Deploy
 COM32 syslinux/source/com32/chain/chain.c32
  APPEND boot ntldr=/BOOTMGR


Am I missing something entirely with the referenced UBCD outline?


With PXELINUX, I know the BOOT and​ SOURCES folders and the BOOTMGR needed to reside in the same folder as pxelinux.0... Do they need to reside in the some folder as ldlinux.sys with SYSLINUX (that's assuming it is possible with my config)? Does SYSLINUX have any verbose logging that would be able to tell me where I'm going wrong?




Edited by numbnuts, 27 March 2013 - 09:06 PM.

#2 numbnuts

  • Members
  • 4 posts
    United States

Posted 28 March 2013 - 01:17 AM

Apologies guys -- I went back and took a look at the version I'm using (I've got a mixed mess of paths that have worked for me over the last year or so and it seems I was/am pointing to an older version that I had thought I'd updated, but apparently missed) -- So the version I'm referring to is 4.05, not 5.x...


I've just began working on updating to 5.x but ran into problems loading vesamenu.c32 and libutil.c32/libcom32.c32 -- I was hoping with the paths I had established previously, I'd just be able to drop the source files into the directory and go, but only just discovered the file dependency, so I may have to revert back to 4.05 or 4.06 until I work this out with 5.x...


Anyhow, the same questions still apply... Is this possible with 4.x? The post I referred to is dated for 2009, and 4.05 (iirc) was released last year, so I would think it would still work.

#3 numbnuts

  • Members
  • 4 posts
    United States

Posted 28 March 2013 - 06:10 AM

I found another post between delicatepc and icecube from a couple years ago indicating a potential fix in the APPEND statement changing it from: 

APPEND boot ntldr=/BOOTMGR




After working out the directory structure and uppercase/lowercase filename/folder format on a clean stick with SYSLINUX 4.06 (not sure if that problem still exists -- I remember about 6 years ago having issues with it, but didn't remember until I was neck deep in troubleshooting), everything appears to be working now...


I'm usually pretty good at nailing down effective search terms, but widening my keyword search parameters to include windows boot components, I guess I hadn't reached that level of frustration quite yet... I get there eventually, even if I, admittedly, stumble over the answer looking for something else in my forays into the abyss.


Anyhow, thanks for this awesome repository of brilliant concepts thanks and for the awesome work you guys do...   :good:

Edited by numbnuts, 28 March 2013 - 06:11 AM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users