Jump to content











Photo
- - - - -

Usb key causing slow post when on usb 3 port

usb 3 syslinux

  • Please log in to reply
3 replies to this topic

#1 billyjoe

billyjoe
  • Members
  • 2 posts
  •  
    Canada

Posted 22 March 2013 - 04:05 PM

Hi Folks,

 

My usb flash drive is causing post to take minutes to progress, and then the drive is not present when the boot device selection list finally shows up (F12 prompt).

Not sure if this is related to Syslinux so I posted in the general usb forum. I have a corsair survivor 16gb usb 3 flash drive which I've formatted as ntfs and trying to get booting to the YUMI menu using syslinux 5.01. The problem is only happening when I have the drive plugged into the usb 3 port. When I change the port behavior in the bios to only function as usb 2, the problem persists. When I plug the drive into the other usb port which is usb 2 only, it works fine. The system is a lenovo x1 carbon ultrabook.

 

I've configured the flash drive as such using win 7:

1) Run diskpart,

- sel disk 2

- clean

- create part pri

- sel part 1

- format fs=ntfs quick      ;I need ntfs rather than fat32 because I have some .wim files which are 4gb+

- active

- assign letter=E

- exit

2) I robocopy the yumi files and my other boot images over to the key

3) I run syslinux 5.01 on the key: syslinux64.exe -d \multiboot\ -i E:

4) I also tried running syslinux with some different switches: syslinux64.exe -m -s -d \multiboot\ -i E:

 

Also I'm able to boot to winpe 3 from the usb 3 port when using a usb hdd (haven't tried yumi with syslinux with that hdd).

 

Is this likely an incompatibility between syslinux and the usb 3 port in this laptop? I checked the specs and it's an intel mobile qs77 express chipset which includes both usb 3 and 2 ports in the chipset.

 

Thanks!



#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 22 March 2013 - 04:16 PM

Did you check for the latest BIOS update?

http://support.lenov...?DocID=DS030684



#3 billyjoe

billyjoe
  • Members
  • 2 posts
  •  
    Canada

Posted 22 March 2013 - 05:04 PM

I just updated the BIOS and the behaviour persists. So I looked again in the BIOS options for the usb ports, and for the usb 3 port it is defaulted to Auto. I had already tried forcing it to usb 2 and that didn't help. So now I tried forcing it to usb 3, and now it works! I guess when it was set to Auto it was acting as a usb 2 port and it was not playing nicely with my usb 3 flash drive. I don't know why it didn't work on auto or usb 2 mode, but oh well. Thanks!



#4 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 22 March 2013 - 05:08 PM

Presumably if set to USB 3 then USB 2 devices won't work in that port??? Auto should work, but hey ho!







Also tagged with one or more of these keywords: usb 3, syslinux

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users