Jump to content











Photo
- - - - -

MSVBVM50 copy error ( windows xp sp3 text setup )

msvbvm50 xpsp3

  • Please log in to reply
42 replies to this topic

#1 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 02:19 PM

hello

as title says i have error while  copying this file in winxp sp3 text setup

the setup is from usb orginaly made with win2flash then copyed to be usable with g4d on ntfs usb

what ever i try to replace the file from the orginal file is the cd i get the same error even from another sp copy or even dl from internet

only this file has the problem !!! :(  so every time i have to skip this file

any ideas fellas ?

 

PS: this's maybe help
---------------------------


COMMAND LINE: FILE="F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_" FILEINFO FILESTART=0 SURE

RMPARTUSB v2.1.660 ©2012 RM Education plc [SSi]
=================================================

File Byte 0 (Sector 0.0)

============= SECTOR DATA ================


[Sector 0]  0MB
0000 4D 53 43 46 00 00 00 00 - 3F F1 08 00 00 00 00 00  MSCF.... ?ٌ......
0010 2C 00 00 00 00 00 00 00 - 03 01 01 00 01 00 00 00  ,....... ........
0020 00 00 00 00 49 00 00 00 - 2A 00 03 15 00 B0 14 00  ....I... *...°.
0030 00 00 00 00 00 00 17 2B - 00 20 00 01 6D 73 76 62  ......+ . ..msvb
0040 76 6D 35 30 2E 64 6C 6C - 00 D9 CF DF A9 82 43 00  vm50.dll .ظدك©‚C.
0050 80 5B 80 80 8D 26 10 F0 - 89 00 00 21 05 60 34 00  €[€€چ&ً ‰..!.`4.
0060 00 6D 00 DD DD E1 B6 C3 - 8D 18 16 CA 64 55 D4 A6  .m.ففل¶أ چتdUش¦
0070 90 5B B1 9A F1 EC A0 CA - C6 15 BF D6 1A 23 95 54  گ[±ڑٌى ت ئ؟ض#•T
0080 B8 9C 2D 3E 47 9E BA 57 - BD BF 97 E5 51 F7 52 54  ¸œ->G‍؛W ½؟—هQ÷RT
0090 EA AA A8 29 36 F4 8F A2 - 7F 12 2A D7 AE D5 2A CA  êھ¨)6ôڈ¢ *×®ص*ت
00A0 2C D1 18 0C 51 CD CC 20 - DE 22 00 F3 03 A3 F6 FB  ,ر.Qحج  ق".َ.£ِû
00B0 25 DE F7 C5 EE B7 6F 7B - 3B EC 91 2F EC C0 73 67  %ق÷إî·o{ ;ى‘/ىہsg
00C0 01 7B B0 D5 72 BC D9 6B - 2D 65 0F 1F F9 AD 22 8F  .{°صr¼ظk -eù­"ڈ
00D0 7A 63 2B CE 27 C7 D9 BF - 0A E4 1C AD 55 26 AD CE  zc+خ'اظ؟ .ن­U&­خ
00E0 D8 63 97 F9 68 13 5B EC - E2 22 89 C6 72 59 99 47  طc—ùh[ى â"‰ئrY™G
00F0 63 B2 50 50 34 A2 91 B6 - 50 98 32 24 B2 B6 98 90  c²PP4¢‘¶ Pک2$²¶کگ
0100 34 34 B2 B2 98 D8 36 44 - 92 92 D8 A0 C6 44 92 56  44²²کط6D ’’ط ئD’V
0110 98 E0 46 1A D7 64 4C A6 - 6D 49 3C 40 E2 F7 DD 7F  کàF×dL¦ mI<@â÷ف
0120 BB FF FF ED FF 00 04 06 - 00 88 66 AA 8C 8A C0 F7  »ےےيے... .ˆfھŒٹہ÷
0130 1F EF BC F4 39 BC CC BA - BC 2A 97 AB 9B 1B A7 24  ï¼ô9¼ج؛ ¼*—«›§$
0140 01 01 A2 00 02 63 9A 87 - F3 39 A2 3D B0 FB A1 E0  ..¢..cڑ‡ َ9¢=°û،à
0150 FE CB B5 EB 9D 94 F5 88 - 42 2B 82 33 7D 0A 33 89  ‏ثµë‌”ُˆ B+‚3}.3‰
0160 C2 45 FE 46 34 0B 8F 47 - A4 FC 24 71 6C C1 12 E5  آE‏F4.ڈG ¤ü$qlءه
0170 18 16 A5 53 12 BC A6 6F - FD A6 65 D2 26 7B A9 C9  ¥S¼¦o ‎¦eز&{©ة
0180 4E D8 4B 74 76 8F DD DA - 61 8D 36 CA A4 C5 6E 4D  NطKtvڈفع aچ6ت¤إnM
0190 48 9A A5 13 DA 5E 76 37 - C7 AB 9E EC A6 4D FB 91  Hڑ¥ع^v7 ا«‍ى¦Mû‘
01A0 1E C6 A9 71 E3 EF 94 63 - 90 81 13 89 4E A2 22 6F  ئ©qمï”c گپ‰N¢"o
01B0 4A 15 55 DE 2F C1 D5 1A - 11 1A 51 52 24 89 32 97  JUق/ءص QR$‰2—
01C0 CB ED 6E 3B E5 D3 3D 2F - 49 F7 B2 2B D5 72 FF 9E  ثيn;هس=/ I÷²+صrے‍
01D0 41 69 CA 75 C1 E8 FF 7F - DB D4 92 F0 95 33 BE 90  Aiتuءèے غش’ً•3¾گ
01E0 75 13 22 D9 EC DC 7F F6 - AF 21 5F 1A 2A 4A E2 7C  u"ظىـِ ¯!_*Jâ|
01F0 22 07 F3 EE 56 CE D3 B9 - F7 51 C7 EB 27 DA C4 B5  ".َîVخس¹ ÷Qاë'عؤµ

========= END OF SECTOR DATA ================



F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_ is 586047 bytes long (572.312 KiB).
 

MD5 : 210da9e59ff8e8cca1285aa90b907f68


Edited by Motasem, 22 March 2013 - 02:21 PM.


#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 5,342 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 22 March 2013 - 02:25 PM

Can you try a different target system (or a VM is it will work in one) and a different source USB drive?



#3 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 02:31 PM

no i didn't try another system ( because i dont have another now !  but my point is my usb will work on hundred of pc's a day so solution must be universal and file must be fixed

 

and i didn't try on VM yet and ( i will now ) but i need to be sure it work on real system this problem wasn't there before i change my xp usb installation files from sp2 tp sp3
 

PS: i have made memtest to be sure of my hardware and no errors



#4 steve6375

steve6375

    Platinum Member

  • Developer
  • 5,342 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 22 March 2013 - 03:09 PM

Can you copy the file to your USB drive (from original source) and call it 

F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_X

then delete

F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_

the rename F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_X to F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_

 

and try again?



#5 steve6375

steve6375

    Platinum Member

  • Developer
  • 5,342 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 22 March 2013 - 03:18 PM

I found the file on my system from an SP2 XP install and an identical file in an SP3 Xp ISO.

The filelength is 586047 and date is 4 August 2004, but the MD5 is 6e88c281d06414ccbc76971869245b67

 

This suggests it is corrupt and as it is a compressed file, it seems XP setup cannot unpack/extract it???



#6 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 03:24 PM

this's all info from hashmyfile  http://grabout.com/27PpPSiF

 

yes maybe your right  can you give me your file so i test with it ?



#7 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 03:28 PM

Can you copy the file to your USB drive (from original source) and call it 

F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_X

then delete

F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_

the rename F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_X to F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_

 

and try again?

yes i have try this as i mention in the first post that i did try to get the orginal file that was before even using win2flash to copy files to usb !



#8 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 04:39 PM

copying ur file didnt resolve the problem .... im now testing on new usb on the same system.

i wil report when im done



#9 steve6375

steve6375

    Platinum Member

  • Developer
  • 5,342 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 22 March 2013 - 04:40 PM

Did you take an MD5 of the file after downloading and an MD5 of the file after copying it to the USB drive?



#10 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 04:53 PM

this's it   http://grabout.com/bkDup2cL

 

PS:  You can make 1 more posts until A minute ago... so will some admin please add me more so i can post and replay here



#11 ilko

ilko

    Frequent Member

  • Advanced user
  • 487 posts
  •  
    Bulgaria

Posted 22 March 2013 - 06:11 PM

Does this error occur during Text mode of Setup?

Where did this line come from? What were you trying to do?

 

COMMAND LINE: FILE="F:\$WIN_NT$.~LS\I386\MSVBVM50.DL_" FILEINFO FILESTART=0 SURE

 

Can you zip and post your txtsetup.sif file? Or upload it to www.datafilehost.com for example and provide download link.



#12 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 22 March 2013 - 08:07 PM

1.yes it is during windows text mode setup

2. this line is from steve program called remprepusb i used an option called ( File Info ) so i wanted to give all info i have so others can help

3. my txtsetup.sif file is here http://dropmefiles.com/en/gl9zp



#13 ilko

ilko

    Frequent Member

  • Advanced user
  • 487 posts
  •  
    Bulgaria

Posted 23 March 2013 - 02:50 AM

msvbvm50.dll is found twice in txtsetup.sif. This usually is not an issue if booting from a CD, but from USB Setup complains.

 

 

 

[SourceDisksFiles]

....

msvbvm50.dll = 1,,,,,,,2,0,0

....

msvbvm50.dll = 100,,,,,,,2,0,0

 

Try deleting the first or the second entry, or just comment it out putting semicolon ( ; ) at front of the line.

Can't recall which txtsetup.sif was used in ~BT&~LS setup, but edit the one in root if present, the one in ~BT and the one in ~LS\I386\ just in case.



#14 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 23 March 2013 - 11:04 AM

I did commet them 1 by 1 and same problem but look when i commeted the first line i got the error at 44 percent ! And then i commeted the next line and got the error at the old position 88percent 



#15 ilko

ilko

    Frequent Member

  • Advanced user
  • 487 posts
  •  
    Bulgaria

Posted 23 March 2013 - 11:17 AM

Did you try leaving the first one uncommented and commenting only the second one?

Which txtsetup.sif do you edit? Where is it located?

 

Stock XP SP3 Pro has only

 

msvbvm50.dll = 1,,,,,,,2,0,0

 

Try also using proper unmodified sources.



#16 wimb

wimb

    Gold Member

  • Developer
  • 2,179 posts
  •  
    Netherlands

Posted 23 March 2013 - 11:26 AM

I did commet them 1 by 1 and same problem but look when i commeted the first line i got the error at 44 percent ! And then i commeted the next line and got the error at the old position 88percent 

 

 

Check if the file is mentioned in dosnet.inf and if missing then add rule 

 

d1,msvbvm50.dll

 

The second entry is not occurring in my  txtsetup.sif and should be removed probably.

 

Better is to use WinNTSetup which is insensitive to such dosnet.inf errors.

http://www.msfn.org/...winntsetup-v23/

 

:cheers:



#17 steve6375

steve6375

    Platinum Member

  • Developer
  • 5,342 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 23 March 2013 - 11:29 AM

Did I miss something? Did you resolve why the MD5 value of the file is wrong once it is copied to the USB drive?



#18 ilko

ilko

    Frequent Member

  • Advanced user
  • 487 posts
  •  
    Bulgaria

Posted 23 March 2013 - 11:41 AM

@wimb

Wasn't dosnet.sif is used only when preparing ~BT and ~LS folders? File is already present in ~LS\I386\. This should rule out dosnet.sif problem.

 

@Steve

Post #10, md5 hash is as it should be.

 

@Motasem

Can you also post your layout.inf?


  • wimb and steve6375 like this

#19 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 23 March 2013 - 08:54 PM

@ilko


yes i did try them seperated and i got the same error but as i explain ive had the problem with the file @ 88% of copying the file but when i commet the first line i got the error at 44% so i guess there must be tow msvbvm50.dl_ files... i dono if its true i only guess that

the textsetup.inf is at my usb root and its the same i edited

@wimb


yes the rule exists ( http://grabout.com/j7JbJsTx )

 

and about ( The second entry is not occurring in my  txtsetup.sif and should be removed probably. )

which one should be removed this one ( msvbvm50.dll = 1,,,,,,,2,0,0 ) or this one ( msvbvm50.dll = 100,,,,,,,2,0,0 ) ???

 

@ steve6375

 

no my friend u didnt miss anything and the md5 file check is identical ( http://grabout.com/bkDup2cL )

the first file at desktop is the one u sent to me and the next line is after copying to usb

@ ilko

 

this's my layout.inf ( http://dropmefiles.com/en/QhGm5 )


Edited by Motasem, 23 March 2013 - 08:56 PM.


#20 wimb

wimb

    Gold Member

  • Developer
  • 2,179 posts
  •  
    Netherlands

Posted 24 March 2013 - 06:42 AM

which one should be removed this one ( msvbvm50.dll = 1,,,,,,,2,0,0 ) or this one ( msvbvm50.dll = 100,,,,,,,2,0,0 ) ???

 

msvbvm50.dll = 100,,,,,,,2,0,0 should be removed.

It is not present in my case.

 

How was the XP Setup ISO prepared ?

 

The procedure that I use is described here

http://www.911cd.net...showtopic=24424

 

Install of XP or Windows 7 from USB After Booting with 7 PE and 
by using WinNTSetup2_x86.exe and Setup ISO file in Virtual drive

 

:cheers:



#21 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 24 March 2013 - 01:13 PM

but i commit this one and i got error so whats the point of removing it !!!



#22 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 24 March 2013 - 04:26 PM

so every one give me your attention please because this's sucks and take over a time more than it needs

 

first off my first goal is to install xp from usb...so all over the internet there's tow ways to do this

1. maping iso file

2. flat file usage like the one im using now

ive had alot alot alot of problems trying to install from flat file if i count problems maybe over 6 problems i face in this and now finaly we are all here stuck at this msvbvm.dll error file so...

some good guys here advise me to use alternative ways to boot iso file and alot of ready apps like (  YUMI ) and this's correct its easy with no errors and great but what im trying to do is getting this done with the lowest time i can so loading the iso file way was ignored for me from the beginning because at the first stage and the 2nd stage i have to load the iso of xp again and loading the file take alot of time for me or by the meaning of formatting 20 pc's a day !!! so i went to get the winxp setup flat file structure because it don't need to load anything

after that i find win2flash app and use it to make winxp install files and after that i copy them all to my multiboot usb and thanks to Steve who gave me alot of his time fixing errors after that because win2flash wasn't made to boot from grub !

untill now i have errors and every time its becoming complicated so what im searching for 

 

is there an app like win2flash  can make winxp setup files to load them in g4d ? i just want to try another thing or way of win2flash :(

 

ps: im now testing Rufus and i see its copying xp files extracted so maby this will work i will report .


Edited by Motasem, 24 March 2013 - 04:27 PM.


#23 steve6375

steve6375

    Platinum Member

  • Developer
  • 5,342 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 24 March 2013 - 04:53 PM

You could try rufus and then copy the files over to a multiboot drive?


  • Motasem likes this

#24 Motasem

Motasem

    Frequent Member

  • Advanced user
  • 168 posts
  • Interests:War Make's Men And Problems Make's You Expert
    MooT®
  •  
    Jordan

Posted 24 March 2013 - 05:00 PM

EXACTLY thats what im trying to do now

im trying now all the programs on the net

first i started with rufus and i have error so i dont want you all to dislike me so i didnt report the error and moved to WinSetupFromUSB

 

btw at the end of rufus it gave me error and i saved the log also i have try to boot it says ( press any key to boot from usb ... ) when i press anything the pc hang

----------

Finalizing...
W:autorun.inf already exists - keeping it
NTFS Fixup (Checkdisk)...
Volume label is GRTMPVOL_EN.

CHKDSK is verifying files (stage 1 of 3)...
File verification completed.
CHKDSK is verifying indexes (stage 2 of 3)...
Correcting error in index $I30 for file 69.
Correcting error in index $I30 for file 69.
Correcting error in index $I30 for file 69.
Correcting error in index $I30 for file 69.
Correcting error in index $I30 for file 3151.
Correcting error in index $I30 for file 3151.
Index verification completed.

Errors found.  CHKDSK cannot continue in read-only mode.
Error while checking disk.
Found drive 'Generic USB Flash Disk USB Device'
1 device found.
Sector Size: 512 bytes
Cylinders: 491, TracksPerCylinder: 255, SectorsPerTrack: 63
Partition type: MBR, NB Partitions: 1
Disk ID: 0x0036995B
Partition 1:
  Type: NTFS (0x07)
  Size: 3.8 GB (4042260480 bytes)
  Start Sector: 2048, Boot: No, Recognized: Yes
---------



#25 ilko

ilko

    Frequent Member

  • Advanced user
  • 487 posts
  •  
    Bulgaria

Posted 24 March 2013 - 05:03 PM

@ ilko

this's my layout.inf ( http://dropmefiles.com/en/QhGm5 )

Nothing wrong here. I am confused, if you properly edit txtsetup.sif and leave only the line msvbvm50.dll = 1,,,,,,,2,0,0 and everything is fine with the hardware, the error should not come up. I've seen similar reports, with a single file making problems without a definitive solution.

 

What I'd do:

1) Use stock, untouched XP SP3 source. There are plenty of them floating around. The one you are using may have other issues not yet revealed.

2) Integrate the appropriate driver packs.

3) Avoid using nLite, or use it in experimental way, so you can keep track if a change breaks Setup. And use it BEFORE BTS DP Base.

4) Use WinSetupFromUSB 1.0 beta8 or beta9 to prepare the USB disk. It has number of useful options which no similar program has:

- add up to 99 XP/2000/2003 sources in a single partition

- uses grub4dos as bootloader, as you needed

- properly supports all the mentioned versions with no files deleted if source is not XP SP3

- Beta9 even still not published supports multiple Vista/7/8/Server 2008/2012 sources added as ISO files and as far as I could test it works just fine. It also takes care of some rare cases, where every other method of installing Vista and above would fail.

- supports automatic addition of the needed mass storage (F6) driver thanks to Chenall's DPMS. In beta9 DPMS is fixed and should work fine, the original one, which was included in beta8 has a serious bug

- properly handles multi disk scenarios, for example 2 or more internal disks

 

http://code.google.c...e DownloadCount

http://www.msfn.org/...omusb-with-gui/