Jump to content











Photo
- - - - -

WinXP AOE boot problem with new hardware


  • Please log in to reply
3 replies to this topic

#1 tinoy69

tinoy69

    Newbie

  • Members
  • 24 posts
  •  
    Philippines

Posted 22 February 2013 - 11:05 PM

I've been looking for a solution for this for a long time...hoping to find a solution here...

 

i've religously followed Sir Cristian Magadan's tutorial...

 

https://windowsdiskl...e.wordpress.com

 

and been able to boot winxp via aoe (encountered problems along the way, but successfully managed to get it working)

 

i've been able to boot it only on old systems (g31 and g41)

 

but...using the exact same method of successfully booting the above systems but using new hardware

h61 (gigabyte h61m-ds2+intel g620) have not able to boot successfully, always stop (7b) or stuck at loading screen

 

now, this has been the common problem of the above tutorial and googling about the topic

leads to no answers

 

these are the steps i've taken to successfully aoe boot on my g31, g41

 

1) install winxp (mines an nlited winxp sp3, without driverpacks) on a single 3gb partition, disabled pagefile

2) installed only lan driver (via driverpack solution)

3) installed aoe driver

4) set lan card driver "start" parameter to 0

5) used dd to image whole partition to a "shared" drive on the server (IMG file created)

6) disconnecting drive and enabling network boot, while serving the IMG via vblade

 

I've used this steps to successfully network boot 6pcs i have here (g31, g41) without problems

 

i tried this same steps on the h61 board, it doesn't work...

 

-more info

the gigabyte mobo uses UEFI

tried updating to standard drivers (ide+isa), still won't boot

haven't tried creating vhd from virtualbox, then using that...i will try that next...

enabled /sos on boot.ini, stuck on the first screen where cpu and memory is displayed

 

what could seem to be the problem? as the steps i've taken works on the old architecture...

i'm trying to solve this for the longest time...

 

i will give more details on what i've done, also reading "universal xp", "usb boot", other topics that could

help me in this one...



#2 tinoy69

tinoy69

    Newbie

  • Members
  • 24 posts
  •  
    Philippines

Posted 27 February 2013 - 08:33 PM

hmmm...made my laptop (ibm t60, 965 chipset) boot aoe using the above steps, works great...

 

...but still not able to aoe boot the gigabyte h61 board

 

blue screen on 7b "ndis"

 

...but, using sha0 tutorial on "make computer a boot on computer b"

 

and following the hal, ntoskrnl part, and the /sos switch

 

aoe booting from the same board, by choosing "standard hal" from boot menu

boot log shows that loading devices get past "ndis"

it does not blue screen anymore...but...

 

windows have been able to display the initial screen (one with cpu and memory info)

but just in the upper left corner

 

AoE boot via IPXE

NIC "lan machine id" target e0.14

ERROR: "lan machine id" not found

 

where does this message come from? aoe32.sys, ipxe?

 

please, if anyone can help?



#3 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 215 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 16 June 2014 - 04:14 PM

I have very similar problem but i tried install WinXP from AoE-ISO to AoE-HDD. I make test in MS VPC 2007

  • with IntegrateDRV integrate drivers net21x4, iScsiPrt, SanBootConf, NICBootConf to target (unpacked xp.ISO)
    IntegrateDrv /driver=..\Drivers\net21x4 /driver=..\Drivers\iScsiPrt\x86 /driver=..\Drivers\sanbootconf /driver=..\Drivers\nicbootconf /target=E:\win\files\
  • with nLite integrate AoE TXT-Mode + WinVBlock TXT-Mode drivers
  • make RAW disk image san.img 1500MB
  • run vBlade server for san.img and xp.iso
    san.img -> Shelf/Slot 0.0
    xp.iso -> Shelf/Slot 0.1
  • boot MS VPC machine from iPXE, go to shell and execute this command:
    dhcp
    sanhook --drive 0x80 aoe:e0.0
    sanboot --drive 0xe0 aoe:e0.1
    
    Press any key to boot from CD
  • after press any key to boot from CD WinXP Setup runs, load all the necessary (integrated) drivers but end with BSOD 7B

Please watch this video as proof that the drivers are loaded -> win_setup.avi

Maybe NIC card over AoE no have IP like over iSCSI ???
5798204m.png 5788988m.png


Edited by reboot12, 16 June 2014 - 04:18 PM.


#4 reboot12

reboot12

    Frequent Member

  • Advanced user
  • 215 posts
  • Interests:WinXP, Debian, OpenWrt, gPXE, iPXE, BIOS, Coreboot
  •  
    European Union

Posted 14 February 2016 - 05:40 PM

Can not be installed directly WinXP via AoE but if first install WinXP using iSCSI, later possible boot using AoE
This is normal boot screen WinXP over AoE:
aoe_ipxe.png

In winxp.iso need integrate drivers:

with IntegrateDRV 1.1.9

  • network ethernet card (any NIC driver if install WinXP from local optical drive)
  • iScsiPrt
  • sanbootconf
  • nicbootconf
  • AoE (PNP) - delete txtsetup.oem and aoe.0 files, delete unwanted spaces

Note! To AoE driver was available in Device Manager after installation you need to change in the aoe.inf file string AoE to Root\AoE:

[AoEDriver]"AoE x86"=install, Root\AoE
[AoEDriver.NTamd64]"AoE x64"=install, Root\AoE

with nLite 1.4.9.3

  • WinVBlock (TXT) - optional but if use nLite then during GUI-mode installation phase, you'll not be warned about installing unsigned drivers

Fixed drivers separated x86 & x64:

AoE (PNP) - Attached File  aoe_root_PNP_x86_x64.zip   72.21KB   94 downloads
WinVBlock (TXT) - http://reboot.pro/to...-23#entry193748

WARNING! IntegrateDRV integrates driver AoE type PNP but it is available in the TXT WinXP installation phase. AoE integrate possible only together with sanbootconf, nicbootconf and NIC driver otherwise appear BSOD 7E in WinXP TXT setup:
aoe_txt_7E.png

Note: sanbootconf 1.1.1 driver from IntegrateDRV not support gPXE:
aoe_gpxe.png sanbootconf.sys.png
(the WARNING is since version sanbootconf 0.9.9: (driver) Warn about use of unsupported software)

Of course, AoE also works without iSCSI drivers - just a change in the registry service ethernet card DWORD value Start type to zero. But in this case need install WinXP to real disk, manually install AoE driver and make RAW disk image.
Identifying the network service name and enabling network boot

P.S. There are three options to run WinXP:
all_drivers.png
iscsi.png aoe.png winvblock.png

 

WinVBlock is twice but this is TO DO:

 

Note: By using the ISO image with integrated WinVBlock in real optical drive appears twice in Device Manager but when mapping ISO vanilla + F6 floppy or ISO nLite integrated WinVBlock occurs only once in the device manager :-)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users