Jump to content











Photo

Is there a limit on the number of partitions for Windows 8 ?


  • Please log in to reply
1 reply to this topic

#1 gbrao

gbrao

    Frequent Member

  • Advanced user
  • 379 posts
  •  
    India

Posted 05 February 2013 - 03:22 AM

Has anyone installed / booted Windows 8 on a system where there are more than, say, 24 partitions. I think there is a bug ( at least now ) in W8 that does not allow it to boot in such cases.

 

My neighbour had a hdd with 3 primary partitions & 10 logical partitions. The hdd was in bad shape so they bought a new hdd. I created the same number of partitions on the new hdd. Installed W7 to one pri of the new hdd, W8 Pro to another pri, with the old hdd disconnected. Both worked fine. I then reconnected the old hdd (and hid the primary partitions on the old hdd) so they could copy files from the old hdd to the new one. W7 (and a XP PE) booted fine. But W8 would reboot almost immediately. Repair failed too. I then hid some of the partitons on the old hdd, same problem. I then formatted the partition with W8 and tried to reinstall W8 with both hdds attached. The boot process would throw up a error while copying files saying unable to find some file. I was installing from USB btw.

 

So has anyone had a similar experience ? Is it the number of drives that is causing the problem ?



#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15340 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 05 February 2013 - 10:27 AM

So has anyone had a similar experience ? Is it the number of drives that is causing the problem ?
IMHO too many variables (including the reported "bad shape" of the original hard disk) and too little details to provide a senceful answer.

You might be hitting some issue with the drive letter assignment/automounting features (limited - by design - to 24 drive letters) but it is a "loooong" shot (in the dark).

With ONLY the "new" hard disk connected, you can try mounting any "non-vital for booting" partition/volume on the "new" hard disk to mountpoints on the "main" NTFS volume, try cleaning the MountedDevices key in the Registry from non used letters, reboot, try if everything is accessible normally, then switch off, add the "old" hard disk and try booting again.

:cheers:
Wonko




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users