Jump to content











Photo
- - - - -

Windows-8 wont boot after installing Linux

uefi dual-boot secure-boot

Best Answer twohot , 22 January 2013 - 04:17 AM

This issue was conquered yesterday morning. So, what was the fix?
  1. Discovered that the current version of os-prober (12.2) does not support chainloading of another EFI bootloader, therefore it was generating a faulty menu entry for Win-8. First step was to disable os-prober

    echo GRUB_DISABLE_OS_PROBER=true >> /etc/default/grub

     

  2. Establish the EFI boot partition holding the Windows boot manager and probe it for string hints search parameter (in my case it was: "/efi/Boot/bootx64.efi". I found lots of examples pointing to "/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi". Note that, in fedora, the command for this is grub2-probe. Many examples online had grub-probe. This was confusing at first.

     

    grub2-probe --target=hints_string  /efi/Boot/bootx64.efi

     

  3. Create a custom menuentry for Win-8 UEFI-GPT system in "/etc/grub.d/40_custom" and add the results of the above command on the search line. It will look like the following:

     

    menuentry "Microsoft Windows x86_64 UEFI-GPT" {
        insmod part_gpt
        insmod fat
        insmod search_fs_uuid
        insmod chain
        search --fs-uuid --no-floppy --set=root <insert ouput from grub2-probe here>
        chainloader /efi/Boot/bootx64.efi
    }

     

  4. Run grub2-mkconfig as root using the output to replace the current EFI grub.cfg. grub2-mkconfig uses the contents of "/etc/default/grub" and "/etc/grub.d/40_custom" to create a working GRUB menu list

     

    # grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

     

  5. Reboot and Enjoy

 

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 twohot

twohot
  • Members
  • 6 posts
  •  
    Nigeria

Posted 19 January 2013 - 05:57 AM

The Machine?:  Dell Inspiron (intel-i7) with 8GB RAM, 1TB HDD, GPT-partitioning, and UEFI boot

 

The Process?:  I installed Fedora Linux (version 18) from a non-EFI USB-drive hoping to achieve dual-booting between Win-8 and Fedora.  I tried to preserve the original partitioning structure by squeezing the installation between  the OS partition and the recovery partition.  I ended up with the following GPT table:

 

[EFI system (FAT)]  [Another System Partition (FAT)]  [Microsoft Reserved Partition (Unknown)]  [Recovery Environment (NTFS)]  [Basic Data (actually Windows -- NTFS)]  [BIOS-boot (Unknown)]  [Linux (/home EXT4)]  [Fedora-18 (root  EXT4)]  [Linux (swap EXT4)]  [Windows Recovery Environment (NTFS)]


The result?:  Windows-8 does not show up on GRUB.  The machine is essentially a Linux-only machine which wasn't the intention.  However, contents of the above partitions are still intact.  Linux boots only on Legacy BIOS mode.  Once I set the BIOS to EFI nothing works.  The Windows Boot Manager on the BIOS boot menu does nothing

 

The request:  How do I restore Windows Booting without reinstallation on this machine?.  I would still like to dual-boot with Fedora-18.  *NOTE: I backed up the recovery program from within Windows before embarking on this adventure.  The resultant EFI USB from the backup utility doesn't help much to the best of my knowledge. 



#2 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 19 January 2013 - 08:23 AM

Not a solution of your present problem, but here is some info on UEFI MultiBoot of Windows 8 and Linux.

I used USB-harddisk with Standard MBR partition table and FAT32 Boot partition and NTFS System partition.

 

UEFI Multiboot USB - Windows 8 and Linux Parted Magic

http://reboot.pro/to...e-2#entry165182

http://reboot.pro/to...t-usb-harddisk/



#3 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1682 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 19 January 2013 - 07:43 PM

The Machine?:  Dell Inspiron (intel-i7) with 8GB RAM, 1TB HDD, GPT-partitioning, and UEFI boot

 

The Process?:  I installed Fedora Linux (version 18) from a non-EFI USB-drive

I think you meant a non-GPT USB storage device.  A USB storage device can be neither BIOS nor (U)EFI; it's not a computer.

 

hoping to achieve dual-booting between Win-8 and Fedora.  I tried to preserve the original partitioning structure by squeezing the installation between  the OS partition and the recovery partition.  I ended up with the following GPT table:

 

[EFI system (FAT)]  [Another System Partition (FAT)]  [Microsoft Reserved Partition (Unknown)]  [Recovery Environment (NTFS)]  [Basic Data (actually Windows -- NTFS)]  [BIOS-boot (Unknown)]  [Linux (/home EXT4)]  [Fedora-18 (root  EXT4)]  [Linux (swap EXT4)]  [Windows Recovery Environment (NTFS)]


The result?:  Windows-8 does not show up on GRUB.  The machine is essentially a Linux-only machine which wasn't the intention.  However, contents of the above partitions are still intact.  Linux boots only on Legacy BIOS mode.  Once I set the BIOS to EFI nothing works.  The Windows Boot Manager on the BIOS boot menu does nothing

 

The request:  How do I restore Windows Booting without reinstallation on this machine?.  I would still like to dual-boot with Fedora-18.  *NOTE: I backed up the recovery program from within Windows before embarking on this adventure.  The resultant EFI USB from the backup utility doesn't help much to the best of my knowledge. 

Please use gdisk or another GPT partitioning tool to report here which partition is marked as active, if any.  Please mount each FAT or EFI system partition and list the directory contents of each, possibly with:

cd /mnt/mountpoint && find .

GRUB will have placed itself as a file called BOOT*.EFI in one of the FAT or system partitions.  BootMgr will have done the same thing on one of the partitions, or GRUB might have overriden it.  Reporting these directory contents here will probably reveal more information.



#4 twohot

twohot
  • Members
  • 6 posts
  •  
    Nigeria

Posted 19 January 2013 - 10:23 PM

Made Progress.   I uninstalled Fedora (with Legacy BIOS Boot) and installed it with EFI-support.  Now Grub lists Windows-8 on the boot menu.  The only problem is that the Windows entry throws some errors:

 

error: can't find command 'drivemap'
error: invalid EFI File path

Press any key to continue ....

That's a pointer, I think.  What next?

 

I also have some partitioning details produced by bootinfoscript (sourceforge):

http://paste.stg.fed...roject.org/3312



#5 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1682 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 20 January 2013 - 04:16 AM

That's a pointer, I think.  What next?

 

I also have some partitioning details produced by bootinfoscript (sourceforge):

http://paste.stg.fed...roject.org/3312

The bootinfoscript output is very useful for observing your partition layout, but how about the other suggestions?



#6 twohot

twohot
  • Members
  • 6 posts
  •  
    Nigeria

Posted 20 January 2013 - 05:00 AM

cd /mnt/mountpoint && find .

 

Isn't something missing in that command?  What is it finding?



#7 twohot

twohot
  • Members
  • 6 posts
  •  
    Nigeria

Posted 20 January 2013 - 10:49 PM

MORE PROGRESS:

Both OSes now boot on the machine. Fedora boots fine via GRUB while Windows-8 boots fine via the Windows Boot Manager -- which is accessible by pressing F2 for "boot options" after powering-up. GRUB shows a Windows-8 entry but choosing that option throws the error message mentioned above and, of course, Windows Boot Manager doesnt even think fedora exists on the machine.

The desired behaviour is for both OSes to be booted from the GRUB menu.

Any ideas?



#8 twohot

twohot
  • Members
  • 6 posts
  •  
    Nigeria

Posted 22 January 2013 - 04:17 AM   Best Answer

This issue was conquered yesterday morning. So, what was the fix?
  1. Discovered that the current version of os-prober (12.2) does not support chainloading of another EFI bootloader, therefore it was generating a faulty menu entry for Win-8. First step was to disable os-prober

    echo GRUB_DISABLE_OS_PROBER=true >> /etc/default/grub

     

  2. Establish the EFI boot partition holding the Windows boot manager and probe it for string hints search parameter (in my case it was: "/efi/Boot/bootx64.efi". I found lots of examples pointing to "/boot/efi/EFI/Microsoft/Boot/bootmgfw.efi". Note that, in fedora, the command for this is grub2-probe. Many examples online had grub-probe. This was confusing at first.

     

    grub2-probe --target=hints_string  /efi/Boot/bootx64.efi

     

  3. Create a custom menuentry for Win-8 UEFI-GPT system in "/etc/grub.d/40_custom" and add the results of the above command on the search line. It will look like the following:

     

    menuentry "Microsoft Windows x86_64 UEFI-GPT" {
        insmod part_gpt
        insmod fat
        insmod search_fs_uuid
        insmod chain
        search --fs-uuid --no-floppy --set=root <insert ouput from grub2-probe here>
        chainloader /efi/Boot/bootx64.efi
    }

     

  4. Run grub2-mkconfig as root using the output to replace the current EFI grub.cfg. grub2-mkconfig uses the contents of "/etc/default/grub" and "/etc/grub.d/40_custom" to create a working GRUB menu list

     

    # grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

     

  5. Reboot and Enjoy

 







Also tagged with one or more of these keywords: uefi, dual-boot, secure-boot

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users