Jump to content











Photo
- - - - -

BSOD 'winsrv'


  • Please log in to reply
11 replies to this topic

#1 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 21 March 2007 - 06:16 PM

Some languages (I currently know Spanish, Hungarian and Polish) got a blue screen when booting from ISO.

This is fixed now by a new version 018 of the hivesFactory script.

I did an upload to nativeEx_barebone, but you should be able to use the script in XP Live CD, too.

I tested in Spanish and it has been ok.
Because I do not have Polish and Hungarian CDs:

@All:
Whoever gets a blue screen with a message about 'winsrv' and 'reinstall':

Try the new version and post the results here :cheers:

Peter

#2 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10501 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 21 March 2007 - 08:16 PM

Another bug solved! :cheers:

#3 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 22 March 2007 - 01:34 AM

For the Hungarian XPSP2 source this HoJoPE Hives Factory Version=018 (with WinBuilder 068 - beta 13)
not working

in the nativeEx_barebone project:
(the settings are at the defaults as downloaded from server psc.boot-land.net/Projects/)
result is the same in emulator (qEmu, MS Virtual PC 2007, InnoTek VirtualBox) and from burned CD on real machine

now there is no BSOD with 'STOP: c0000135' and 'winsrv' and 'reinstall' messages
but after the bootlogo suddenly reboot without any error message

also not working in the LiveXP project:
after the bootlogo the desktop appears - without desktop icons - and popup an error message box
(with 'RUNDLL' header) says: exception while running "X:\i386\system32\iernonce.dll,RunOnceExProcess"
when i click on the OK button the machine reboot

nevertheless i can manage WB to make a bootable CD from my Hungarian source
this method works only in the LiveXP project
and not working at all in the nativeEx_barebone project:
i exported the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls
registry key from my real XP and converted it to script

the script that helped for me with the new Hives Factory Version=018 is:
[process]

Echo,"Copying files.."

FileCopy,"%ScriptDir%\c_1250.nls","%TargetDir%\I386\system32"

FileCopy,"%ScriptDir%\c_1252.nls","%TargetDir%\I386\system32"

FileCopy,"%ScriptDir%\c_437.nls","%TargetDir%\I386\system32"

FileCopy,"%ScriptDir%\c_850.nls","%TargetDir%\I386\system32"

FileCopy,"%ScriptDir%\c_852.nls","%TargetDir%\I386\system32"

FileCopy,"%ScriptDir%\c_10000.nls","%TargetDir%\I386\system32"

FileCopy,"%ScriptDir%\c_10029.nls","%TargetDir%\I386\system32"

Echo,"Loading registry hive: [%TargetDir%\i386\System32\setupreg.hiv]"

RegHiveLoad,Tmp_setupreg_hiv,%TargetDir%\i386\System32\setupreg.hiv

Echo,"Writing new values on registry hive.."

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","ACP","1250"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","OEMCP","852"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","MACCP","10029"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","OEMHAL","vga852.fon"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","1250","c_1250.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","1252","c_1252.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","437","c_437.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\codepage","850","c_850.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","852","c_852.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","10000","c_10000.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","10029","c_10029.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\language","Default","040e"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\language","040e","l_intl.nls"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\language groups","1","1"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\Locale","(Default)","00000409"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\locale","00000409","1"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\locale","0000040e","2"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\locale\alternate sorts","00010407","1"

RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\nls\locale\alternate sorts","0001040e","2"

RegHiveUnLoad,Tmp_setupreg_hiv


#4 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 March 2007 - 07:25 AM

For the Hungarian XPSP2 source this HoJoPE Hives Factory Version=018 (with WinBuilder 068 - beta 13)
not working

in the nativeEx_barebone project:
(the settings are at the defaults as downloaded from server psc.boot-land.net/Projects/)
result is the same in emulator (qEmu, MS Virtual PC 2007, InnoTek VirtualBox) and from burned CD on real machine

now there is no BSOD with 'STOP: c0000135' and 'winsrv' and 'reinstall' messages
but after the bootlogo suddenly reboot without any error message

also not working in the LiveXP project:
after the bootlogo the desktop appears - without desktop icons - and popup an error message box
(with 'RUNDLL' header) says: exception while running "X:\i386\system32\iernonce.dll,RunOnceExProcess"
when i click on the OK button the machine reboot

nevertheless i can manage WB to make a bootable CD from my Hungarian source
this method works only in the LiveXP project
and not working at all in the nativeEx_barebone project:
i exported the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls
registry key from my real XP and converted it to script

the script that helped for me with the new Hives Factory Version=018 is:

[process]

 Echo,"Copying files.."

 FileCopy,"%ScriptDir%\c_1250.nls","%TargetDir%\I386\system32"

...

 Echo,"Loading registry hive: [%TargetDir%\i386\System32\setupreg.hiv]"

 RegHiveLoad,Tmp_setupreg_hiv,%TargetDir%\i386\System32\setupreg.hiv

 Echo,"Writing new values on registry hive.."

 RegWrite,HKLM,0x1,"Tmp_setupreg_hiv\ControlSet001\Control\Nls\CodePage","ACP","1250"

...

 RegHiveUnLoad,Tmp_setupreg_hiv


Thanks for yor help, Dera!

Can you please PM me your Hungarian:
  • HIVEDEF.INF
  • HIVECLS.INF,
  • HIVESYS.INF,
  • HIVESFT.INF,
  • INTL.INF
  • SHELL32.DL_
A second:
Inside nativeEx_barebone, after you have built the (rebooting) project, start Tools > RegEditWB and export the project's structure ....\NSL you described above.
I need that, too.

Peter

#5 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 22 March 2007 - 12:23 PM

Thanks for yor help, Dera!

Can you please PM me your Hungarian:

  • HIVEDEF.INF
  • HIVECLS.INF,
  • HIVESYS.INF,
  • HIVESFT.INF,
  • INTL.INF
  • SHELL32.DL_
A second:
Inside nativeEx_barebone, after you have built the (rebooting) project, start Tools > RegEditWB and export the project's structure ....\NSL you described above.
I need that, too.

Peter

[attachment=1667:rebooting_error.zip]

#6 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 March 2007 - 02:13 PM

[attachment=1667:rebooting_error.zip]

Many thanks, Dera :cheers:
But sorry, I forgot one file :cheers:
I also need txtsetup.sif.

Peter

#7 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 22 March 2007 - 03:08 PM

I also need txtsetup.sif


Sorry !
i am afraid a liitle misleading you
i wrote my script doesn't help in the 'nativeEx_barebone' project and i am sure yesterday it was true at my home pc
but today when redownloaded the project and tested again on an other pc
experienced it solve the reboot problem in your project too!

[attachment=1669:txtsetup.zip]

#8 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 22 March 2007 - 04:49 PM

New version 019 of hiveFactory is available for download! :cheers:

Many thanks to Dera for his Hungarian files. :cheers:

They helped me to do the final fix adjustements.

With my 'Fake Hungarian' source -made from German XP and Dera's files- I boot into a half Hungarian environment.

So it seems to run.

Peter

#9 dera

dera

    Gold Member

  • .script developer
  • 1335 posts
  •  
    Hungary

Posted 22 March 2007 - 08:55 PM

New version 019 of hiveFactory is available for download! :cheers:


Great!
Thanks Peter!

Boot fine in nativeEx_barebone and LiveXP too!

#10 asiekierka

asiekierka

    Member

  • Advanced user
  • 48 posts

Posted 17 April 2007 - 09:52 AM

I have the same BSOD... :/ with latest nativeEX.

#11 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10501 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 17 April 2007 - 10:06 AM

Would you please post your log.html to see more details? :cheers:

#12 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12701 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 17 April 2007 - 10:06 AM

I have the same BSOD... :/ with latest nativeEX.


Can you please post your (I think Polish) source files
  • HIVEDEF.INF
  • HIVECLS.INF,
  • HIVESYS.INF,
  • HIVESFT.INF,
  • INTL.INF
  • SHELL32.DL_
  • txtsetup.sif
Peter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users