Jump to content











Photo
- - - - -

getting ImDisk error: Cannot open drive for direct access, Access is Denied.


  • Please log in to reply
2 replies to this topic

#1 YeahPete

YeahPete
  • Members
  • 2 posts
  •  
    United States

Posted 12 January 2013 - 01:24 PM

New user here.  First I wanted to thank Olof for making this program.  Great work! I heard so many good things about it, so I decided to give it a try.

 

The Error:

In the GUI, when I click "Save image..." I get this error: with a big yellow ! on the left.

"ImDisk Virtual Driver"

"Cannot open drive for direct access:"

"Access is denied."

 

Windows 7 Professional x64

 

 

Why I want to use ImDisk.

I casually play a game called Path of Exile.  The game constantly loads from my slow hard drive.  Loading the game from RAM would help tremendiously.

 

So how am I getting this error?

I followed the tutorial here:  ,

but was unable to do the same things he did on his computer.

 

What I did Step by Step.

Double Click ImDisk Virtual Driver in Control Panel

Click "Mount New"

Drive Letter: Z

Size of virtual disk: 512 MB

Click OK!

 

Format Disk => NTFS => Quick Format => Start => OK

 

Select Drive Letter => Save image...

 

Get error. :(

-----------------------------------------------------------------------------------

So I've tried many things to try and fix this but my lack of programming/windows knowledge

is definately holding me back. 

I've attempted all 3 file system types.

I've uninstalled and reinstalled w/ different versions.

I've tried DataRAM Ramdisk.  That worked, but I like this program better and would like this program to work.

I've tried to disable Device signing check for windows, still didn't work.

I've updated windows and restarted.

I turned firewall and antivirus off.

 

I saw somewhere someone mentioned UAC.  I don't know what UAC is or how to disable it on my system. But is this a possible reason as to it not letting me save the image.

------------------------------------------------------------------------------------

A side note, the turorial I was watching, the guy was dragging and dropping files from his open windows to the command line while an administrator.

 

When I tried this it wasn't working?  I had to type mklinks manually, why was his so easy?

 

 

I know long post I wanted to be as descriptive as possible.  Thank you all in advance for helping.

Last question.. :) Is there a place with a simple tutorial for people like me to use the cmd line?  I think another possible workaround to my problem is to create a batch file and mount each file individually and load it directly to the RAM without saving the image.  I have to learn about this though as I know nothing about batch files or the cmd prompt for that matter :/.

 

THANKS AGAIN ALL!



#2 v77

v77

    Silver Member

  • Team Reboot
  • 530 posts
  •  
    France

Posted 12 January 2013 - 02:11 PM

It is a well known issue...

This command needs admin rights, and Explorer doesn't have it by default. So, there is 3 workarounds:

- use an alternative explorer that you can easily start with admin rights, such as http://www.freecommander.com/

- use the following command in a command prompt with admin rights:

rundll32 imdisk.cpl,RunDLL_SaveImageFile Z:

- use my GUI :) : in the Advanced tab, use "Save as Image File..." button with the appropriate drive letter

(I will release a new version very soon)

http://reboot.pro/to...-first-release/


  • YeahPete likes this

#3 YeahPete

YeahPete
  • Members
  • 2 posts
  •  
    United States

Posted 12 January 2013 - 02:52 PM

AHhhh! it worked! TYTYTY I knew it was something so simple. I literally spent 10 hours trying to get this to work. :P

 

I Used:

rundll32 imdisk.cpl,RunDLL_SaveImageFile Z:

to get it to work.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users