Jump to content











Photo
- - - - -

How to add 'copy image file to memory' (-t vm) in Registry

imdisk registry

Best Answer Olof Lagerkvist , 08 January 2013 - 01:02 PM

The correct name of the flags value should be "Flags0", not "Flag0". You can also omit the "Size0" value.

Go to the full post


  • Please log in to reply
2 replies to this topic

#1 Martin71

Martin71
  • Members
  • 2 posts
  •  
    Netherlands

Posted 08 January 2013 - 08:14 AM

I've just managed to load a ramdisk from file using the registry, but I do not want changes to be written back to the file.

 

Using the 'copy image file to memory' seems to be what I need, but how can I enable this -t vm switch in the registry?

 

This is what I currently have

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ImDisk\Parameters]
"LoadDevices"=dword:00000001
"FileName0"="\\Device\\HarddiskVolume1\\RamDisk\\tempdrive.img"
"DriveLetter0"="X"
"Size0"=hex(b):00,00,00,00,00,00,00,00
"Flag0"=dword:00000200


Edit: According to http://www.ltr-data....127855d7e11.htm Flag0 with value of value 512 (200 hex) should work, but ImDisk still writes data back to the image file. Any ideas what I'm doing wrong?


Edited by Martin71, 08 January 2013 - 08:27 AM.


#2 Olof Lagerkvist

Olof Lagerkvist

    Gold Member

  • Developer
  • 1409 posts
  • Location:Borås, Sweden
  •  
    Sweden

Posted 08 January 2013 - 01:02 PM   Best Answer

The correct name of the flags value should be "Flags0", not "Flag0". You can also omit the "Size0" value.



#3 Martin71

Martin71
  • Members
  • 2 posts
  •  
    Netherlands

Posted 08 January 2013 - 03:17 PM

I got the registry example from another post. After using Flags0 instead of Flag0 it works perfect, thank you

 

:clap:







Also tagged with one or more of these keywords: imdisk, registry

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users