Jump to content











Photo

UEFI Windows 8 + BIOS Grub4dos = MultiBoot USB-Harddisk

uefi win8 linux bios grub4dos vhd win7 xp multiboot usb

  • Please log in to reply
128 replies to this topic

#76 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 April 2013 - 07:03 PM

Isn't the error message clear enough?

 

file :  \grldr.mbr

Info : Because the needed file missing or error , so can't load the program or system



#77 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 04 April 2013 - 07:50 PM

You should use UEFI_MULTI or BOOT_IMG program to add Grub4dos entry to Boot Manager menu (file grldr.mbr is added to Boot Drive).
Also select your ISO as Boot Image File so that ISO file is copied to Boot Drive and Grub4dos entry for booting ISO is made in menu.lst
 
Use the programs, they are designed to do the work for you .....
 
What OS version are you using ? 

 

In Win 7/8 OS Set User Account Control Off and Reboot

 

 
:cheers:


#78 cdob

cdob

    Gold Member

  • Expert
  • 1344 posts

Posted 04 April 2013 - 08:26 PM

add Grub4dos entry in Boot\BCD
Windows 8 bootmgr process boot.ini still. There is no need to edit file Boot\BCD.

Add a file \boot.ini to USB.
[operating systems]
c:\grldr="Boot grub4dos"
Copy a current grub4dos \grldr to USB.

#79 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13752 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 05 April 2013 - 11:09 AM

Windows 8 bootmgr process boot.ini still. There is no need to edit file Boot\BCD.

Add a file \boot.ini to USB.
[operating systems]
c:\grldr="Boot grub4dos"
Copy a current grub4dos \grldr to USB.



Good :).
Can you confirm that BOOT.INI is parsed anyway?
I mean, from here:
http://www.msfn.org/...er/page__st__20
it seemed like there was the *need* of "an entry in BCD for booting a previous NT system".
Was that inaccurate and you can just add a file BOOT.INI to the root of a partition (same where the booted BOOTMGR is) and it will be read anyway?

:cheers:
Wonko

#80 cdob

cdob

    Gold Member

  • Expert
  • 1344 posts

Posted 05 April 2013 - 01:19 PM

Can you confirm that BOOT.INI is parsed anyway?
Yes, a boot sector like entry is listed. Grub4dos does work that way.

it seemed like there was the *need* of "an entry in BCD for booting a previous NT system".
Yes, that's true still. Bootmgr dosn't list a previous NT system from boot.ini.

#81 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13752 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 05 April 2013 - 03:11 PM

Maybe I see.
BOOT.INI is parsed anyway by BOOTMGR but "selectively", i.e. entries for "legacy^2" ;) Operating Systems such as:

 

C:\grldr="grub4dos"

are read, whilst anything with an arcpath like:

 

 

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

are ignored (unless there is an entry in the BCD for them, in which case the entry in the BCD "prevails").

 

IF this is correct, a XP Recovery Console entry in BOOT.INI such as:

 

 

C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons

should also work allright.

 

Did I get it right? :unsure:

 

:cheers:

Wonko



#82 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 05 April 2013 - 04:45 PM

Dear sir ,

 

I successfully made UEFI Windows 8 + BIOS Grub4dos which is MultiBoot USB-Harddisk.

 

I made it this way :

 

1. Make Fat32 first primary partition active ............ with EFI

2. Make NTFS second primary partition ................. UEFI Windows 8

 

As for Grub4dos , I put all files in Fat32 partition (EFI) :

    multi-boot.iso (which have the Partition Tools , Backup & Recovery , WinPE ...) , i,e,

         ISO\iso.iso

         grldr

         grldr,mbr

         menu.lst                    find --set-root --ignore-floppies /iso/iso.iso
                                          map /iso/iso.iso (hd32)
                                          map --hook
                                          chainloader (hd32)
                                          boot

   ---------------------------------------------------------------------------------------------------------------------------

When I boot up USB harddisk with MBR mode , Win8 boot up , a moment later , a boot menu with :

 

     Windows 8

     GRUB4DOS

 

I choose GRUB4DOS , the computer restart at once wihtout going into my iso.iso multi-boot menu. Then I choose again the USB harddisk with MBR mode in the second boot , this time , my iso.iso multi-boot menu pop up.

 

All my program in this iso.iso can work normally. It's fine

 

But what I'm thinking is , is it too trouble to boot into the MBR iso.iso when it's embedded to Win8 ? The first boot-time taks about 20 seconds , then reboot , and you have to watch and choose second time MBR boot , then you have what you want.

 

What I thought before is , what UEFI Win8 & GRUB4DOS together means is , when you boot the this USB harddisk , you can choose to boot Win8 or GRUB4DOS right the way. But now it's not



#83 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 05 April 2013 - 08:09 PM

you can choose to boot Win8 or GRUB4DOS right the way. But now it's not

 

UEFI_MULTI.exe program will organise things differently, so that you don't have that problem and can select direct Grub4os Or Windows 8

 

Follow the Tutorial and use UEFI_MULTI.exe http://www.911cd.net...showtopic=25269

 

Screenshot shows that I have access to Win8 Advanced Boot Options  :whistling:



#84 alacran

alacran

    Frequent Member

  • Advanced user
  • 490 posts
  •  
    Mexico

Posted 05 April 2013 - 11:43 PM

Windows 8 bootmgr process boot.ini still. There is no need to edit file Boot\BCD.

Add a file \boot.ini to USB.

[operating systems]
c:\grldr="Boot grub4dos"
Copy a current grub4dos \grldr to USB.

Well let my tell you my problem with that:

 

On my HDD I had that entry in my XP boot.ini, then after Win7 install it was listed in bootmanager options (end of list), but if it was selectected from there NO GO and I get the screen “with something is wrong in bootmanager and you need to fix it please insert your install disk and reboot system”, so it was necessary to select first XP entry and from next screen (boot.ini itself) select Grub4dos, of curse it was very easy to fix this adding grld.mbr and an entry in bootmanager to it as all you know, removing the entry in Boot.ini to avoid confusion.

 

Or is it possible that when it is only a single entry in boot.ini, it works the way you say?

 

Please don’t misunderstand me I’m not saying your info it’s not accurate, what I am looking is for an answer.

 

Edit: I haven't read wonko posts and answers to him when I wrote this, so please excuse my silly question.

 

Best Regards


Edited by alacran, 06 April 2013 - 12:19 AM.


#85 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 11:32 AM

Thanks for gold member ,

 

I've tried UEFI_MULTI.exe , it's good and can do what I want.

 

But there are 2 problems

 

1. When it boot my 1.8GB iso file , it use "map --mem /iso.iso (0xff)" method , i.e.

    

     find --set-root --ignore-floppies /iso.iso
     map /iso.iso (0xff) || map --mem /iso.iso (0xff)
     map --hook
     root (0xff)
     chainloader (0xff)

 

   Everytime I boot this iso file , I've to wait too much time to let it load iso to memory , very inconvenient. How can I change this menu.lst to load the iso file directly ?

 

2. Under the UEFI condition , it boot my UEFI win8x64 with pmagic ..... The pmagic boots and works fine. But when the next time I boot the UEFI win8x64 , the screen flash and return to the bootmenu at once , means I can't load my win8.

 

Before UEFI_MULTI.exe , my UEFI win8x64 boot properly.

 

Please help. Thanks



#86 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13752 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 12:08 PM

   Everytime I boot this iso file , I've to wait too much time to let it load iso to memory , very inconvenient. How can I change this menu.lst to load the iso file directly ?

This line:
     map /iso.iso (0xff) || map --mem /iso.iso (0xff)
  
is saying in plainer English:
try to map .iso directly, if it fails, then map it in memory.

Simply change that line to:
 
map /iso.iso (0xff)
When you attempt to boot, you will likely have an error 60 (which is most probably the reason why the direct mapping is skipped and the memory one is used) which means that the .iso is fragmented and should be de-fragmented. 
Direct map NEEDS a contiguous file, memory map does not.
 
:cheers:
Wonko

#87 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 01:38 PM

You're right sir ,

 

I've already tried :

    map /iso.iso (0xff)      or    map /iso.iso

 

Also I've tried :

    map /iso.iso (hd32)
    map --hook
    chainloader (hd32)
    boot

 

When I changed to "map /iso.iso (0xff)" and boot , an error message come out :

 

Booting iso.iso

  (hd0,0)
map /iso.iso (0xff)

Error 60: File for drive emulation must be in one contiguous like area

Press any key to continue ...

 

So , please sir , how can I not to use map mem and with contiguous ? Thanks



#88 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13752 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 01:58 PM

Look :unsure:, I have just written how it would have been likely (and you just confirmed that) that you would have an error 60 because the file is not contiguous.

Again, to make direct map you need a contiguous file.

Your .iso is now NOT contiguous you MUST make it contiguous.

WHAT is the problem? :w00t:

Run Contig or Wincontig as mentioned EVERYWHERE on this board in connection with grub4dos error 60.

 

Or are you having this issue here? (Contig/Wincontig not capable of making the file contiguous because there is not enough contiguous space in the filesystem) :dubbio:

http://reboot.pro/to...disk-emulation/

(solved :smiling9:)

 

:cheers:

Wonko



#89 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 06 April 2013 - 02:00 PM

2. Under the UEFI condition , it boot my UEFI win8x64 with pmagic ..... The pmagic boots and works fine. But when the next time I boot the UEFI win8x64 , the screen flash and return to the bootmenu at once , means I can't load my win8.

 

Before UEFI_MULTI.exe , my UEFI win8x64 boot properly.

 

Was the Checkbox Add Boot Win 7/8 System Selected ? It is needed to make Win8 bootable again.

Also your ISO is fragmented as Wonko already explained to you :)

What is the size of your USB Boot Drive ? If small then fragmentation of ISO eeasily can occur.

 

You can solve both problems at once by renew of your USB FAT32 Boot Drive:

 

0. Connect Portable USB-harddisk and start computer from normal harddisk with Windows 7/8 (x64 version)

1. Format your USB Boot Drive with FAT32
2. Run UEFI_MULTI.exe
3. Select FAT32 Boot Drive of USB-harddisk
4. Select NTFS System Drive of USB-harddisk - Select Checkbox Add Boot Win7/8 System to Make Win8 Boot files
5. Select Source Folder UEFI_MULTI\MULTI_BOOT for Copy to Boot Drive (will add soources\boot.wim and pmagic folder)
6. Select Your ISO or VHD Boot Image File - VHD is Copied always to NTFS System Drive - ISO is copied to Boot Drive
7. Optionally Add EFI Boot Manager for UEFI booting of Linux Parted Magic - Requires to Disable UEFI Secure Boot
8. Click GO to make Multi-Boot USB-Harddisk

 

If ISO still fragmented then the USB Boot Drive is probably too small.

You can try to use WinContig to defragment your ISO.

 

:cheers:



#90 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13752 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 06 April 2013 - 02:20 PM

If ISO still fragmented then the USB Boot Drive is probably too small.

 

The linked to thread provides a (working) procedure/workaround to "format" a NTFS "small" stick in such a way that it can contain an unfragmented "big" image. :whistling:

http://reboot.pro/to...disk-emulation/

 

:cheers:

Wonko



#91 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 06 April 2013 - 02:42 PM

The linked to thread provides a (working) procedure/workaround to "format" a NTFS "small" stick in such a way that it can contain an unfragmented "big" image. :whistling:

http://reboot.pro/to...disk-emulation/

 

That is nice, but the ISO is copied to the FAT32 Boot Drive

 

As alternative one can manually copy the big ISO to the NTFS System Drive (may be of sufficient size)

and remove the ISO from FAT32 Boot Drive (menu.lst will be OK to find the ISO on NTFS System drive).

 

:cheers:



#92 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 02:46 PM

Thanks for all your tutorial

 

I've tried to defrag my iso which is 674MB in size. I use the program written by Easyboot forum good teacher "balder" , after defrag my iso file , I boot it again , it boot fine with no "map /--mem". It boots directly.

 

Really thanks to you all. My iso file now is 674MB , it's only for test. My actual iso file size is 4.8GB, I know a 4.8GB iso file can't be put in Fat32 partition. "balder" is teaching how to split this big iso file into 3 pieces. Still what I'm worring is will this big iso file can be defraged !

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Dear Gold member ,

"Select Checkbox Add Boot Win7/8 System to Make Win8 Boot files"

 

Yes i did check "Add Boot Win7/8 System........."

 

Also , for the UEFI boot portion , I don't want any other pmagic , linux ........ I only want UEFI boot Win8x64

 

All I want is , my big iso file and UEFI boot Win8x64 in a same USB harddisk , which is UEFI and MBR bootable.

 

Thanks to you all



#93 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 06 April 2013 - 02:56 PM

Also , for the UEFI boot portion , I don't want any other pmagic , linux ........ I only want UEFI boot Win8x64

 

All I want is , my big iso file and UEFI boot Win8x64 in a same USB harddisk , which is UEFI and MBR BIOS bootable.

 

Well then you should have Unchecked - Add EFI Boot Manager (you don't need that for Win8)

and you don't add pmagic folder to MULTI_BOOT ....

 

Everything can be customised .....

 

:cheers:



#94 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 03:15 PM

Thanks for your advice , I've check "Add EFI Boot Manager".

 

I'll try your advice to uncheck it. And redo everything again. Thanks



#95 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 04:09 PM

I've uncheck "Add EFI Boot Manager" , but this time , the bootmenu don't have UEFI Win8x64 to choose ? It only has the pmagic choice

 

As for MBR boot , everytime I do the UEFI_MULTI , a "Start GRUB4DOS" added , now my MBR startmenu is like this :

 

     Windows 8

     Start GRUB4DOS

     Start GRUB4DOS

     Start GRUB4DOS

 

I don't know :

 

1. Where is the above bootmenu exist and to edit . In Windows , it's in msconfig

2. Which file contains the UEFI startmenu pmagic

 

Thanks for help



#96 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 06 April 2013 - 04:35 PM

I've uncheck "Add EFI Boot Manager" , but this time , the bootmenu don't have UEFI Win8x64 to choose ? It only has the pmagic choice

 

As for MBR boot , everytime I do the UEFI_MULTI , a "Start GRUB4DOS" added , now my MBR startmenu is like this :

 

Uncheck "Add EFI Boot Manager" does NOT remove the EFI Boot Manager.

To remove EFI Boot Manager then you should remove the EFI folder and then use UEFI_MULTI.exe again.

 

To avoid multiple Grub4dos entries, you should NOT Select the Checkbox "Add G4d to Boot Manager"

Just keep it unchecked as it was presented to you.

 

Better approach is to Format FAT32 drive and then Run UEFI_MULTI.exe once according to your wishes .....

 

:cheers:



#97 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 04:42 PM

Thanks Gold Member ,

 

I've find the way to delete some files in the Fat32 EFI folder , it's mainly return EFI to it's original look. Now when I want to boot UEFI Win8x64 , it boots this Win8x64 right the way without making any choice.

 

This is what I want.

 

Still I want to know how to edit the MBR startup menu :

 

     Windows 8

     Start GRUB4DOS

     Start GRUB4DOS

     Start GRUB4DOS

 

And where this file is located , so I can cut away the surplus 2 "Start GRUB4DOS". I think there's no reason to always format the Fat32 EFI partition.

 

Please help. Thanks



#98 wimb

wimb

    Gold Member

  • Developer
  • 2281 posts
  •  
    Netherlands

Posted 06 April 2013 - 04:57 PM

Still I want to know how to edit the MBR startup menu :

 

You can use bcdedit.exe to edit the Boot\BCD file - (this file gives you Boot Manager Menu in BIOS mode)

 

In admin command window you can edit Boot\BCD on Drive D: after showing entries with /enum option

 

bcdedit.exe /store D:\Boot\BCD /enum

 

mark and copy the {guid} of Grub4dos entry
 
bcdedit /store D:\Boot\BCD /delete {guid} /f

 

EasyBCD can also be used to remove entries

 

:cheers:



#99 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 06 April 2013 - 05:30 PM

hello Gold Member ,

 

Many great thanks to you , this time I;ve made what I want. I know bcdedit , but I didn't know use bcdedit to edit bcd file. It's your tutor to me.

 

Now in MBR boot :

 

     Windows 8

     Start GRUB4DOS

 

In UEFI Win8x64 boot , it can boot up to Win8x64 directly.

-------------------------------------------------------------------------------------------------------------------------------------------------

I've two more test :

 

1. My 4.7GB iso file , which actually contains Win7PE and Win8PE in it , should I move it to the Win8-To-Go NTFS partition to reduce my iso to less than 2GB to fit the EFI Fat32 , or

 

2. I want to try to split down my 4.7GB iso file to 3 iso file , making it less than 2GB each.

 

I need time to try them. May be I'll need your help later. Thanks here again for kind heart Gold Member.



#100 allgames71

allgames71

    Member

  • Members
  • 44 posts
  •  
    Hong Kong

Posted 07 April 2013 - 07:23 PM

Sorry sir ,

 

-----------------------------

Total Fail

-----------------------------

I redo the UEFI Multi-boot again with another USB harddisk , but this time I'm totally fail :

1> After making with UEFI_MULTI_74 , I boot my USB harddisk in MBR mode , when I choose to boot from my iso.iso , an error message comes out :

 

GRUB4DOS 0.4.5.B 2011-06-16, Mem: 630K/511M/510M, End:3561F9
[ Minimal BASJ-like line editing is supported. For the first word, TAB
   lists possible command completions. Anywhere else TAB lists the possible
   completions of a devicd/filename. ]

grub>

 

2> In UEFI_MULTI_74 , I uncheck "Add EFI Boot Manager". Last time I delete some files in the EFI partition , then nothing can be boot except EURI Win8x64 , it boots directly.

But this time I don't even have the choice of boot Win8x64

 

Sir, I don't know what I was wrong. Surely I was right yesterday !!

 

Please help. Thanks







Also tagged with one or more of these keywords: uefi, win8, linux, bios, grub4dos, vhd, win7, xp, multiboot, usb

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users