Jump to content











Photo
- - - - -

Debian Live

debian live

  • Please log in to reply
17 replies to this topic

#1 sweetsuicide

sweetsuicide
  • Members
  • 7 posts
  •  
    Italy

Posted 29 October 2012 - 11:23 PM

I tried very hard to start a debianlive ( http://live.debian.net/ ) from iso, but it didn't work out well. I simply copied the files inside the /live directory to a subdir (DEB) and everything started to work (I am actually writing from that live distro on QEMU-kvm).

title DebianLive
find --set-root /DEB/live/vmlinuz2
kernel /DEB/live/vmlinuz2 boot=live persistent live-media-path=/DEB/live/vmlinuz2 config
initrd /DEB/live/initrd2.img

#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6541 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 30 October 2012 - 08:19 AM

Which ISO did you use exactly?

#3 sweetsuicide

sweetsuicide
  • Members
  • 7 posts
  •  
    Italy

Posted 30 October 2012 - 12:37 PM

I am very sorry not to have provided enough information and to have double posted my solution.

Back to the issue. I didn't make it with the ISO, I extracted the files. Anyway I used the following starting file: debian-live-6.0.5-i386-kde-desktop.iso (like the one in http://live.debian.n...kde-desktop.iso ).

I Mounted the ISO, created a /DEB folder and copied the /live folder from the ISO.

Another thing worth mentioning is that Debian Live 32bit DVDs come with two different sets of kernels:

* vmlinuz (and corresponding initrd) are 486 kernels
* vmlinuz2 (and corresponding initrd2) are 686 kernels

So I think I could also write:

title DebianLive486
find --set-root /DEB/live/vmlinuz
kernel /DEB/live/vmlinuz boot=live persistent live-media-path=/DEB/live/vmlinuz config
initrd /DEB/live/initrd.img

title DebianLive686
find --set-root /DEB/live/vmlinuz2
kernel /DEB/live/vmlinuz2 boot=live persistent live-media-path=/DEB/live/vmlinuz2 config
initrd /DEB/live/initrd2.img

#4 voyager2

voyager2
  • Members
  • 4 posts
  •  
    Bulgaria

Posted 30 October 2012 - 03:41 PM

all livecd distros work if you extract cd completely to root folder but this turns drive into a garbage so im loking for a way to boot from image . which will make harddisks cleaner :D

#5 steve6375

steve6375

    Platinum Member

  • Developer
  • 6541 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 30 October 2012 - 03:56 PM

But sweetsuicide has not extracted to the root, he has extracted to a DEB folder.

#6 ilko

ilko

    Silver Member

  • Advanced user
  • 500 posts
  •  
    Bulgaria

Posted 30 October 2012 - 04:30 PM

Have you tried using the "fromiso" kernel parameter with path to the ISO file?
Something like, given debian-live-6.0.5-i386-kde-desktop.iso is in "debian" folder, not tested:


title Debian live 6.0.5-i386-kde-desktop

find --set-root --devices=hf /debian/debian-live-6.0.5-i386-kde-desktop.iso

map /debian/debian-live-6.0.5-i386-kde-desktop.iso (0xff) || map --mem /debian/debian-live-6.0.5-i386-kde-desktop.iso (0xff)

map --hook

root (0xff)

kernel /live/vmlinuz boot=live config fromiso=/debian/debian-live-6.0.5-i386-kde-desktop.iso quiet

initrd /live/initrd.img

To stay on the safe side, watch out for capital letters in folder/ISO file names, Debian and debian might not be the same.

If you need the other kernel parameters for failsafe, rescue, install etc. get them from isolinuxlive.cfg.

For example, rescue:

title Debian live 6.0.5-i386-kde-desktop Rescue

find --set-root --devices=hf /debian/debian-live-6.0.5-i386-kde-desktop.iso

map /debian/debian-live-6.0.5-i386-kde-desktop.iso (0xff) || map --mem /debian/debian-live-6.0.5-i386-kde-desktop.iso (0xff)

map --hook

root (0xff)

kernel /live/vmlinuz fromiso=/debian/debian-live-6.0.5-i386-kde-desktop.iso rescue/enable=true vga=normal quiet

initrd /live/initrd.img



#7 steve6375

steve6375

    Platinum Member

  • Developer
  • 6541 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 30 October 2012 - 04:34 PM

The 'fromiso' and 'isofrom' are both recognised, but debian says it cannot find the iso even though it gets the correct name from the preseed.
I think there is a bug in the scripts.
http://lists.debian....7/msg00146.html

#8 ilko

ilko

    Silver Member

  • Advanced user
  • 500 posts
  •  
    Bulgaria

Posted 30 October 2012 - 04:43 PM

Good find, thanks.

Have you tried to include device name in the path to the ISO file, i.e. fromiso=/dev/sda1/debian/iso_file_name.iso ?
Or placing the ISO file in root and check if startup scripts seek for ISO file as in Debian's HD install images?

Added:
Part of the init script :

# support for fromiso=.../isofrom=....

    if [ -n "$FROMISO" ]

    then

        ISO_DEVICE=$(dirname $FROMISO)

        if ! [ -b $ISO_DEVICE ]

        then

            # to support unusual device names like /dev/cciss/c0d0p1

            # as well we have to identify the block device name, let's

            # do that for up to 15 levels

            i=15

            while [ -n "$ISO_DEVICE" ] && [ "$i" -gt 0 ]

            do

                ISO_DEVICE=$(dirname ${ISO_DEVICE})

                [ -b "$ISO_DEVICE" ] && break

                i=$(($i -1))

       		 done

        fi



        if [ "$ISO_DEVICE" = "/" ]

        then

            echo "Warning: device for bootoption isofrom= ($FROMISO) not found.">>/live.log

        else

            mkdir /isofrom

            mount -t auto "$ISO_DEVICE" /isofrom

            ISO_NAME="$(echo $FROMISO | sed "s|$ISO_DEVICE||")"

            loopdevname=$(setup_loop "/isofrom/${ISO_NAME}" "loop" "/sys/block/loop*" "" '')

            devname="${loopdevname}"

        fi

    fi


#9 steve6375

steve6375

    Platinum Member

  • Developer
  • 6541 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 30 October 2012 - 04:50 PM

I tried /dev/sdb1/xxx.iso (as booting from a USB drive) and still did not work.
ISO is in root.

Added: I am using the Rescue ISO (as it is much smaller).

#10 steve6375

steve6375

    Platinum Member

  • Developer
  • 6541 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 30 October 2012 - 05:14 PM

@sweetsuicide: Hmm - OK I downloaded the http://live.debian.n...kde-desktop.iso file, and copied the live folder to my USB FAT32 grub4dos bootable flash drive and used the menu supplied - it has the same problem as the Rescue iso which is was testing with previously - it does not seem to work???
Is the menu.lst correct? Did you use a FAT32 USB Flash drive? Did you try a real system or use some VM of some sort? Are there any other files on your test drive?

#11 sweetsuicide

sweetsuicide
  • Members
  • 7 posts
  •  
    Italy

Posted 30 October 2012 - 10:48 PM

@sweetsuicide: Hmm - OK I downloaded the http://live.debian.n...kde-desktop.iso file, and copied the live folder to my USB FAT32 grub4dos bootable flash drive and used the menu supplied - it has the same problem as the Rescue iso which is was testing with previously - it does not seem to work???
Is the menu.lst correct? Did you use a FAT32 USB Flash drive? Did you try a real system or use some VM of some sort? Are there any other files on your test drive?

I actually tried the solution I gave first on an ext3 formatted usb drive. It was tested on QUEMU. Today I tried to boot the ext3 usb drive on my physical pc and it worked. Same with my FAT32 formatted usb drive.The problems you encounter in booting debian live from iso is that it needs the is that it needs the sssquashfs filesystem for the "live-media-path" parameter. What is suspect is that once in "iso unpacking mode"the relative path is not available to debian scripts for some reason. If someone found a way to boot from iso it would be a very welcome input.Regardin boot options. My boot options are the results of trial and error testing, but I have to recognize that some of the parameters are wrong. The persistent parameter is usually supplied (it is even required in the isolinux config file on the iso itself) with the parameter union=aufs. I will try again and tell you what I discovered new, but for the moment my parameters seems to work some way. Regarding the rescue mode I fear there must be some specific issue to it. As soon as I have time I will make my experiments on that too.

#12 sweetsuicide

sweetsuicide
  • Members
  • 7 posts
  •  
    Italy

Posted 31 October 2012 - 12:16 PM

There seem not to be an end to the things that can go wrong with my topic... By the way, shouldn't my posts be editable?

Anyway, I wanted to point out that in my codes there is a huge mistake:

title DebianLive
find --set-root /DEB/live/vmlinuz2
kernel /DEB/live/vmlinuz2 boot=live persistent live-media-path=/DEB/live/vmlinuz2 config
initrd /DEB/live/initrd2.img


and

title DebianLive486 find --set-root /DEB/live/vmlinuz
kernel /DEB/live/vmlinuz boot=live persistent live-media-path=/DEB/live/vmlinuz config
initrd /DEB/live/initrd.img

title DebianLive686
find --set-root /DEB/live/vmlinuz2
kernel /DEB/live/vmlinuz2 boot=live persistent live-media-path=/DEB/live/vmlinuz2 config
initrd /DEB/live/initrd2.img


The most important setting : live-media-path should point to a path. Therefore:

WRONG:

kernel /DEB/live/vmlinuz boot=live persistent live-media-path=/DEB/live/vmlinuz config



should actually be:


kernel /DEB/live/vmlinuz boot=live persistent live-media-path=/DEB/live/ config



and

WRONG:

kernel /DEB/live/vmlinuz2 boot=live persistent live-media-path=/DEB/live/vmlinuz2 config



should actually be:

kernel /DEB/live/vmlinuz2 boot=live persistent live-media-path=/DEB/live/ config


Edited by sweetsuicide, 31 October 2012 - 12:18 PM.


#13 steve6375

steve6375

    Platinum Member

  • Developer
  • 6541 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 31 October 2012 - 12:27 PM

That's better! :cheerleader: Works now! I should have spotted it!

#14 pollo

pollo
  • Members
  • 6 posts
  •  
    Belgium

Posted 31 July 2016 - 06:29 PM

Hi all

I'm trying to boot the debiandog get from this link https://debiandog.gi...ndogjessie.htmland trying with the iso file and with the extracted one's but neither the first nor the second methodes work and get those messages under vmware, some codes used here are from this forum, if any one can help to find a solution to this, thanx

::::: methode with ISO file, I copied the iso file into the root of my flash disk ::::

title Debian
find --set-root debian.iso
map debian.iso (0xff) || map --mem debian.iso (0xff)
map --hook
root (0xff)
kernel /live/vmlinuz1 boot=live config persistence swapon quickreboot noeject showmounts
initrd /live/initrd.img

 

http://imgbox.com/iVXlh6dj

::::: methode with extracted iso file, the files are all inside the directory /debian/ ::::

title Debian
find --set-root /debian/live/initrd.img
kernel /debian/live/vmlinuz1 boot=live config persistence swapon quickreboot noeject showmounts
initrd /debian/live/initrd.img

http://imgbox.com/nzXXBzrW

 

well the methodes start working and extracting but stop in the end because some files are missing I dont why......


Edited by pollo, 31 July 2016 - 06:33 PM.


#15 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13443 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 August 2016 - 08:01 AM

I wouldn't be surprised, since those were already reported as not working.
Have you tried adding the:

live-media-path=/DEB/live/

cheatcode?

(or similar ones)

The directory should be "/live/" by default, but maybe on that specific distro it needs to be explicitly passed to the booting system:
http://clonezilla.or...s/live-boot.php

 

It is entirely possible that the good Linux guys completely changed the self-mounting approach, it wouldn't be the first time that this happens, but try the above first, also here:
http://murga-linux.c...pic.php?t=93496

 

:duff:

Wonko



#16 pollo

pollo
  • Members
  • 6 posts
  •  
    Belgium

Posted 01 August 2016 - 07:20 PM

tested but not working, will search another way, thank you for your help wanko.



#17 ner0

ner0

    Member

  • Members
  • 48 posts

Posted 15 November 2016 - 11:54 AM

This should work:

 

::::: methode with ISO file, I copied the iso file into the root of my flash disk ::::

 

title Debian
set ISO=/debian.iso
find --set-root %ISO%
uuid () && call set UUID=%^?%
map %ISO% (0xff) || map --mem %ISO% (0xff)
map --hook
root (0xff)
kernel /live/vmlinuz boot=live config persistence swapon quickreboot noeject showmounts live-media-path=live fromiso=/dev/disk/by-uuid/%UUID%%ISO% ip=frommedia union=overlay #toram=filesystem.squashfs #uncomment 'toram' if you want to load system to RAM
initrd /live/initrd.img
 
::::: methode with extracted iso file, the files are all inside the directory /debian/ ::::

 

title Debian
find --set-root /debian/live/vmlinuz
uuid () && call set UUID=%^?%
kernel /debian/live/vmlinuz boot=live config persistence swapon quickreboot noeject showmounts live-media-path=debian/live bootfrom=/dev/disk/by-uuid/%UUID% ip=frommedia union=overlay #toram=filesystem.squashfs #uncomment 'toram' if you want to load system to RAM
initrd /debian/live/initrd.img

Edited by ner0, 15 November 2016 - 11:59 AM.


#18 nguyentu

nguyentu

    Member

  • Members
  • 65 posts
  •  
    Vietnam

Posted 15 November 2016 - 08:15 PM

Try this:

kernel /DEB/live/vmlinuz2 boot=live components quiet splash live-media-path=/DEB/live
initrd /DEB/live/initrd2.img

I think Debian uses the file name vmlinuz and initrd, please look at /DEB/live dir

kernel /DEB/live/vmlinuz boot=live components quiet splash live-media-path=/DEB/live
initrd /DEB/live/initrd.img

Boot Debian from ISO:

title Debian Live
set ISO=/debian.iso
find --set-root --ignore-floppies %ISO%
map %ISO% (0xff) || map --mem %ISO% (0xff)
map --hook
kernel (0xff)/live/vmlinuz boot=live components quiet splash findiso=%ISO%
initrd (0xff)/live/initrd.img

Edited by nguyentu, 15 November 2016 - 08:23 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users