Jump to content











Photo
- - - - -

LOCALBOOT 0 ambiguous message "Booting from local disk..."


  • Please log in to reply
8 replies to this topic

#1 ghandi666

ghandi666
  • Members
  • 6 posts
  •  
    Germany

Posted 18 October 2012 - 04:17 PM

Hello,

after the 'LOCALBOOT 0' command for me there is the message

"Booting from local disk..."

A least for me this is not entirely correct as the local boot order defined by BIOS is carried out, not necessaryly a local disk is booted.

It works like charm tho, so I just want to mention that.


Thanks for the great Software
  • MichaelPr likes this

#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 18 October 2012 - 08:34 PM

So are you booting from a remote disk (pxe boot?)
  • MichaelPr likes this

#3 ghandi666

ghandi666
  • Members
  • 6 posts
  •  
    Germany

Posted 18 October 2012 - 08:58 PM

yes.
  • MichaelPr likes this

#4 ghandi666

ghandi666
  • Members
  • 6 posts
  •  
    Germany

Posted 18 October 2012 - 09:25 PM

I just double checked and I think I am wrong: my description is true for what "is displayed" with following

/../tftproot/pxelinux.cfg/default:
DEFAULT local

UI menu.c32

prompt 0

timeout 100

ONTIMEOUT local



MENU TITLE PXE Menu



LABEL local

LOCALBOOT 0

MENU LABEL Continue local boot order

when timeout runs out, or by hitting enter on the 'local' label.

But, (I stated wrong above) it is not true if I enter the command manually in the boot console:


boot: LOCALBOOT 0

Could not find kernel image: LOCALBOOT


so my configuration has errors.
At least it does what I want. I'll go on reading :book:
  • MichaelPr likes this

#5 ghandi666

ghandi666
  • Members
  • 6 posts
  •  
    Germany

Posted 18 October 2012 - 10:18 PM

I found a configuration for localboot there: http://www.syslinux...._with_sub-menus

DEFAULT menu.c32

prompt 0

timeout 100

ONTIMEOUT bootlocal

MENU TITLE PXE Menu



label bootlocal

	  menu label Continue local boot order

	  menu default

	  localboot 0

	  timeout 80

	  TOTALTIMEOUT 9000


I don't get the error anymore.

It continues with BIOS defined order.
Thats what I want, so still for me the message is ambiguous.

Do I have this right?

#6 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1682 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 18 October 2012 - 10:30 PM

I found a configuration for localboot there: http://www.syslinux...._with_sub-menus


DEFAULT menu.c32

prompt 0

timeout 100

ONTIMEOUT bootlocal

MENU TITLE PXE Menu



label bootlocal

      menu label Continue local boot order

      menu default

      localboot 0

      timeout 80

      TOTALTIMEOUT 9000

TIMEOUT and TOTALTIMEOUT are global options, so I suggest moving them to the top of your config-file, without indentation. I don't know if you want 80 or 100, but you can pick one.

I don't get the error anymore.

It continues with BIOS defined order.
Thats what I want, so still for me the message is ambiguous.

Do I have this right?

LOCALBOOT and the other non-menu-specific directives are documented in doc/syslinux.txt. There is also a mention of LOCALBOOT in doc/pxelinux.txt. It discusses using gPXE (but also applies to iPXE, too) and PXELINUX being used together. Does this match your scenario?

#7 ghandi666

ghandi666
  • Members
  • 6 posts
  •  
    Germany

Posted 19 October 2012 - 08:46 AM

I'm sorry for not removing the indent timeout lines. I got them from the syslinux page linked above. I guess they are not in scope of this thread.

Yes, I'm reading syslinux.txt and others.

My scenario includes pxelinux provided by dnsmasq.

Edited by ghandi666, 19 October 2012 - 08:48 AM.


#8 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1682 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 19 October 2012 - 05:47 PM

I'm sorry for not removing the indent timeout lines. I got them from the syslinux page linked above. I guess they are not in scope of this thread.

Please: No apology. It's just a suggestion so that you can better visualize global versus LABEL-specific directives.

Yes, I'm reading syslinux.txt and others.

My scenario includes pxelinux provided by dnsmasq.

If your scenario does not involve gPXE nor iPXE, then I would expect LOCALBOOT to behave as described in doc/syslinux.txt.

You are right, though: The message is misleading for PXELINUX, where the LOCALBOOT code is actually a message for the PXE stack, and doesn't have anything to do with disks. "LOCALBOOT 0" tells the PXE stack "I am finished with success."

#9 ghandi666

ghandi666
  • Members
  • 6 posts
  •  
    Germany

Posted 22 October 2012 - 02:40 PM

Thank you for clarification.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users