Jump to content











Photo
- - - - -

remove uneccessary messages on loading grldr


  • Please log in to reply
38 replies to this topic

#1 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 01 October 2012 - 07:30 AM

at July 4, 2012, Steve6375 has placed a issue (issue 95) about 'removing uneccessary messages on loading grldr' in the grub4dos-chenall project: http://code.google.c...es/detail?id=95

any chance, that this will be implemented in future grldr versions?

fuwi

#2 tinybit

tinybit

    Silver Member

  • Developer
  • 849 posts
  •  
    China

Posted 01 October 2012 - 08:55 AM

it should already have been implemented in the latest 2012-09-25 or 2012-09-29 build.

It can be found here(in a Chinese page):

http://bbs.znpc.net/...thread&tid=6731

or here(also a Chinese board):

http://bbs.wuyou.com...74&extra=page=1

#3 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 01 October 2012 - 10:48 AM

just tested build grub4dos-0.4.5c-2012-09-29.7z -> the messages are still there
(or is there a new command in menu.lst for supressing this messages?)

fuwi

#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 10,081 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 October 2012 - 10:57 AM

There is the version used here:
http://reboot.pro/16964/
http://reboot.pro/17157/

:cheers:
Wonko

#5 tinybit

tinybit

    Silver Member

  • Developer
  • 849 posts
  •  
    China

Posted 01 October 2012 - 12:30 PM

just tested build grub4dos-0.4.5c-2012-09-29.7z -> the messages are still there
(or is there a new command in menu.lst for supressing this messages?)

fuwi


The boot-record message Try (hd0,0)'s are still there. But other messages should not appear unless you have a problematic config which caused hang-up.

The Try (hd0,0) messages will help the developer to locate possible causes of a failure in the boot process.

Currently you have to compile your own version for a message-less boot process.

#6 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 01 October 2012 - 03:07 PM

I see more then the "Try (hd0,0)" message, e.g. something with "PXE stack commands ......" (can not read the whole text, flashing too fast)

fuwi

#7 tinybit

tinybit

    Silver Member

  • Developer
  • 849 posts
  •  
    China

Posted 04 October 2012 - 04:57 AM

Some messages are important in the developer's view.

If the machine hangs up, the message displayed will tell the developer(or the user) something about the problem.

The message is flashing fast because it boots normally.

If you would mind, you can re-compile it by comment out the messages.

If there would be no messages and the boot failed, then developers will not know what is wrong.

1. A bad or problematic user configuration would hang-up a machine.

2. A bad BIOS might hang-up a machine. This includes the possible case of OEM attacking on open-source software.

3. A developer's mistake also could hang-up a machine.

So the developers choose to display those messages at startup unconditionally.

#8 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 10,081 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 04 October 2012 - 08:19 AM

and (AGAIN) a "silent" compile has been already made....

:cheers:
Wonko

#9 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 October 2012 - 10:27 AM

Some messages are important in the developer's view.

If the machine hangs up, the message displayed will tell the developer(or the user) something about the problem.

The message is flashing fast because it boots normally.

If you would mind, you can re-compile it by comment out the messages.

If there would be no messages and the boot failed, then developers will not know what is wrong.

1. A bad or problematic user configuration would hang-up a machine.

2. A bad BIOS might hang-up a machine. This includes the possible case of OEM attacking on open-source software.

3. A developer's mistake also could hang-up a machine.

So the developers choose to display those messages at startup unconditionally.


Most programmers compile two versions, one is debug version and one is release version. If there are any problems (never seen any issues before menu.lst is loaded myself!) then the debug version can be installed and tested.

The problem is that grub4dos is so damn brilliant :clap: that people want it to look slick and cool. We now can have hi-res backgrounds, function keys, advanced batch scripts, etc. but it is let down by the 'amateur' looking debug text as it boots.

Suggestion: Could we perhaps have a single byte somewhere in the stage 1 boot code which could be patched so that we don't get any of these messages before menu.lst is loaded? Then anyone who does not want these messages could patch the byte (e.g. use a dd command in the menu.lst so that once it has been run once, it permanently patches the byte for every boot thereafter)? That way the default will be to have the messages enabled, but a simple line in the menu.lst file will allow us to turn off the debug preboot messages?

#10 tinybit

tinybit

    Silver Member

  • Developer
  • 849 posts
  •  
    China

Posted 04 October 2012 - 01:58 PM

Would anyone have done a patch for a silent build?

Post the patch here and I will see if it could be accepted.

#11 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 16 January 2013 - 02:04 PM

Patch grub4dos to be silent  on bootup.

 

The following code at the start of a menu.lst will patch your USB boot device  (assumes it is hd0 when booted) so that there are no startup messages.

Once it has been run once, there is no need to keep the code in the menu.lst file. If you prefer you can just run it once whenever you make a new stick or replace the grldr file with a newer version.

 

Menu.lst

 

# Patch hd0 and the grldr file to be silent on bootup
/patchg4d.g4b

 

patchg4d.g4b

!BAT
#patch to get rid of grub4dos startup text!
#first check if already done and exit if it has!
cat --locate="Running menu" --number=1  ()/grldr  > nul || goto :EOF

cat --locate="Try (hd0,0 )" --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="EXT2: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="NTFS5: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="FAT32: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="FAT16: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="FAT12: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="non-MS: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="skip " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="Extended: " --number=1 --replace=\0\0 (hd0)+20 > nul
cat --locate="invalid or null" --number=1 --replace=\0\0 (hd0)+20 > nul

cat --locate="Initialize var" --number=1 --replace=\0\0 ()/grldr > nul
cat --locate="Starting cmain" --number=1 --replace=\0\0 ()/grldr > nul
cat --locate="Running menu" --number=1 --replace=\0\0 ()/grldr > nul

#optional - reboot to make patch effective...
reboot

 

 


#12 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 April 2013 - 09:02 PM

To get rid of annoying grub4dos diagnostic messages on boot up, copy the patchme file to your grub4dos boot drive:
 
1. Boot to grub4dos menu
2. Press c to get to comand console
3. Type /patchme
4. Press a key to reboot
 
This patches some sectors on the grub4dos boot disk and also patches the grldr file.
The patches will persist until you overwrite the grldr file or re-install grub4dos.
 

Attached Files



#13 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 25 June 2013 - 09:42 AM

Hi steve

 

In grub4dos 2013-06-24 the developpers have built-in in a couple new stupid boot up messages  :frusty:

Very very very very very very annoying!!!!!!!!!!  :realmad:

 

- Version message is hard coded ...

 

- Some new "Processing blablabla" messages ...

 

- The "Running menu" message is no longer present, so your .g4b patch will no longer start ...   :thumbdown:

 

fuwi



#14 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 25 June 2013 - 10:06 AM

Hi

I know, I asked for the old message to be removed or at least improved to look better, and they changed it but made it worse!

 

I have a patch that will remove all messages from the boot code and the grldr loader which is a grub4dos batch file..

 

I haven't tested it on the new version yet, but you can try it if you like...

 

Boot to grub4dos command prompt and run the batch file to patch the boot device.

 

 

 

Attached Files



#15 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 25 June 2013 - 10:42 AM

Hi Steve

 

Thanks a lot, your new patch works perfect! :clapping:

 

I have detected one last message: "begin pxe scan..."

 

cat --locate="begin pxe scan" --number=1 --replace=\0\0 ()/grldr > nul
 

-> this makes my grldr completely silent... :D

 

fuwi



#16 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 25 June 2013 - 10:59 AM

Ok, here some additional messages i've made silent since a couple of weeks:

 

cat --locate="!! number of h" --number=1 --replace=\0\0 ()/grldr > nul
cat --locate="!! sectors-per" --number=1 --replace=\0\0 ()/grldr > nul
cat --locate="Will boot" --number=7 --replace=\0\0 ()/grldr > nul
cat --locate="Booting '%s'" --number=1 --replace=\0\0 ()/grldr > nul
 

fuwi



#17 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 25 June 2013 - 11:01 AM

when do you see those messages? Are they from commands or what?



#18 fuwi

fuwi

    Frequent Member

  • Expert
  • 130 posts
  • Location:Switzerland
  •  
    Switzerland

Posted 25 June 2013 - 11:40 AM

Booting '%s' displays a message for every title in menu.lst when it is started, e.g. "Booting Memtest86" if i have a menu item "Memtest86" .

 

"!! number of h" and "!! sectors-per" this messages i had with some USB-Sticks with uncommon (?) number of heads/number of sector per track

but they all boots flawlessly.

 

"Will boot" messages i get for menu items which boots an other OS (e.g. booting WinXP from the local Harddisk -> "Will boot NTLDR ...").

 

This display also a "Will boot NTLDR ..." message:

title Windows 8 PE (32-bit) \n Windows 8 PE (PE4) - the Windows Rescue and Repair Environment
chainloader /bootmgr
 

 

fuwi



#19 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 10,081 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 25 June 2013 - 12:46 PM

Hi steve

 

In grub4dos 2013-06-24 the developpers have built-in in a couple new stupid boot up messages  :frusty:

Very very very very very very annoying!!!!!!!!!!  :realmad:

That is anyway a 0.4.6a version that should NOT be used if not for alpha testing or a 0.4.5c WITHOUT the "Featured" tag, that should also be not used if not for experimenting.

 

 

 

I know, I asked for the old message to be removed or at least improved to look better, and they changed it but made it worse!

The general idea of "asking" is that what is asked can either be fulfilled or it can be rejected, in this case the Author(s) seemingly found your request (they did not obey to your order :w00t:) not "good enough" or more simply did not fancy it.

 

:cheers:

Wonko



#20 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 25 June 2013 - 01:13 PM

Booting '%s' displays a message for every title in menu.lst when it is started, e.g. "Booting Memtest86" if i have a menu item "Memtest86" .

 

"!! number of h" and "!! sectors-per" this messages i had with some USB-Sticks with uncommon (?) number of heads/number of sector per track

but they all boots flawlessly.

 

"Will boot" messages i get for menu items which boots an other OS (e.g. booting WinXP from the local Harddisk -> "Will boot NTLDR ...").

 

This display also a "Will boot NTLDR ..." message:

title Windows 8 PE (32-bit) \n Windows 8 PE (PE4) - the Windows Rescue and Repair Environment
chainloader /bootmgr
 

 

fuwi

 

For 'Will boot' you can use   chainloader (0xff) > nul

 

Same for root (xx)  > nul

 

I quite like the 'Booting..' message, especially as it now prints  variables like %fred% expanded in the message now...

 

I just wish that there was a way to suppress the 'Processing xxx' message at least for submenus



#21 nando4

nando4

    Frequent Member

  • Advanced user
  • 110 posts
  •  
    Australia

Posted 06 August 2013 - 05:05 AM

Is there any way of getting rid of a momentary flash (~0.3s) of the following screen? AFAIK this is built into grub4dos ensuring it finds the menu.lst file to work with.

I'm using grub.exe chainloaded from bootmgr with menu.lst in the spoiler. Adding a Title item in there making no difference. You can see I've put as many supression messages as I can in there. Applying steve6375's patchme.zip (modified to work on grub.exe) making no difference.

Any ideas?
 
:: Load HDD disk image as first HDD (hd0)
:: This file must be in root directory if using 
:: XP/Vista/Win7 bootloader 

# suppress messages
debug off
timeout 0
hiddenmenu --silent
clear

# Set location of image file
set IMG=/eGPU/eGPU-Setup.img

# Set root to be found location of image file
# The image can be found on *any* partition
find --set-root %IMG%

# Map image file as writable first harddisk (hd0)
# Move real harddisks to be (hd1) and (hd2) so can
# be accessed from Setup 1.x' grub4dos 
map (hd1) (hd2)
map (hd0) (hd1)
map %IMG% (hd0)
map --hook
root (hd0)
chainloader (hd0)+1
rootnoverify
t0tb.jpg

#22 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 August 2013 - 07:45 AM

This text is caused because you don't have a /menu.lst file  (or grldr.exe cannot find it in the default volume). The simplest way to fix it is to put a menu.lst file in the root of the boot drive.

You can always redirect grub4dos to a different menu using  configfile /path/xxx.lst.

 

The alternative is to modify the internal default menu file which is embedded inside the grldr file. To do this use BootIce - Utilities - Start Menu Editor - Open - (usb drive: \grdlr) - change 'configfile' to 'configfile /path/menu.lst' and click Save. Or you may prefer just to edit the 'timeout 1'  line to 'timeout 0'.

 

I am not sure how to rewrite a grub.exe, but I guess you could modify my patchme script so that it looks in grldr.exe and replaces 'timeout 1' with 'timeout 0' ???

 

Standard internal grldr menu:

pxe detect
configfile
default 0
timeout 1

title find /menu.lst, /boot/grub/menu.lst, /grub/menu.lst
	errorcheck off
	configfile /boot/grub/menu.lst
	configfile /grub/menu.lst
	if "%@root%"=="(ud)" && calc *0x82A0=*0x82b9&0xff
	if "%@root:~1,1%"=="f" && find --set-root --devices=f /menu.lst && configfile /menu.lst
	find --set-root --ignore-floppies --ignore-cd /menu.lst && configfile /menu.lst
	find --set-root --ignore-floppies --ignore-cd /boot/grub/menu.lst && configfile /boot/grub/menu.lst
	find --set-root --ignore-floppies --ignore-cd /grub/menu.lst && configfile /grub/menu.lst
	errorcheck on
	commandline

title commandline
	commandline

title reboot
	reboot

title halt
	halt

  • nando4 likes this

#23 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 August 2013 - 08:07 AM

P.S. An alternative would be to use wee to load grldr. see here.



#24 nando4

nando4

    Frequent Member

  • Advanced user
  • 110 posts
  •  
    Australia

Posted 06 August 2013 - 10:46 AM

This text is caused because you don't have a /menu.lst file  (or grldr.exe cannot find it in the default volume). The simplest way to fix it is to put a menu.lst file in the root of the boot drive.
You can always redirect grub4dos to a different menu using  configfile /path/xxx.lst.
 
The alternative is to modify the internal default menu file which is embedded inside the grldr file. To do this use BootIce - Utilities - Start Menu Editor - Open - (usb drive: \grdlr) - change 'configfile' to 'configfile /path/menu.lst' and click Save. Or you may prefer just to edit the 'timeout 1'  line to 'timeout 0'.
 
I am not sure how to rewrite a grub.exe, but I guess you could modify my patchme script so that it looks in grldr.exe and replaces 'timeout 1' with 'timeout 0' ???


The quick fix was, as you highlight, to replace the "timeout 1" with "timeout 0" in the internal menu.lst. I did that with a hex editor and indeed that flashing of the default menu.lst is now gone. What's odd is there is definitely a /menu.lst that sits in same dir as the /grub.exe that's being called. I'm not sure how I'd be adding a configile parameter to grub.exe within bcdedit?
 
Real-mode Boot Sector
---------------------
identifier              {799bdf2d-4cba-11e2-afb2-c6a52d55d19a}
device                  partition=C:
path                    \grub.exe
description             DIY eGPU Setup 1.x
In any case "timeout 1" being replaced by "timeout 0" would be another good one to add to patchme.g4b.

Edited by nando4, 06 August 2013 - 10:46 AM.


#25 steve6375

steve6375

    Platinum Member

  • Developer
  • 4,955 posts
  • Location:UK
  • Interests:computers (!), programming (masm,vb6,C,vbs), OSes, photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 August 2013 - 10:53 AM

Windows has a boot partition and a system partition, maybe you need to put the menu.lst in the system ptn or maybe in (hd0,0) ???

You could just try putting a copy in all ptns until you find which one is needed and then report back on what your ptn arrangement is and what worked?

P.S. Next version of E2B (after 1.06 Beta) will have the timeout 0 patch in.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users