Jump to content











Photo
- - - - -

Booting WinPE via HTTP

http winpe ipxe wimboot ramdisk

  • Please log in to reply
66 replies to this topic

#26 mcb30

mcb30

    Newbie

  • Members
  • 22 posts
  •  
    United Kingdom

Posted 26 September 2012 - 02:38 PM

Do I need a special bootmgr for not wasting the ram? Because Iam still missing the ~200mb of the wim file when booting via wimboot.


There should be no special bootmgr needed. Which version of Windows is this, and what test are you using which shows that 200MB of RAM is missing?

Michael

#27 fuxxi

fuxxi

    Newbie

  • Members
  • 27 posts
  •  
    Germany

Posted 26 September 2012 - 03:42 PM

There should be no special bootmgr needed. Which version of Windows is this, and what test are you using which shows that 200MB of RAM is missing?

Michael

Its a PE created by WAIK 2.0 and the test is a commercial software which shows sys info after booting pe.

#28 mcb30

mcb30

    Newbie

  • Members
  • 22 posts
  •  
    United Kingdom

Posted 26 September 2012 - 05:21 PM

Its a PE created by WAIK 2.0 and the test is a commercial software which shows sys info after booting pe.


Are you able to reproduce the test result using freely-available software, so that I can observe the same problem that you are seeing?

Thanks,

Michael

#29 joakim

joakim

    Silver Member

  • Team Reboot
  • 910 posts
  • Location:Bergen
  •  
    Norway

Posted 26 September 2012 - 07:58 PM

@mcb30
Just sent 3 versions to you. It is not only from checked builds that fail, but also previous or other versions. I think it is important to fix, because otherwise I suspect wimboot will fail with future versions of bootmgr.

#30 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 29 September 2012 - 09:49 AM

Using grub4dos, I am trying to boot with the following menu.lst file configuration :

title iPXE3



pxe keep

kernel /IPXE.KRN

initrd /LOAD.IPX

LOAD.IPX : ( saved as UNIX text file )[/code]


#!ipxe



dhcp

chain http://192.168.0.200/winpe/boot.ipxe

grub4dos loads IPXE.KRN but LOAD.IPX is never processed and the computer falls back to the network boot screen.

Booting command-list



Linux - zImage , setup=0x800 ....



iPXE initializing devices - sis 900_probe...

.

.

ok





iPXE 1.0.0+ (8e4faa) Open Source Network Boot Firmware



Intel UNDI, PXE - 2.0 ( build 082 )



CLIENT MAC ADDR ....

The computer reacquires an IP address from DHCP and the grub4dos menu is presented again.

Removing initrd /LOAD.IPX from menu.lst works fine and I can hit CTRL+B to to access the command-line mode.

Removing pxe keep does not change the result.

IPXE.KRN is extracted from ipxe.iso

How do I need to configure the menu.lst file to run the script LOAD.IPX successfully?

#31 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 29 September 2012 - 10:13 AM

Tried also the configuration below but no success ( Embedding via the command line method ) , ment lst entry :


title iPXE



kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe


Testing this method :


Booting command-list



Linux - zImage , setup=0x800 ....



iPXE initializing devices - sis 900_probe...

.

.

ok





iPXE 1.0.0+ (8e4faa) Open Source Network Boot Firmware



"&&" : no such network device

"chain" : no such network device

"http://192.168.0.200/winpe/boot.ipxe" : no such network device


Once again, the computer falls back to the network boot screen :


Intel UNDI, PXE - 2.0 ( build 082 )



CLIENT MAC ADDR ....


#32 mcb30

mcb30

    Newbie

  • Members
  • 22 posts
  •  
    United Kingdom

Posted 01 October 2012 - 11:30 AM


title iPXE

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe


Testing this method :

iPXE 1.0.0+ (8e4faa) Open Source Network Boot Firmware

"&&" : no such network device

"chain" : no such network device

"http://192.168.0.200/winpe/boot.ipxe" : no such network device


From the error message, it looks as though the backslashes (in "&&") are being passed through to iPXE, which won't work. Try instead:


title iPXE

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe


Michael

#33 mcb30

mcb30

    Newbie

  • Members
  • 22 posts
  •  
    United Kingdom

Posted 01 October 2012 - 11:31 AM

Just sent 3 versions to you. It is not only from checked builds that fail, but also previous or other versions. I think it is important to fix, because otherwise I suspect wimboot will fail with future versions of bootmgr.


@joakim

Thanks. I can reproduce the problem, and I'll get these working shortly.

Michael

#34 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 01 October 2012 - 01:53 PM

From the error message, it looks as though the backslashes (in "&&") are being passed through to iPXE, which won't work. Try instead:


title iPXE

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe


Michael


Hi Michael,

I tried the line below but it does not work :

title iPXE

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe


I get the error message message : Warning no such command chain.

Replacing && with && didn't work too.

#35 mcb30

mcb30

    Newbie

  • Members
  • 22 posts
  •  
    United Kingdom

Posted 01 October 2012 - 02:51 PM

I tried the line below but it does not work :


title iPXE

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe

I get the error message message : Warning no such command chain.


Is that error message coming from grub? iPXE's "no such command" error message would look something like:


chain: command not found


Michael

#36 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13600 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 October 2012 - 03:33 PM

I suspect that somehow you are "inventing" grub4dos syntax :ph34r:.
AFAICT this:

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe

means in grub4dos (PSEUDO CODE):
Load as kernel the file /IPXE.KRN passing to it the parameter "dhcp" ,and if this succeeds, then execute the command "chain" with parameter "http://192.168.0.200...inpe/boot.ipxe"

What is the "original" that you are trying to "translate" togrub4dos? :unsure:


:cheers:
Wonko

#37 mcb30

mcb30

    Newbie

  • Members
  • 22 posts
  •  
    United Kingdom

Posted 01 October 2012 - 03:40 PM

What is the "original" that you are trying to "translate" togrub4dos? :unsure:


The instruction to grub4dos should be:

Load and execute ipxe.lkrn, passing it the command line:

dhcp && chain http://192.168.0.200/winpe/boot.ipxe

Michael

Edited by mcb30, 01 October 2012 - 03:41 PM.


#38 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13600 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 October 2012 - 03:57 PM

Load and execute ipxe.lkrn, passing it the command line:


dhcp && chain http://192.168.0.200/winpe/boot.ipxe

Then the issue is to *somehow* "escape" the "&&" which in grub4dos is an operator meaning "do if previous succeeded". Cannot say how this can be done. :unsure:

Normally yes, it is the backslash to escape, but it isn't a "real" escape, see a few examples here:
http://www.rmprepusb...orials/grub4dos
\n is a separator, \r\n ,means "new line", etc.
Possibly Steve6375 is the one more familiar with this particular syntax.



:cheers:
Wonko

#39 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 01 October 2012 - 08:48 PM

Hi Michael,

It looks like that the error message is coming from grub4dos :


Booting iPXE



Linux - zImage , setup=0x800



Warning! No such command


Some seconds later, I can see the boot message of iPXE.

I dedided to test pxelinux.0 with Tftpd32. iPXE processed the line below and loaded the Win7PE components from the http server but I got a different error message :

kernel /IPXE.KRN dhcp && chain http://192.168.0.200/winpe/boot.ipxe


wimboot V1.00 -- Windows Imaging Format bootloader



Bad CPIO magic



FATAL : could not extract initrd files. Press a key to reboot



#40 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13600 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 October 2012 - 03:30 PM

These could work (in the sense that grub4dos should not parse the && as an operator:
kernel /IPXE.KRN "dhcp && chain http://192.168.0.200/winpe/boot.ipxe



kernel /IPXE.KRN "dhcp && chain http://192.168.0.200/winpe/boot.ipxe"


But then it depends on the way the IPXE.KRN parses the quoted string....

:cheers:
Wonko

#41 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 02 October 2012 - 07:00 PM

Hi Wonko,

Thanks for your help. I tried both of the options you proposed.

First test :

pxe keep

kernel /IPXE.LKRN "dhcp && chain http://192.168.0.200/winpe/boot.ipxe"

iPXE obtains an IP address after the dhcp command but strangely it tries to download pxelinux.0 from the address below. Once again, iPXE ignores the script file boot.ipxe. Removing the second double quote had no any effect, the result was the same.

http://releng.archli...boot/pxelinux.0

Error message :

could not boot http://releng.archlinux.org/pxeboot/boot/pxelinux.0 : Connection timed out

Second test :

After removing the line pxe keep, I got the error message displayed by iPXE :

"dhcp: command not found

Removing the second symbol " had no any effect, I received the same dhcp command not found message.

#42 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 02 October 2012 - 07:17 PM

grub4dos version = 0.4.5c 2012-06-19

#43 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 02 October 2012 - 07:18 PM

grub4dos version = 0.4.5c 2012-06-19

#44 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13600 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 October 2012 - 07:32 PM

Yep, what grub4dos passes is inside quotes, (or has a leading quote) evidently the IPXE.KRN does not support a parameter enclosed in quotes.
If you just run:
pxe keep

kernel /IPXE.LKRN

pxe keep

kernel /IPXE.LKRN "dhcp"
the result is the same, right?


I guess that the good guys developing ipxe should consider the idea of accepting a parameter enclosed in double quotes (i.e. strip them on the fly).

:cheers:
Wonko

#45 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 02 October 2012 - 08:03 PM

Hi Wonko,


pxe keep

kernel /IPXE.LKRN "dhcp"

iPXE receives an IP address but the error message is :

could not boot http://releng.archlinux.org/pxeboot/boot/pxelinux.0 : Connection timed out


pxe keep

kernel /IPXE.LKRN

The result is the same and I get the same Connection timed out message.


pxe keep
kernel /IPXE.LKRN "Vortex"

Same result. This means that the double quotes doesn't have any effect.

#46 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1679 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 03 October 2012 - 05:32 AM

Using grub4dos, I am trying to boot with the following menu.lst file configuration :

title iPXE3



pxe keep

kernel /IPXE.KRN

initrd /LOAD.IPX

That should work just fine.

LOAD.IPX : ( saved as UNIX text file )

#!ipxe

dhcp

chain http://192.168.0.200/winpe/boot.ipxe
grub4dos loads IPXE.KRN but LOAD.IPX is never processed and the computer falls back to the network boot screen.

Try getting rid of the space before #!ipxe It should start at the beginning of the line.

You can try to figure out why GRUB4DOS isn't passing the initrd to iPXE. It works for me. Try getting a GRUB4DOS CLI and entering the commands manually. Find out if the initrd command is working. You can also prove whether or not iPXE is getting the initrd by doing the following at the GRUB4DOS CLI:

kernel /ixpe.lkrn imgstat

initrd /load.ipxe

boot

Hopefully this helps you to follow along with the topic of mcb30's original post in this thread.

iPXE 1.0.0+ (09cc) -- Open Source Network Boot Firmware -- http://ipxe.org
Features: VLAN iSCSI HTTP DNS TFTP AoE SRP ELF MBOOT PXE bzImage Menu PXEXT
<INITRD> : 38 bytes



#47 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 232 posts

Posted 03 October 2012 - 07:28 AM

Hi Sha0,

Thanks for your help. The extra space character escaped from my attention. Removing it solved the problem :
pxe keep

kernel /IPXE.KRN

initrd /LOAD.IPX


#48 fuxxi

fuxxi

    Newbie

  • Members
  • 27 posts
  •  
    Germany

Posted 05 February 2013 - 08:06 AM

A short question related to booting winpe via http:

 

I used to use the following commandline from my syslinux config to boot my winpe iso:

 

kernel http://ip/grub.exe
APPEND initrd=http://ip/images/winpe.iso --config-file="map (rd)+1 (hd32); map --hook; root (32); chainloader (hd32)"

 

It worked well until grub.exe from February 2012. However with later versions from:

 

http://code.google.c.../downloads/list

 

this commandline fails. I tried several versions. It keeps going to the bash or is hanging at loading grub.exe

 

Is this a bug in all later grub4dos versions or does the commandline changed?

 

 

PS: As it wasnt mentioned here yet: to use wimboot directly through syslinux get the latest version of Syslinux (5.01) and wimboot (1.03), add this config to Your menu:

 

LABEL wimboot
MENU LABEL Http-WinPE-Booting via Syslinux using wimboot

COM32 linux.c32
APPEND wimboot initrdfile=winpe/bootmgr@bootmgr,winpe/boot/bcd@bcd,winpe/boot/boot.sdi@boot.sdi,winpe/sources/boot.wim@boot.wim



#49 bilou_gateux

bilou_gateux

    Frequent Member

  • Expert
  • 230 posts
  •  
    France

Posted 20 February 2013 - 11:33 AM

PS: As it wasnt mentioned here yet: to use wimboot directly through syslinux get the latest version of Syslinux (5.01) and wimboot (1.03), add this config to Your menu:

 

 

Thanks for the tip.

I switched from SYSLINUX 4.06 to SYSLINUX 5.01 to test wimboot successfully using your menu.

 

boot sequence [SYSLINUX 4.06]:

BIOS -> PXE ->  pxelinux.0 -> ipxe.lkrn

OK

BIOS -> PXE -> pxelinux.0 -> wimboot

fails

 

boot sequence [SYSLINUX 5.01]:

BIOS -> PXE -> pxelinux.0 -> wimboot

OK

BIOS -> PXE -> pxelinux.0 -> ipxe.lkrn

fails

 

LABEL conf
MENU LABEL ^conf
menu default
    KERNEL ipxe.lkrn
    INITRD conf.ipxe


#50 glitch

glitch
  • Members
  • 3 posts
  •  
    Denmark

Posted 27 March 2013 - 02:11 PM

Hi

 

I am having trouble booting with iPXE and wimboot kernal as showed down below I am keep getting these errors:

Bad CPIO magic and

FATAL: could not extract initrd files.

 

My boot.ipxe file is:

 

#!ipxe
boot
 
Maybe you can give me a hint how I can solve the problem?
 

foto.jpg







Also tagged with one or more of these keywords: http, winpe, ipxe, wimboot, ramdisk

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users