Jump to content

- - - - -

Dropbox autostart fails (probably because TEMP dir is not yet available)

  • Please log in to reply
3 replies to this topic

#1 besez

  • Members
  • 4 posts

Posted 12 September 2012 - 06:21 PM


I posted this question as a reply to another thread, but I figured it was probably better suited in its own thread.

When using the Task Scheduler method of creating an ImDisk RAMDisk I got the following problem:

* No RAMDisk was created at reboot
* When checking in Task Scheduler, my ImDisk task reports some error code e.g. Last Run Result = 0x8007051F
* When right clicking and manually selecting "Run" it worked...

So I found another method while googling for help
* Start gpedit.msc
* Edit the windows startup script to call a .bat with imdisk & TEMP directory creation.

I also set both the windows temp dirs to K:\TEMP (on the RAMDisk)

Now, I just have one problem:

Dropbox needs to access the windows TEMP dir quite early (I put it to the RAMDisk at K:\TEMP) - but when it tries to access it at startup (autostart) it says that it's not available!

If I try to restart dropbox manually a few seconds later, it works!

How can I make ImDisk start as EARLY as possible to avoid failing early access to TEMP directory?
And why is the Task Scheduler method failing me?

Information about my computer:
Core i7 gen3
16GB DDR3 1600MHz RAM
SSD system disk + HDD extra disk, both connected to intel 6Gbps SATA interface.
Windows 7
(my system boots VERY fast ~20s after POST, could that be related to the Task Scheduler method not working?)


#2 besez

  • Members
  • 4 posts

Posted 18 September 2012 - 08:52 PM

OK, so I solved this myself (the ugly way).

The .bat-script I use to start ImDisk and create the TEMP directory, now also starts dropbox.

I just turned off autostart in dropbox, and as I said the script I use to start ImDisk now also starts dropbox.

I wish there was a more elegant solution, though. If anyone finds a better one, please share!

For reference my script looks like this

imdisk -a -s 2000M -m K: -p "/fs:NTFS /q /y"


mkdir TEMP

label K: RAMDISK

C:Users<username>AppDataRoamingDropboxbinDropbox.exe /home

#3 Bad_Machine



  • Members
  • 13 posts
    United Kingdom

Posted 20 September 2012 - 02:58 PM

This is an issue I was unable to recreate on any of my systems. You can however slow down the loading priority of DropBox using Start-Q, this should give you enough time for the RAMdisk and the TEMP folder to be created, before DropBox tries to acces it. Get it here:


#4 besez

  • Members
  • 4 posts

Posted 20 September 2012 - 08:04 PM

@Bad_Machine My .bat-method is currently working for me, I was mainly wondering because I might run into similar problems with other programs in the future, and I want to be prepared =)

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users