Jump to content











- - - - -

Simple Script I've made is obviously missing something

win7pese

  • Please log in to reply
6 replies to this topic

#1 Guest_Boot_Monkey_*

Guest_Boot_Monkey_*
  • Guests

Posted 16 July 2012 - 08:41 AM

Hello All,

I'm trying to write a little script to drag in two DLLs so a program that needs them can run.

( I'm wanting for them to come from the Source DVD )

They are:
activeds.dll and adsldpc.dll.

So, far I've got

[main]

Title=My Dependancy Files

Description=Adds files that another silly program needs in order to run

Selected=True

Level=5

Version=1

[variables]

%ProgramTitle%=

%ProgramEXE%=

%ProgramFolder%=

[process]

Require_File,activeds.dll,,,PRESERVE,NOWARN

Require_File,adsldpc.dll,,,PRESERVE,NOWARN


This only works if I use the "Open Source Directory" and pop it in there manually. I was wondering how to get it to come from the Windows DVD during the normal copying process?

Edited by Boot_Monkey, 16 July 2012 - 09:03 AM.


#2 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12702 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 16 July 2012 - 11:29 AM

IMO the source *.WIMs are not mounted when you run the single script.

I reproduced in multiPE codebox.
Your code does not copy the files.
When I modify to

[main]
Title=My Dependancy Files
Description=Adds files that another silly program needs in order to run
Selected=True
Level=5
Version=1
[variables]
%ProgramTitle%=
%ProgramEXE%=
%ProgramFolder%=
[process]
Run,%ImageIndexScript%,CheckMountCD
Require_File,activeds.dll,,,PRESERVE,NOWARN
Require_File,adsldpc.dll,,,PRESERVE,NOWARN
Run,%ImageIndexScript%,CheckUnMountCD

it runs well.

Peter

#3 Guest_Boot_Monkey_*

Guest_Boot_Monkey_*
  • Guests

Posted 16 July 2012 - 11:34 PM

Oh thank you so much Peter,

Close but no cigar.

Getting errors now.


My.script My Silly Program

  File [%BaseDir%ProjectsWin7PESETZ_Process_LastMy.script] Version



Run - Failed to find section [CheckMountCD] in file: [%ImageIndexScript%]

Halt

  My Silly Program

  Script time: 130 milliseconds

  Script has been sucessfully processed!




Might need to place it higher in the run.

Update: Definately doesn't work. Not sure what is going on. In the interim, I'm using the "Additional Files" script

#4 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12702 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 17 July 2012 - 08:21 AM

Sorry, you misunderstood me.

I proofed in the multiPE project, that your code works when the sourceCD is mounted.
[CheckMountCD] in [%ImageIndexScript%]
are defined in multiPE.

Unfortunatelly you cannot use the multiPE functionality in a WIN7PE environment.

You hve to mount / unmount with the tools your project offers.
Because I do not know Win7PE, I cannot tell you the HowTo.

Peter

#5 Guest_Boot_Monkey_*

Guest_Boot_Monkey_*
  • Guests

Posted 17 July 2012 - 08:27 AM

That's ok Pete.

Thanks for explaining it. Gives me something to think about. :book:

#6 sbaeder

sbaeder

    Gold Member

  • .script developer
  • 1338 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 18 July 2012 - 05:35 AM

As Peter said, you need to do it in a place in the processing where things are "mounted" or still available (like having the "source" expanded.

If it doesn't need to be a script, there are already some places in theproject to add extra files to be copied. If you really want a separate script, make sure it is named, placed in the right place and has the right level to run as a part of the "build" after the script that copies the other main files. Then work from there.

:cheers:
Scott

#7 Guest_Boot_Monkey_*

Guest_Boot_Monkey_*
  • Guests

Posted 18 July 2012 - 05:46 AM

Nice. Thanks. All makes sense.





Also tagged with one or more of these keywords: win7pese

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users