Jump to content











Photo

Updating your isostick's firmware


  • Please log in to reply
3 replies to this topic

#1 elegantinvention

elegantinvention

    Frequent Member

  • Developer
  • 310 posts
  • Location:South Bend, Indiana, USA
  •  
    United States

Posted 15 July 2012 - 06:33 PM

Posted Image
isostick firmware updater by eric.agan, on Flickr

Updater downloads:
Windows (32-bit)
Windows (64-bit)
MacOS X
Linux
[Known issue: There is a compatibility bug with Ubuntu 10.04 x64 and possibly other linux distros because of the libc version the isostick updater was compiled with. I'm working on this, until it is fixed you may need to locate another machine or use a VM to perform firmware updates.]

Usage overview:
First, use a paper clip to press the reset button on the bottom of your isostick. The isostick must be plugged in when you do this. Note that hardly any force is required to activate the switch.
Your isostick should now be in bootloader mode.

Now run the firmware updater.
On Windows and MacOS X the isostick bootloader should be automatically selected.
Linux users will have to select it manually; it is usually called ttyACM0 or similar. Note also that, depending on your particular setup, you may need to execute the updater as root to access the port. I apologize for any inconvenience. You can verify your selection by pressing Get Info.

If the updater has not automatically retrieved your Service Code and highlighted your installed firmware (shown above), press Get Info.

If the Service Code was retrieved but the firmware list remains empty, try refreshing the firmware list by pressing the green Refresh button. The firmware list is fetched from isostick.com; if you require a proxy to reach the internet, press the Network Settings button (the gear icon) to configure one.


To update to a particular firmware, simply select it in the list then click Apply Update.
On rare occasion the Apply Update button doesn't enable when you select a firmware. Just select another one, then select the desired firmware again and the button will enable.

If an update fails: DON'T PANIC :good:
The isostick will remain in bootloader mode until it has valid firmware. You may power cycle it, move it between machines, etc. There is no harm in leaving it in this state indefinitely, and the bootloader is protected from being overwritten even in a worst-case failure.

General Info:
Each firmware update has a brief summary of changes. Hovering the mouse over an update will show full release notes.

Note also that you are always free to apply any firmware you wish -- if a new firmware is giving you trouble, you can always revert to an old one until a fix is released.

It's also worth pointing out that if your isostick ever has a catastrophic failure (firmware crash, et al.), it will drop into bootloader mode. If this ever happens, you should run the updater to see if new firmware is available, as it may solve whatever caused the crash.

In some cases the updater may not recover properly from a timeout, especially on Windows. If this happens, close the updater and run it again. If the problem persists, try power cycling the isostick and make sure that the old process isn't hanging around (Task Manager on Windows, Activity Monitor on MacOS X, ps on linux).

If you have any issues, please contact support@isostick.com and include your Service Code if possible.
  • Nuno Brito likes this

#2 Chris Weiss

Chris Weiss

    Newbie

  • Members
  • 15 posts
  •  
    United States

Posted 13 August 2012 - 07:20 PM

The updater does not run on Ubuntu 10.04LTS.


$ sudo ./isostick-updater

./isostick-updater: /lib32/libc.so.6: version `GLIBC_2.15' not found (required by ./isostick-updater)



ls -l /lib32/libc.so.6

lrwxrwxrwx 1 root root 14 2012-03-09 07:57 /lib32/libc.so.6 -> libc-2.11.1.so



#3 elegantinvention

elegantinvention

    Frequent Member

  • Developer
  • 310 posts
  • Location:South Bend, Indiana, USA
  •  
    United States

Posted 13 August 2012 - 10:59 PM

@Chris Weiss, Thanks, I've added a note to the original post, and opened a case in our bug tracker.

#4 scott3091

scott3091
  • Members
  • 6 posts
  •  
    United States

Posted 15 September 2012 - 04:45 PM

I finally made the time to upgrade from Linux Mint 12 to Linux Mint 13, and now I'm able to use the updater from Linux.

Here are a couple notes that might be worth mentioning:

1. Make the file executable: chmod +x ./isostick-updater
2. If you're new to Linux, you might not know that isostick-updater is not the same as ./isostick-updater. Use: ./isostick-updater
3. If you're not sure which device to select from the list, go to a terminal window and try this: dmesg|grep tty|tail -n1
4. If ./isostick-updater doesn't work, and you're on a 64-bit machine, you should try: sudo apt-get install ia32-libs libglib2.0-dev
5. If you're not sure if you're running a 32-bit or 64-bit installation, try this:


Type: uname -a

Linux 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:52:48 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

If you see 64 in the response, it's probably 64-bit; if it says i386 or i686, that's 32-bit.

Dev - Can you make the program use dmesg or grep /var/log/syslog to try and guess which device we just plugged in when the app first runs? That might make it a little easier for some people.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users