Jump to content











Photo
- - - - -

Multiboot XP-Win7-Hiren Boot

multiboot boot xp win7 hiren

  • Please log in to reply
29 replies to this topic

#1 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 06 June 2012 - 06:28 AM

Hello

I'm trying to make a MultiBoot USB with Windows XP, Windows 7 and Hiren's Boot Cd


I made it with Grub4Dos and Firadisk loading ISO's directly.


But the WinXp installation failed, and Win7 installation was very slowly.

Now i'm trying to make it extracting the ISO to make the installation faster, but i don't know how to do it.


Thanks in advance

#2 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 June 2012 - 06:52 AM

For a USB Flash drive see www.rmprepusb.com. Tutorial #63 and add to it Tutorial #36.

#3 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 06 June 2012 - 07:23 AM

Thanks in advance

The ISO Load using Firadisk worked great


I will try what you said and i will post the result


Nice to meet you, and thanks for your tutorials

#4 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 06 June 2012 - 08:36 AM

Hi again

I followed all the steps of #63 tutorial and i got these errors:

On winXP

error copying winblock and firadisk after selecting those drivers
can't find OEMbinun7zip.exe after beginning the 2nd step of the installatin

On WIn7

Warning SOURCEINSTALL.WIN not found



¿Is there a way to do this extracting the iso directly on the USB drive?


Thanks

Edited by dagonas, 06 June 2012 - 08:38 AM.


#5 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 June 2012 - 08:55 AM

Did you use an MS source ISO or a 'special' one of your own?
The tutorials are for MS install ISOs.
You can simply extract the Win 7 source DVD and then use a grub4dos menu to boot to chainloader /bootmgr.

Are you trying to run Win 7 and XP from a USB Flash drive or install Win 7 and XP from a USB flash drive?

#6 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 06 June 2012 - 09:00 AM

It's a special ISO...

I want to make an USB for installing XP or Windows 7


I will try extracting the ISO, but what do i have to do for WinXp?


Thanks again

#7 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 June 2012 - 09:42 AM

Try running WinSetupFromUSB and then transferring the files over to your multiboot stick.

#8 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 06 June 2012 - 11:44 AM

It seems it works

I will try doing a complete installation of each one this afternoon

I'll tell you the result

Thanks again for your help

#9 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 06 June 2012 - 07:49 PM

Hi again

I'm getting an error installing forn WinSetup with Windows 7 and Windows Xp


Is there a way to start the installation with Grub4dos?

Thank you

#10 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 June 2012 - 09:14 PM

What error?
Did you test your USB drive using RMPrepUSB Quick Size Test? It may be faulty?

#11 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 07 June 2012 - 07:38 AM

Hello again

I'm going to tell you the steps i have made:

1) Winsetupfromusb with options:
Auto format it with Fbinst, NTFS, Align

Section "Add to USB DISK"

Windows 2000/XP/2003 Setup Checked and the correct drive with an iso mounted inside the textbox

Windows Vista / 7 ... Setup Checked and the correct drive with an iso mounted inside the textbox

2) Start the process

3) Try each installation

a) On Windows XP, when i started the second part of the installation it get hanged when the installation said "39 minutes left"

B) On Windows 7, it get hanged when the installation reached the Blue Screen of the installation beginning.



It seems WinSetupfromUSB have a problem detecting the USB pendrive


Is there another way to do this Multiboot?

#12 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 07 June 2012 - 07:41 AM

What system are you testing it on and what USB port (USB 2 or 3) are you using?
Did you try QEMU for Win 7 boot?

#13 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 07 June 2012 - 08:03 AM

Yes, i tried the QEMU and worked

It takes a long time to show the screen on the computer where i inserted the USB

It's a USB 2.0 port

#14 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 07 June 2012 - 09:36 AM

So what system are you testing it on? Does it have SATA drives, what chipset, what mainboard, etc.

#15 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 07 June 2012 - 09:54 AM

I have tried it on different system

The Win7 installation started a hour ago and now is on 77% expanding files

So it is going VERY slowly

The system is:

Mainboard: MSI N1996
Chipset: VIA
Hardisk: SATA

But yesterday i tried it on a different system with a PATA hard disk

Edited by dagonas, 07 June 2012 - 09:56 AM.


#16 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 07 June 2012 - 11:27 PM

Hi again

what about this method?

https://sites.google...and-server-2008

do you think it may help?

THANKS

#17 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 08 June 2012 - 06:56 AM

I think the problem is that the first system has a strange mass storage controller and the 2nd one has slow USB ports.
MSI N1996 is not the board name, all MSI boards have MSI N1996 on them - the name should be something like MS-6359.
Did you test your USB drive with RMPrepUSB Quick Size Test?
For XP set the BIOS HDD mode to IDE not AHCI.

#18 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 08 June 2012 - 05:02 PM

I have tried another source and all went ok.

Now i'm thinking about how may i put two different sources of Windows XP (one clean and another modified) to install one or other depending on the situation

Do you know how can i do that?


Thanks

#19 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 08 June 2012 - 07:00 PM

Well you can have two ISOs, but if one is modified it might not work in the same way. I can't really help with the modified one...

#20 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 08 June 2012 - 07:09 PM

But Installing from ISO is too slow

#21 Mah Moua

Mah Moua
  • Members
  • 1 posts
  •  
    Belgium

Posted 08 June 2012 - 09:20 PM

The easiest is to boot hiren from grub4dos
mount the iso (xp or 7) with eg imdisk
There are 2 "fast" installers under programs/others in hiren's menu one for xp (winntsetup)
and another for win6/7 (nt6.x fast installer)

If you want to install xp directly from iso use winvblock. Make the iso file contigious with wincontig
You can copy the xp iso (as one file) to your hard disk first. The installation is much faster
Win7 directly from iso is difficult

Below are the menu.lst enteries for xp with winvblock usb

title Install Windows XP from iso with winvblock
find --set-root --ignore-floppies /xpsp3.iso
map /winvblock.ima (fd0)
map /winvblock.ima (fd1)
map /xpsp3.iso (0xff)
checkrange 0x80 read 0x8280 && map (hd0) (hd1)
checkrange 0x80 read 0x8280 && map (hd1) (hd0)
map --hook
chainloader (0xff)

title Continue Windows XP setup with winvblock
find --set-root --ignore-floppies /xpsp3.iso
map /winvblock.ima (fd0)
map /winvblock.ima (fd1)
map /xpsp3.iso (0xff)
checkrange 0x80 read 0x8280 && map (hd0) (hd1)
checkrange 0x80 read 0x8280 && map (hd1) (hd0)
map --hook
chainloader (hd0)+1

#22 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 11 June 2012 - 08:06 AM

Thanks, Mah Moua. I will try what you said.

Steve, i'm getting the Stop error 0x0000007B so as i read in your Tutorial, i have to include the AHCI driver.

http://www.rmprepusb...-xp-from-an-iso


What do i have to do if i have this folder structure?


Posted Image


And the file menu.lst


title Windows XP/2000/2003 Setup

map --unmap=0:0xff

map --unhook

savedefault

ls /usbdrive.tag || find --set-root --ignore-cd /usbdrive.tag

configfile /winsetup.lst

title Start Vista/Win7/Server 2008 Setup or PE/Recovery ISO from partition 0

map --unmap=0:0xff

map --unhook

root (hd0,0)

chainloader /bootmgr



and Winsetup.lst



color black/cyan yellow/cyan

timeout 10

default /windefault

title Back to Main Menu

configfile /menu.lst



title First part of Windows XP Professional SP3 setup from partition 0

map --unmap=0:0xff

map --unhook

ls /WINSETUP/XPpSP3.ISO || find --set-root --ignore-cd /WINSETUP/XPpSP3.ISO

map /WINSETUP/XPpSP3.ISO (0xff) || map --mem /WINSETUP/XPpSP3.ISO (0xff)

savedefault 2

checkrange 0x00,0x01 read 0x8280 && configfile /BOOTWS/fd.lst

checkrange 8 calc *0x475 & 0xFF && configfile /BOOTWS/8.lst

checkrange 7 calc *0x475 & 0xFF && configfile /BOOTWS/7.lst

checkrange 6 calc *0x475 & 0xFF && configfile /BOOTWS/6.lst

checkrange 5 calc *0x475 & 0xFF && configfile /BOOTWS/5.lst

checkrange 4 calc *0x475 & 0xFF && configfile /BOOTWS/4.lst

checkrange 3 calc *0x475 & 0xFF && configfile /BOOTWS/3.lst

checkrange 2 calc *0x475 & 0xFF && configfile /BOOTWS/2.lst

checkrange 1 calc *0x475 & 0xFF && configfile /BOOTWS/1.lst

boot

map --unmap=0:0xff

map --unhook

title Second part of 2000/XP/2003 setup / Boot first internal hard disk

checkrange 8 calc *0x475 & 0xFF && configfile /BOOTWS/8.lst

checkrange 7 calc *0x475 & 0xFF && configfile /BOOTWS/7.lst

checkrange 6 calc *0x475 & 0xFF && configfile /BOOTWS/6.lst

checkrange 5 calc *0x475 & 0xFF && configfile /BOOTWS/5.lst

checkrange 4 calc *0x475 & 0xFF && configfile /BOOTWS/4.lst

checkrange 3 calc *0x475 & 0xFF && configfile /BOOTWS/3.lst

checkrange 2 calc *0x475 & 0xFF && configfile /BOOTWS/2.lst

checkrange 1 calc *0x475 & 0xFF && configfile /BOOTWS/1.lst

boot



Thanks, again



The easiest is to boot hiren from grub4dos
mount the iso (xp or 7) with eg imdisk
There are 2 "fast" installers under programs/others in hiren's menu one for xp (winntsetup)
and another for win6/7 (nt6.x fast installer)

If you want to install xp directly from iso use winvblock. Make the iso file contigious with wincontig
You can copy the xp iso (as one file) to your hard disk first. The installation is much faster
Win7 directly from iso is difficult

Below are the menu.lst enteries for xp with winvblock usb

title Install Windows XP from iso with winvblock
find --set-root --ignore-floppies /xpsp3.iso
map /winvblock.ima (fd0)
map /winvblock.ima (fd1)
map /xpsp3.iso (0xff)
checkrange 0x80 read 0x8280 && map (hd0) (hd1)
checkrange 0x80 read 0x8280 && map (hd1) (hd0)
map --hook
chainloader (0xff)

title Continue Windows XP setup with winvblock
find --set-root --ignore-floppies /xpsp3.iso
map /winvblock.ima (fd0)
map /winvblock.ima (fd1)
map /xpsp3.iso (0xff)
checkrange 0x80 read 0x8280 && map (hd0) (hd1)
checkrange 0x80 read 0x8280 && map (hd1) (hd0)
map --hook
chainloader (hd0)+1



#23 dagonas

dagonas

    Newbie

  • Members
  • 18 posts
  •  
    Spain

Posted 15 June 2012 - 10:56 AM

Hi again

I'm testing how to add a XP F6 installation driver for my SATA old computer

I done this:


; Copyright (c) 2003-10 Intel Corporation

;#############################################################################

;#

;#    Filename:  TXTSETUP.OEM

;#

;#############################################################################

[Disks]

disk1 = "Intel(R) Rapid Storage Technology Driver", iaStor.sys, 

diskf="FiraDisk Installation Disk",firadisk.inf,

disk = "WinVBlock Driver Disk",WinVBlk.inf,



[Defaults]

#scsi = iaStor_Mobile

#SCSI=firadisk

scsi = firadisk

#scsi = WINVBLOCK32



;#############################################################################

[scsi]

Default = "Choose Firadisk (or WinvBlock), then press S then choose your SATA driver"

firadisk="FiraDisk Driver (32-bit)"

firadisk64="FiraDisk Driver (64-bit)"

WinVBlock32 = "WinVBlock Bus (32-bit)"

WinVBlock64 = "WinVBlock Bus (64-bit)"





; iaAHCI.inf

iaAHCI_7RDH					 = "Intel(R) ICH7R/DH SATA AHCI Controller"

iaAHCI_ESB2					 = "Intel(R) ESB2 SATA AHCI Controller"

iaAHCI_7MMDH				    = "Intel(R) ICH7M/MDH SATA AHCI Controller"

iaAHCI_8RDHDO				   = "Intel(R) ICH8R/DH/DO SATA AHCI Controller"

iaAHCI_8MEM					 = "Intel(R) ICH8M-E/M SATA AHCI Controller"

iaAHCI_9RDODH				   = "Intel(R) ICH9R/DO/DH SATA AHCI Controller"

iaAHCI_9MEM					 = "Intel(R) ICH9M-E/M SATA AHCI Controller"

iaAHCI_10DDO				    = "Intel(R) ICH10D/DO SATA AHCI Controller"

iaAHCI_10R					  = "Intel(R) ICH10R SATA AHCI Controller"

iaAHCI_5					    = "Intel(R) 5 Series 4 Port SATA AHCI Controller"

iaAHCI_5_1					  = "Intel(R) 5 Series 6 Port SATA AHCI Controller"

iaAHCI_5_1_1				    = "Intel(R) 5 Series/3400 Series SATA AHCI Controller"

iaAHCI_DesktopWorkstationServer = "Intel(R) Desktop/Workstation/Server Express Chipset

SATA AHCI Controller"

iaAHCI_Mobile				   = "Intel(R) Mobile Express Chipset SATA AHCI

Controller"

iaAHCI_ICH7R = "Intel(R) 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)"

iaAHCI_ICH6R = "Intel(R) 82801FR SATA AHCI Controller (Desktop ICH6R)"

iaAHCI_ICH6M = "Intel(R) 82801FBM SATA AHCI Controller (Mobile  ICH6M)"



; iaStor.inf

iaStor_ESB2					 = "Intel(R) ESB2 SATA RAID Controller"

iaStor_7RDH					 = "Intel(R) ICH7R/DH SATA RAID Controller"

iaStor_7MDH					 = "Intel(R) ICH7MDH SATA RAID Controller"

iaStor_DesktopWorkstationServer = "Intel(R) Desktop/Workstation/Server Express Chipset

SATA RAID Controller"

iaStor_Mobile				   = "Intel(R) Mobile Express Chipset SATA RAID

Controller"

iaStor_ICH7DH = "Intel(R) 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)"

iaStor_ICH6R = "Intel(R) 82801FR SATA RAID Controller (Desktop ICH6R)"

iaStor_ICH5R = "Intel(R) 82801ER SATA RAID Controller (Desktop ICH5R)"

iaStor_ICH5RHR = "Intel(R) 6300ESB SATA RAID Controller"



;#############################################################################

; iaAHCI.inf

[Files.scsi.iaAHCI_ESB2]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_7RDH]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_7MMDH]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_8RDHDO]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_8MEM]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_9RDODH]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_9MEM]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_10DDO]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_10R]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_5]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_5_1]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_5_1_1]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_DesktopWorkstationServer]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_Mobile]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaStor_ICH7DH]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaAHCI_ICH7R]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaStor_ICH6R]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaAHCI_ICH6R]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaAHCI_ICH6M]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaAHCI.inf

catalog = disk1, iaAHCI.cat

[Files.scsi.iaStor_ICH5R]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaStor_ICH5RHR]

driver = disk1, iaStor.sys, iaStor

inf    = disk1, iaStor.inf

catalog = disk1, iaStor.cat



; iaStor.inf

[Files.scsi.iaStor_ESB2]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaStor_7RDH]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaStor_7MDH]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaStor_DesktopWorkstationServer]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaStor.inf

catalog = disk1, iaStor.cat

[Files.scsi.iaStor_Mobile]

driver = disk1, iaStor.sys, iaStor

inf = disk1, iaStor.inf

catalog = disk1, iaStor.cat



;#############################################################################

[Config.iaStor]

value = "", tag, REG_DWORD, 1b

value = "", ErrorControl, REG_DWORD, 1

value = "", Group, REG_SZ, "SCSI Miniport"

value = "", Start, REG_DWORD, 0

value = "", Type, REG_DWORD, 1

;#############################################################################

; iaAHCI.inf

[HardwareIds.scsi.iaAHCI_ESB2]

id = "PCIVEN_8086&DEV_2681&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_7RDH]

id = "PCIVEN_8086&DEV_27C1&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_7MMDH]

id = "PCIVEN_8086&DEV_27C5&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_8RDHDO]

id = "PCIVEN_8086&DEV_2821&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_8MEM]

id = "PCIVEN_8086&DEV_2829&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_9RDODH]

id = "PCIVEN_8086&DEV_2922&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_9MEM]

id = "PCIVEN_8086&DEV_2929&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_10DDO]

id = "PCIVEN_8086&DEV_3A02&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_10R]

id = "PCIVEN_8086&DEV_3A22&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_5]

id = "PCIVEN_8086&DEV_3B29&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_5_1]

id = "PCIVEN_8086&DEV_3B2F&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_5_1_1]

id = "PCIVEN_8086&DEV_3B22&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_DesktopWorkstationServer]

id = "PCIVEN_8086&DEV_1C02&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_Mobile]

id = "PCIVEN_8086&DEV_1C03&CC_0106","iaStor"



; iaStor.inf

[HardwareIds.scsi.iaStor_ESB2]

id = "PCIVEN_8086&DEV_2682&CC_0104","iaStor"

[HardwareIds.scsi.iaStor_7RDH]

id = "PCIVEN_8086&DEV_27C3&CC_0104","iaStor"

[HardwareIds.scsi.iaStor_7MDH]

id = "PCIVEN_8086&DEV_27C6&CC_0104","iaStor"

[HardwareIds.scsi.iaStor_DesktopWorkstationServer]

id = "PCIVEN_8086&DEV_2822&CC_0104","iaStor"

[HardwareIds.scsi.iaStor_Mobile]

id = "PCIVEN_8086&DEV_282A&CC_0104","iaStor"

[Files.scsi.firadisk]

driver=diskf,firadisk.sys,firadisk

inf=diskf,firadisk.inf

catalog=diskf,firadisk.cat

[Config.firadisk]

[HardwareIds.scsi.firadisk]

id="detectedfiradisk","firadisk"

[Files.scsi.WinVBlock32]

driver = disk,WVBlk32.Sys,WinVBlock

inf = disk,WinVBlk.Inf

catalog = disk,WinVBlk.Cat

[Files.scsi.firadisk64]

driver=disk1,firadi64.sys,firadisk

inf=disk1,firadisk.inf

catalog=disk1,firadisk.cat

[Config.firadisk64]

[HardwareIds.scsi.firadisk]

id="detectedfiradisk","firadisk"



[Files.scsi.WinVBlock64]

driver = disk,WVBlk64.Sys,WinVBlock

inf = disk,WinVBlk.Inf

catalog = disk,WinVBlk.Cat



[Config.WinVBlock]

value="",TxtSetupInstalled,REG_DWORD,1



[HardwareIds.scsi.WinVBlock32]

id="ROOTWINVBLOCK","WinVBlock"

id="DetectedWinVBlock","WinVBlock"



[HardwareIds.scsi.WinVBlock64]

id="ROOTWINVBLOCK","WinVBlock"

id="DetectedWinVBlock","WinVBlock"

[HardwareIds.scsi.iaStor_ICH7DH]

id = "PCIVEN_8086&DEV_27C3&CC_0104","iaStor"

[HardwareIds.scsi.iaAHCI_ICH7R]

id = "PCIVEN_8086&DEV_27C1&CC_0106","iaStor"

[HardwareIds.scsi.iaStor_ICH6R]

id = "PCIVEN_8086&DEV_2652&CC_0104","iaStor"

[HardwareIds.scsi.iaAHCI_ICH6R]

id = "PCIVEN_8086&DEV_2652&CC_0106","iaStor"

[HardwareIds.scsi.iaAHCI_ICH6M]

id = "PCIVEN_8086&DEV_2653&CC_0106","iaStor"

[HardwareIds.scsi.iaStor_ICH5R]

id = "PCIVEN_8086&DEV_24DF&CC_0104","iaStor"

[HardwareIds.scsi.iaStor_ICH5RHR]

id = "PCIVEN_8086&DEV_25B0&CC_0104","iaStor"




I opened the winvblock.ima, followed the Steve instructions and then put all the driver downloaded driver into the winvblock ima file.

It told me to overwrite iaStor.sys and other files ¿is it ok?


The motherboard driver is :


ASROCK CONROE 865PE
VENDOR=8086 DEVICE=24D1
ICH5

I can't find that driver, but i'll try with this one:

http://devid.info/es/27749

Thanks again

#24 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 15 June 2012 - 11:25 AM

If 24D1 is not in the INF file then it probably won't work. Try adding extra lines by copying an existing section and changing the PCI ID tp 8086 24D1.
As for overwriting files, I would always use the newest version of the .sys file but it may not work! You can always make one floppy image for the 865 system, and use a different floppy image for other systems if you make a separate menu entry in the grub4dos menu.

#25 cdob

cdob

    Gold Member

  • Expert
  • 1342 posts

Posted 15 June 2012 - 03:42 PM

VENDOR=8086 DEVICE=24D1
ICH5

That's IDE emulation mode, that's NOT AHCI mode.
There is no need to include iastor.sys.

Read instructions again and try custom ntdetect.com.





Also tagged with one or more of these keywords: multiboot, boot, xp, win7, hiren

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users