Jump to content











Photo
- - - - -

RegWriteBin - Type not recognized: Type: [0x3E7]


  • Please log in to reply
9 replies to this topic

#1 Filip Hasa

Filip Hasa

    Frequent Member

  • Advanced user
  • 408 posts

Posted 30 May 2012 - 02:29 PM

Hi guys,

i have problem i converted reg file to script by reg2WBS 4.3.0 And this line:

RegWriteBin,HKLM,0x3E7,%reg%\Classes\Installer\Win32Assemblies\Global,"Microsoft.VC80.CRT,version=\"8.0.50727.762\",publicKeyToken=\"1fc8b3b9a1e18e3b\",type=\"win32\",processorArchitecture=\"x86",38,78,45,74,79,74,2e,47,63,41,6b,60,2b,44,44,63,31,77,74,41,43,6c,69,65,6e,74,3e,5f,6a,30,2c,59,5d,73,21,53,6f,65,38,4d,6b,62,49,64,46,77,55,00,00,

give me this error
RegWriteBin - Type not recognized: Type: [0x3E7] Section [HKLM\wb-hive\Classes\Installer\Win32Assemblies\Global] Key [Microsoft.VC80.CRT,version=\"8.0.50727.762\]:

I use WinBuilder 82.

Any idea?

Thanks

filip
  • Nuno Brito likes this

#2 paraglider

paraglider

    Gold Member

  • .script developer
  • 1728 posts
  • Location:NC,USA
  •  
    United States

Posted 30 May 2012 - 02:52 PM

0x3e7 as reported is an invalid type. Try 0x7. See:

http://code.google.c...iki/regwritebin

for details.

#3 Filip Hasa

Filip Hasa

    Frequent Member

  • Advanced user
  • 408 posts

Posted 30 May 2012 - 02:59 PM

Thank you for tip.

I had to use new version reg2WBS.

I receive:

RegWriteBinEx,HKLM,0x3E7,%reg%ClassesInstallerWin32AssembliesGlobal,"Microsoft.VC80.CRT,version="8.0.50727.762",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",processorArchitecture="x86",38,78,45,74,79,74,2e,47,63,41,6b,60,2b,44,44,63,31,77,74,41,43,6c,69,65,6e,74,3e,5f,6a,30,2c,59,5d,73,21,53,6f,65,38,4d,6b,62,49,64,46,77,55,00,00,

Thank you for fast repond

#4 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 01 June 2012 - 04:05 PM

0x3E7 is never a registry type.
To write this "Type" into registry IMO does not bring the wanted result.

IMO it is an error Reg2WBs got and misunderpreted. There seems to be a bug in Reg2WBs.

#define ERROR_SWAPERROR 999L


Can you send me the *.reg producing the issue?

Peter

#5 Filip Hasa

Filip Hasa

    Frequent Member

  • Advanced user
  • 408 posts

Posted 01 June 2012 - 07:01 PM

hi petr,

here it is.

thank you

Attached Files



#6 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 01 June 2012 - 07:30 PM

Thanks, Dera. Filip Hasa :clap:

I saw the reason of the issue.
It is really something currently not provided in Reg2WBs, but propably it will take some time to fix ...

Peter

Sorry, Filip Hasa for the wrong "Thanks".
I confused this topic with a different one I was working on, a minute before.
I edited the post to correct.

Edited by pscEx, 01 June 2012 - 07:49 PM.
Corrected thanks receiver


#7 Filip Hasa

Filip Hasa

    Frequent Member

  • Advanced user
  • 408 posts

Posted 01 June 2012 - 09:34 PM

Thanks, Dera. Filip Hasa :clap:

I saw the reason of the issue.
It is really something currently not provided in Reg2WBs, but propably it will take some time to fix ...

Peter

Sorry, Filip Hasa for the wrong "Thanks".
I confused this topic with a different one I was working on, a minute before.
I edited the post to correct.


Hi Peter,

I wanted ask what "Dera" means?! ;o) It is fine.http://www.acronymfinder.com/DERA.html ;o)

I am waiting for bug fix ;)

Thank you peter

#8 ChrisR

ChrisR

    Silver Member

  • .script developer
  • 784 posts
  •  
    France

Posted 02 June 2012 - 11:35 AM

In my Win7 host, I have a Shlash in addition for \"x86\"

And by changing

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Win32Assemblies\Global]
"Microsoft.VC80.CRT,version=\"8.0.50727.762\",publicKeyToken=\"1fc8b3b9a1e18e3b\",type=\"win32\",processorArchitecture=\"x86""=hex(7):
==>
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Win32Assemblies\Global]
"Microsoft.VC80.CRT,version=\"8.0.50727.762\",publicKeyToken=\"1fc8b3b9a1e18e3b\",type=\"win32\",processorArchitecture=\"x86\""=hex(7):


It seems to work better with RegCPE or reg2WBS.

:cheers:

#9 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 02 June 2012 - 12:15 PM

Thanks ChrisR :cheers:

I already tried to replace the " w/o success.

The real issue seems to be that WinBuilder has difficulties with commas in the key name.
I'm working on Reg2WBS writing #$c instead of commas here.

Peter

#10 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 02 June 2012 - 01:08 PM

I uploaded version 4.4.1 of Reg2WBS.

It fixed handling of commas inside registry key names.
Thanks again to Filip Hasa for report and example registry entries.

Peter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users