Jump to content











Photo

Parted Magic 6.1 not working


  • Please log in to reply
5 replies to this topic

#1 neopath

neopath

  • Members
  • 9 posts
  •  
    Canada

Posted 20 May 2012 - 01:44 PM

Hey guys,

When I try to start Linux based rescue environment (parted magic 6.7) from Hiren's menu (15.1) I get this error:

-------------------------------

find --set-root %pm%

Error 27: Unrecognized command

Press any key to continue

-------------------------------

Which looks suspiciously like the removal of MiniXP "error". Is that the case or am I missing something? I figured that if I can't get it to work I might as well remove the entry in the menu, so I tried uncheking the "parted magic" box in the "bootable tools" section but it still appears in the HBCD menu.

Also, I haven't been able to integrate the "windows tools" part of the HBCD into Win7PE_SE for a while now. I guess I did something stupid and removed some folder somewhere, but I've since created a fresh instance of Winbuilder (redownloaded everything and all.) in another folder and I still have this problem. The thing worked great for a while and then it just stopped working at all whatever I did.No desktop icon, no start menu icon, no nothing at all.So I guess my question is: Does winbuilder keeps it's settings somewhere else than in it's own folder(s)? This thing is portable, right?

Any insight on these would be appreciated.

Cheers!

Edit: Wrong post title. By "Parted Magic 6.1" I meant "Parted Magic 6.7".

Edited by neopath, 20 May 2012 - 01:47 PM.


#2 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 20 May 2012 - 09:04 PM

OK, so I "guess" you are using the script for "otherOS" that is in some other PE build (not even going to try to guess which one :dubbio: ) Best thing wouuld be to givee more details. But some things I am also "guessing"

1. you are using the grub4dos bootloader
2. It doesn't have anything to do with the miniXP, since that is a totally separate item to boot.
3. That is a pretty old version of parted magic...BUT if you want to use it (rather than the separate parted magic script), make sure you check the box for it so it won't be removed from the build (the default is to just add the basics of the HBCD, and remove a lot of the other tools, since there are better ways to keep them updated.

Best would be (especially if you are using win7PE_SE is to create a FULL DEBUG LOG and post it somewhere we can look at it to help you out.

:cheers:
Scott

#3 ChrisR

ChrisR

    Silver Member


  • .script developer
  • 784 posts
  •  
    France

Posted 20 May 2012 - 09:40 PM

Which looks suspiciously like the removal of MiniXP "error". Is that the case or am I missing something? I figured that if I can't get it to work I might as well remove the entry in the menu, so I tried uncheking the "parted magic" box in the "bootable tools" section but it still appears in the HBCD menu.


The HBCD script inside W7pese remove MiniXP and remove "parted magic" if the checkBox is not enabled (default). There is already an existing script for Pmagic.
By cons, the Hiren's menu is taken as is (difficult to remove these entries) and these entry does not work. You just have to know and use instead the "Parted Magic Linux" script.

for info pmagic 6.7 (old enough version) entry in HBCDmenu.lst

title Linux based rescue environment (Parted Magic 6.7)nTo manage partitions, backup and recovery

set pm=/HBCD/Boot/pmagic.lst

find --set-root %pm%

set lang=us

set opt=

configfile %pm%



#4 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 20 May 2012 - 10:10 PM

Just to emphasize what Chris said above

By cons, the Hiren's menu is taken as is (difficult to remove these entries) and these entry does not work. You just have to know and use instead the "Parted Magic Linux" script.

This applies to any part of the original "menu" that isn't included into the final build image...

#5 neopath

neopath

  • Members
  • 9 posts
  •  
    Canada

Posted 21 May 2012 - 05:09 AM

I just knew I was doing something stupid. I was using the "vanilla" Winbuilder 082 and used it to download the win7pe_se project. I downloaded Win7PE_SE_20120416 and... well.. That's more like it. :)

Still having an HBCD 15.1 problem though. The whole build stop with the message "Build stopped by script command" as soon as it gets to the OtherOS/hiren's 15.1 part. I tried letting it download/extract it (which it does). I tried manually directing it to the ISO file. Same result. The log file gives me this warning:

(Hirens Boot CD (for v 15.1 and possibly later))

Can't run from bootable WIM

I'm probably dead wrong but I thought maybe the script didn't like the Image configuration's "extracted wim folders" method I was using so I tried the other way (imagex I think). Same result...


What am I doing wrong?

#6 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 23 May 2012 - 05:18 PM

Best to capture the debug log and loat it to mediafire or other on-line place so we can look at all the settings...

Scott




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users